Please select Into the mobile phone version | Continue to access the computer ver.
P4 And the Dreaded Firmware Shuffle
764 0 2016-3-21
Uploading and Loding Picture ...(0/1)
Flight distance : 39695 ft
United States

I picked up my P4 from the local FedEx office this morning - ordered directly from DJI on March 3 - very happy with the timing and shipment - no problems.  I also ordered one extra battery and set of props - this all came in the same shipment.  The packaging was very professional.

Being a previous P2V+ and P3A owner who has been through the development phases of the myriad of software & firmware releases, I expected to spend a little time with the required firmware updates to the RC and the P4.  In anticipation of this, I downloaded the DJI Assistant App v2 for both Mac OS and for Windows 10 (I run Parallels 11 on my i7 iMac).

After unboxing the P4 I first attempted to install the latest (0288) firmware using the Mac OS Assistant.  It downloaded the firmware files (100% downloaded) in a few minutes, but when it then tried to perform the install via USB to the P4 it would fail. Reboot, reboot, unplug, yadda, yadda.... it would always fail.  So.... over to Window 10 and the Assistant app - it was failing before the firmware files were 100% downloaded (usually only made it to 25% downloaded).  Same thing - failed every time no matter what.  So....

On to the IOS swapping-usb cable procedure - which worked just fine and dandy.  So - if you fail using the PC/Mac USB - Assistant App method, then try the direct method using your tablet.  I would like to see the Assistant app worked on a bit more - it does have potential, but it did not work for me.

As for the P4 - I had a few minutes of daylight left and that thing is amazing.  I'm really looking forward to some really great photo/video opportunities with it.  

P4 Sunset (touched)

P4 Sunset (touched)
Use props
You need to log in before you can reply Login | Register now

Credit Rules