Please select Into the mobile phone version | Continue to access the computer ver.
Phantom 2 CFG-ERR
724 0 2016-4-7
Uploading and Loding Picture ...(0/1)
United Kingdom

Hi all,

I am having issues. I had a perfectly working P2 and decided to upgrade with Lightbridge (1st version).

I connected the Air System DBUS port to the X2 port on the Flight Controller.
I connected the Air System Gimbal port to the spare port on the main board.
I have checked both Air and Ground Systems are running up-to-date firmware.
I have solid green on both Video and Control on Air System.
I have calibrated the Phantom 2 RC via Ground System in Lightbridge Assistant.

And thats as far as I can get, when I plug the P2 into Phantom Assistant I can't calibrate and I get the CFG-ERR.
The android app shows the GoPro feed but pops up with a message saying 'Control Signal Lost'.

I have removed Lightbridge and tried to restore my P2 back to how it was but I get the same problem just trying to use my old RF P2 remote (and I've re-linked it and calibrated in RC Assistant but I get the same error in Phantom Assistant).

Really stuck, could a hard reset on the Flight Controller help? Could I have damaged a pin/wire inside the P2 during my installation?

Any help would be greatly appreciated!
Use props
You need to log in before you can reply Login | Register now

Credit Rules