Please select Into the mobile phone version | Continue to access the computer ver.
Inspire 1 X3 Fail after using with Osmo
1129 0 2016-4-8
Uploading and Loding Picture ...(0/1)


A week ago, I used my Inspire 1 for a couple flights and everything was working perfect.
After the second flight, the work I was doing required the Osmo.
Once I installed the X3 to the Osmo, I got a message to upgrade the firmware. I had upgraded the firmware not long ago (less than 2 weeks).
Since I was on my LTE network and working, I decided to upgrade later by not accepting to upgrade the firmware.

I continued to use the X3 with the Osmo for about 20min. After I was done using the Osmo, I switched back to the Inspire - same routine as yesterday.
This time I didn’t get image, neither on my iPhone 6 Plus nor HDMI output.

The DJI Go app showed “WEAK SIGNAL” followed by “NO SIGNAL”. While on the field I tried power cycle several times,  re-linking RC to AC, but no success.
Proceeded to contact DJI Chat support, since I didn’t want to drop the job I was doing. Support suggested all the things that I had done.
After trying everything again, in disappointment, had to drop the job.

After a long drive back to the city, got back to the office. I tried re-installing latest firmware on Inspire 1. The Inspire 1 accepted the upgrade but ended in fail. Did the same with the Osmo and fail.
Tried downgrading to previous firmare, on both and fail. Upgraded again and fail. Both, the Inspire 1 and Osmo show the changes to the firmware, but end up with fail.

The X3 on the Inspire responds to every command, but no image. On the Osmo responds to all commands and does show image, works correctly, but keeps failing when upgrading.

Everything works as it should in the Inspire 1, but no live feed. I can fly, operate camera (records video and pics), camera tilts, telemetry is on, but no live feed. Can't see what the camera is recording.
The aircraft was working perfectly until I started using the Osmo.

As last resource, I drove to a colleague´s office to try his X3 on my Inspire 1 and works perfect.

I looked at the Hidden Log files and found that on 2 different lines a "device not detected" is present.

I contacted US and China Support, and both suggested to send equipment for inspection and repair.  I live in Panama and this will be very expensive, not mentioning the risk of mishandling the equipment during shipping.

I went ahead and purchased a new camera (arrived today) and that did the trick!
In the latest LOG  The ¨device not detected ¨ issue has been solved for a successful upgrade.

I'm suggesting to DJI to take back the X3 that failed after used with the Osmo and replace it with an original Osmo camera. Since I will not be using an Inspire X3 with the Osmo again.
Will post results...

I hope this helps.

Kind regards,
Santiago Arango
Use props
You need to log in before you can reply Login | Register now

Credit Rules