Please select Into the mobile phone version | Continue to access the computer ver.
Firmware Upgrade Notes
1922 9 2016-4-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
DJI-Paladin
DJI team
Flight distance : 2408 ft

Hong Kong
Offline

New firmware for Inspire 1 series has been released at April 7th, 2016. Here is the list of the firmware versions:

  
Inspire 1 V1.0/2.0: v1.8.1.00
  
Inspire 1 Pro: v1.8.1.00
  
Inspire 1 Raw: v01.08.00.90
  
Remote controller: v1.6.0
  
IOS APP: 2.7.1
  
Android APP: 2.7.2
  
  
When you upgrade your aircraft and remote controller, please note:
  
  
1.       Both aircraft and remote controller must be upgraded to the latest version. If not, “RC Signal Lost” will be displayed on the DJI GO APP.

  
2.       The upgrade on the aircraft will take about 20 minutes and 10 minutes for the remote controller.

  
3.       Be sure that the battery level is over 50% for the upgrade.

  
4.       Do not power off the aircraft during the upgrade process even the following situations are met: gimbal becomes limp; LED indicators blink irregularly or go off; the aircraft reboot itself, etc.

  
5.       Please upgrade your aircraft first. When the aircraft’s upgrade has been completed successfully, upgrade your remote controller. If you have spare batteries, you can put the batteries into the upgraded aircraft one by one with the .bin file not deleted in the SD card.

  
6.       Please pay attention to the camera’s sound during the upgrade period:

  
Detecting the .bin file:D-D-D-D-D-D (less than 3 minutes)

  
During the Upgrade: DDDD-DDDD-DDDD-DDDD (it normally takes about 20minutes)

  
Completed successfully: D—DD—D—DD (Please reboot your drone)

  
Upgrade failed:D----------------------- (Please turn off the aircraft and format the SD card. Copy the .bin file in the card and try again. If failure persists, contact DJI Support)

Here is the Upgrading tutorial for Inspire 1:


2016-4-9
Use props
mtnmaddman
Second Officer

United States
Offline

I am at ver. 1.5 can I go directly to ver. 1.8 or do I have to upgrade all prior revisions in sequence?  thanks
2016-4-9
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

mtnmaddman Posted at 2016-4-9 08:28
I am at ver. 1.5 can I go directly to ver. 1.8 or do I have to upgrade all prior revisions in sequen ...

You can go to 1.8, just rember there is a battery update as well .

I prefer to stay in order if you have all of the files, but you can jump from 1.5 to 1.8

donnie
2016-4-9
Use props
david.mmcp
lvl.1
Flight distance : 92 ft
Offline

Donnie Posted at 2016-4-9 21:31
You can go to 1.8, just rember there is a battery update as well .

I prefer to stay in order if y ...

I have a brand new controller that says it need firmware update, the says the firmware is older or the same as installed. error says it needs version 1.3**** I've upgraded to 1.8
2016-4-9
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

david.mmcp Posted at 2016-4-9 10:40
I have a brand new controller that says it need firmware update, the says the firmware is older or ...

You upgraded the aircraft to 1.8 correct ?  The transmitter will be at 1.6 .  I am going to attach my tips page for you .  Please read it .  It is quite common to have a brand new device need an upgrade.  Before you do any upgrades make sure you are registerd with  with DJI.  This is via the go app.
isted
Make sure you are updating the RC with the go app.

. http://forum.dji.com/thread-45630-1-1.html
My tips page applies to phantom advanced and pro but many of the same programming rules apply

what model do you own ? Just want to make sure it is inspire
2016-4-9
Use props
Donnie
Captain
Flight distance : 3636782 ft
United States
Offline

david.mmcp Posted at 2016-4-9 10:40
I have a brand new controller that says it need firmware update, the says the firmware is older or ...

Is this a brand new Inspire or just the transmitter ?  I am a bit confused.  Where did you see the notice on the FW being older than what is on it?  was that on the SD  file log ?  

If your aircraft is at 1.8 great, you just need to update the transmitter via the go app to 1.6

donnie
2016-4-9
Use props
Olfbcn
lvl.1

Spain
Offline

I ve upgraded rc  first...no read before and now cant init travel mode....can help me please?
2016-4-10
Use props
itsalive69
lvl.2
United Kingdom
Offline

hi, I upgraded the quad and the controller?  but not my spear batteries,  I have been out with it and haven't asked for a new upgrade,  can I put the battery's in and reinsert the memory card with the program on.
2016-4-10
Use props
michael.douglas
New

Ghana
Offline

Olfbcn Posted at 2016-4-10 18:32
I ve upgraded rc  first...no read before and now cant init travel mode....can help me please?

I too have the same issue and can't return to travel mode. What must I do to rectify this?
2016-4-10
Use props
airymok
lvl.4
Flight distance : 2623652 ft
Hong Kong
Offline

michael.douglas Posted at 2016-4-11 02:48
I too have the same issue and can't return to travel mode. What must I do to rectify this?

Do a downgrade for your RC first via DJI GO.
2016-4-11
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules