Please select Into the mobile phone version | Continue to access the computer ver.
Phantom 3 Advanced: RC Fails Firmware Upgrade
809 1 2016-4-26
Uploading and Loding Picture ...(0/1)
o(^-^)o
cmtrisket
New

United States
Offline

I recently purchased the above mentioned drone for my wife. While setting it up and following all the tutorials I upgraded the firmware on the drone just fine, but when I got to the RC it would not work at all. I was on 1 support phone call with minimal help, and 2 live chats with even worse help. I was using an iPhone6 with the latest update 9.3.1. I'll tell you what I tried and what worked:

Tried and failed:
-Upgrading the RC with the same firmware (1.8.8)
-Upgrading by using SD converter in the RC's USB port
-Tried using different SD card
-Tried using different converter
-Tried using Flash Drive
-Tried putting SD card in the drone and connecting the RC to the drone
-Tried connecting the RC to my PC
-Tried the App with and without the drone on (while the SD card was in the drone)
           -I could download the upgrade but I could not gt it to upgrade
           -It would fail and the RC would never stop beeping and being blue, like it was still trying even though it wasn't
-Tried resetting the RC by holding a button sequence told to me by a DJI rep:
           -C1+C2+Record Button+Pressing the right camera wheel
           -All while holding those turn off the RC and then Turn it back on
-Tried re-installing the App

*I tried a number of these in combonation over and over again with no avail*

I then sent in for a refund and figured the RC was trashed (who wouldn't) I figured I would try one more thing. The last thing I could possibly think of.

What Worked:

-
I took the SD card out of the drone while attempting the RC update (I never was told about this and I don't know if anyone really knows about it)
-With SD card out of the drone, power on the RC
-Power on the drone
-Plug in your device
-Launch the App
-Proceed with upgrade

Device is at 2.7.2
RC is at 1.6.0
Phantom is at 1.8.8

I really hope this post helps a ton of people. This took a long time to figure out and I wish a post like this was easy to find.


2016-4-26
Use props
tuckerboy1
lvl.1

Offline

Ty I am going to try this as I have a p3 pro that will not take a firmware update. It will start then just lock up every time
2016-4-26
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules