Please select Into the mobile phone version | Continue to access the computer ver.
P3P Connection Issue
3728 1 2016-4-30
Uploading and Loding Picture ...(0/1)
o(^-^)o
chris.sonnenber
lvl.2

United States
Offline

I have a P3P and flew it a few weeks ago without a problem. Yesterday I tried to go flying again but could not get the aircraft and RC to sync. I would go into the DJI Go App on my iPhone 6 and it would not recognize my bird or let me into the camera. It kept saying How To Connect instead of the usual Camera. I tried to reset the controller and tried every piece of advice I found on the forums. Nothing worked.

Here is how I fixed the problem. First make sure you download the latest firmware (1.8) and update the bird FIRST then the RC. Once that is complete, you have to connect your iPhone to your computer (i used a PC). Open iTunes (make sure you have the latest version) and I backed up my phone. Then after that was complete, I restored my phone to its original state. Then I loaded all my backed up info onto my phone via iTunes. Everything reinstalled on my phone and I checked to see if it worked. IT DID!!!! I can now use my P3P as I used to.

I wanted to post this because I had so much trouble and tried everything with no success. Hopefully this can help revive someone's dead bird. Happy flying!
2016-4-30
Use props
evsjas
Second Officer
Flight distance : 1995479 ft
United States
Offline

Thanks for posting.
2016-5-1
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules