Please select Into the mobile phone version | Continue to access the computer ver.
Just bought Litchi App but won't connect!
13667 24 2016-5-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
G_MEZ_G
lvl.4

Offline

Anyone had this happened? I bought the Litchi App and it says disconnected. Not sure what to do to make it work. I tried on my iPhone 6+ and iPad Air 2. Any suggestions? Also the DJI Go App is working fine.
2016-5-13
Use props
vu.q.le
Banned

United States
Offline

Tip: the author has been banned or deleted automatically shield
2016-5-13
Use props
Boblanglois52
lvl.4
Flight distance : 112674 ft
Offline

I don't have any trouble connecting without the Go App running. I just set wifi to the drone and it connects. I haven't flown with it yet due to bad weather in New Hampshire. I use an Android phone, by the way.
I just copied this from the Litchi Manual

  1. Why is Litchi not connecting to my Phantom 3/Inspire 1?
                                         When starting the app for the first time, you will need to be connected to Internet in order to validate the app with DJI servers.
Some Internet connections may have troubles connecting to DJI servers, in such a case make sure to try a different Internet connection.
                                         Additionally, on Android if DJI Go is your default app for the remote controller USB connection, you will need to clear the defaults for DJI Go (Settings -> Apps -> DJI Go -> Clear Defaults).
                                 

                        
                 


2016-5-13
Use props
rayrokni
Captain
Flight distance : 8139875 ft
United States
Offline

I have exact same setup with a P3, and it works great. And no I don't run go app first, I connect using litchi no problem.
What phantom do you have, what versions of fw.
When you installed the litchi and ran it the first time, did you click on "allow" to all the pop up screens that came up?
You can try this: with the AC and RC both on, shut down the app, unplug cable, replug cable, start litchi app and see what happens
2016-5-13
Use props
G_MEZ_G
lvl.4

United States
Offline

rayrokni Posted at 2016-5-13 18:50
I have exact same setup with a P3, and it works great. And no I don't run go app first, I connect us ...

P3P LATEST FW
2016-5-13
Use props
bfd300
Second Officer
Flight distance : 73661 ft
United States
Offline

That's weird......Litchi works just fine w/ my Ipad air 1 and my iphone 5c. try deleting the App and re-installing.... For giggles try a diff cable.
2016-5-13
Use props
rayrokni
Captain
Flight distance : 8139875 ft
Offline


Did you try what I said
2016-5-13
Use props
G_MEZ_G
lvl.4

Offline

So I tried connecting the go app first and it worked. Not sure if it was related to that or not because I also noticed an email from Litchi asking to verify my email address

So after using it, I have to say I'm not impressed. I could not get a good lock on something for tracking and it would freak out when it lost the object. There was a point that the P3 would not even respond to my commands on the joysticks. I can live without the app.
2016-5-14
Use props
MTR-Aerial
lvl.2

Offline

Is the point and track supposed to work with the P3-S as well?
2016-5-14
Use props
G_MEZ_G
lvl.4

United States
Offline

MTR-Aerial Posted at 2016-5-15 02:36
Is the point and track supposed to work with the P3-S as well?

As far as I know, yes.
2016-5-16
Use props
MTR-Aerial
lvl.2

Offline

G_MEZ_G Posted at 2016-5-17 00:35
As far as I know, yes.

Thank you sir!
2016-5-16
Use props
spencerbent
New

United States
Offline

Had the same problem not connecting to Lichi app. Solution that fixEd my problem was to remove DJI GO from  the default program. Even if I force closed both apps and loaded lichi I had no luck until I did the avove.
2016-5-28
Use props
BillDrum
lvl.1

United States
Offline

Has anyone using DISHNET  been able to connect to DGI servers?
2017-2-15
Use props
Anonymous1
lvl.2
Flight distance : 602303 ft

Jamaica
Offline

I have the same issue with this on my Note 8 running the latest firmware on my Phantom Standard 3
2018-9-3
Use props
Anonymous1
lvl.2
Flight distance : 602303 ft

Jamaica
Offline

Boblanglois52 Posted at 2016-5-13 15:37
I don't have any trouble connecting without the Go App running. I just set wifi to the drone and it connects. I haven't flown with it yet due to bad weather in New Hampshire. I use an Android phone, by the way.
I just copied this from the Litchi Manual

The "Defauts" option is greyed out for both DJI Go and Litch.

DJI Go continues to work perfectly.  I just wish to do Waypoint missions using Litchi.
2018-9-3
Use props
Anonymous1
lvl.2
Flight distance : 602303 ft

Jamaica
Offline

spencerbent Posted at 2016-5-28 19:44
Had the same problem not connecting to Lichi app. Solution that fixEd my problem was to remove DJI GO from  the default program. Even if I force closed both apps and loaded lichi I had no luck until I did the avove.

How do you do that?  My Note8 shows the Default option greyed out in the SETTINGS menu in my phone.
2018-9-3
Use props
RicardoGray
Captain
Flight distance : 4356421 ft
United States
Offline

Anonymous1 Posted at 2018-9-3 09:58
How do you do that?  My Note8 shows the Default option greyed out in the SETTINGS menu in my phone.

You should be able to go into the settings, then into the apps. Scroll though your apps until you get to DJI. Now tap on it and it should open up the settings for that app. Look through the list and you should see something like "Open by default". Click on that and clear the default settings. Do the same for Litchi. Now when you have your RC on, and your phantom on, then plug your usb cable into your device, it should now prompt you which one to use. Always pick "This time only". Do not pick "Always". If you do by mistake, just go back and clear those defaults so it will ask you each time.
So, is this where you are trying to go, and are you saying yours is grayed out and you cannot clear it?
You need to go into the DJI app itself, not the default programs if I understand you cprrectly.
Hope this helps.
2018-9-5
Use props
Anonymous1
lvl.2
Flight distance : 602303 ft

Jamaica
Offline

I have the Phantom 3 Standard, so I don't have the luxury of connecting my phone to the RC transmitter using USB (like the Pro or Advanced models).
The DEFAULTS option is greyed out on my phone for both the DJI GO and Litchi.  I suspect that ultimately, I'll have to delete DJI GO to use Litchi, but I don't want to do that and lose my flight logs (and the user friendly interface of the DJI GO app).  My other test later would be to just install Litchi on another device (only) and use that permanently for Litchi.

The Settings option in the ME option of the DJI GO app doesn't give me any "defaults" option in the Privacy menu.
2018-9-5
Use props
RicardoGray
Captain
Flight distance : 4356421 ft
United States
Offline

Anonymous1 Posted at 2018-9-5 06:11
I have the Phantom 3 Standard, so I don't have the luxury of connecting my phone to the RC transmitter using USB (like the Pro or Advanced models).
The DEFAULTS option is greyed out on my phone for both the DJI GO and Litchi.  I suspect that ultimately, I'll have to delete DJI GO to use Litchi, but I don't want to do that and lose my flight logs (and the user friendly interface of the DJI GO app).  My other test later would be to just install Litchi on another device (only) and use that permanently for Litchi.

I think you may not be followling my suggestion. It is not necessary to connect to your RC to remove the default settings for the app. I am not familiar with your device, but I have had multiple android devices (which I think your is), and all are the same as I described. I might suggest loking on the internet for your answer. You need to have the GO app to set some settings on your aircraft. I understand what you are thinking, but there isn't any reason you can't have both apps on your device. Un-installing the GO app will not cause you to lose any information. It normally doesn't delete all files such as flight logs, etc. When you re-install the app you should still have most of that. You may have to re-set the settings in the app itself as fa as any camera settings. Normally after the install, and you have both apps installed, when you connect to the RC with the app, it should ask you which app you want to use. Just pick "This time only", or "just once"......something like that. Do not pick "Always". Sorry I can't offer any more to help you. Hope you get it working for you.
2018-9-6
Use props
Anonymous1
lvl.2
Flight distance : 602303 ft

Jamaica
Offline

I'm not actually connecting to anything (transmitter or Pahantom3) when I try your suggestion.   I'm just telling you that my "defaults" option is greyed out (unselectable) on my Samsung Galaxy Note 8.

I've never gotten the option to pick "This time only", or "just once" on my phone.  I even uninstalled the DJI GO app, tried with Litchi installed only, but it didn't work.

When I just purchased the Litchi app, it connected to my Phantom 3 once, but since I restarted the app, it didn't reconnect again nor show me the "This time only", or "just once"
2018-9-6
Use props
RicardoGray
Captain
Flight distance : 4356421 ft
United States
Offline

Anonymous1 Posted at 2018-9-6 16:30
I'm not actually connecting to anything (transmitter or Pahantom3) when I try your suggestion.   I'm just telling you that my "defaults" option is greyed out (unselectable) on my Samsung Galaxy Note 8.

I've never gotten the option to pick "This time only", or "just once" on my phone.  I even uninstalled the DJI GO app, tried with Litchi installed only, but it didn't work.

OK, I'm sorry for your troubles. I understand now what you are doing. It is strange for sure. Not sure what else to offer up. Seems odd it would open the app once, but not again??? Only thing I can suggest is again to maybe google your issue for your device. I have never seen your issue myself. There must be some setting turned off not allowing you to change those default settings. Best of luck.
2018-9-10
Use props
Bashy
Captain
Flight distance : 549140 ft
United Kingdom
Offline

Hi, have you tried going to settings, then apps, then 3 dots top right, choose default apps, then remove DJI go as the default app. then see which connects and if all is ok DO NOT TICK make default
2018-9-10
Use props
Anonymous1
lvl.2
Flight distance : 602303 ft

Jamaica
Offline

My Samsung Galaxy Note8 has the DEFAULTS option greyed out.


The Litchi app NOW allows me to connect with the Phantom 3's camera, but will not allow me to unlock the motors. It however updates gimbal movement and what the camera is seeing in real time.

The DJI GO app continues to work as usual.
2018-9-25
Use props
KenDuke
Second Officer
Flight distance : 50837 ft
United States
Offline

You must be running a old version of Litchi.  Update via the Play store.  The newest one works great on both iOS and Android.  Running iOS 12.1 and I've tested on Android 7.1.1 and 9.0(Pie)
2018-10-13
Use props
Anonymous1
lvl.2
Flight distance : 602303 ft

Jamaica
Offline

I can tell you that my version was up-to-date even as recent as last week from the Google Play Store.  I can now see only the static image that the camera shows, but and arm my Phantom 3 standard, or actually deploy a saved flight mission.   I can arm the PS3 directly using the stick commands, and fly line of sight, but it doesn't reflect anything in the actual Litchi app itself.   The DJI GO app still works great just the same.
2018-11-12
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules