Please select Into the mobile phone version | Continue to access the computer ver.
DJI Go Geo - not unlocking correctly
776 1 2016-5-20
Uploading and Loding Picture ...(0/1)
United States

I applied through for the Beta version of DJI Go Geo for IOS and received an email a few days later from TestFlight with the approval. I downloaded the app and everything appeared to install correctly. I thought I remember seeing an authorization code, but cant seem to find that and the App has yet to ask for it, though that may be an issue. I went to a regional airport today to test everything and was unable to fly the P3. Initially, it gave me a warning about being in a restricted zone, I  clicked through all that, accepting both of the terms, and it indicated that it was successfully unlocked. when I tried to start the P3, it would not start and a note popped up about being in a restricted zone. I also wnet through the FlySafe process of unlocking the zone, whcih was done successfully....but, in the end, still got the same message when I tried to start. My P4 did not have any of these problems, I was able to fly at the airport. I have the most current firmware on everything.

I am teaching a UAF class to a group of Civil Air Patrol cadets on Monday evening and want to have both of my Phantoms available for some hands-on experience for the cadets.
Use props
DJI team
Flight distance : 1515312 ft
  • >>>

You also have to install the 1.9 firmware on your P3.
Use props
You need to log in before you can reply Login | Register now

Credit Rules