Please select Into the mobile phone version | Continue to access the computer ver.
Interesting Observation about LB2/A3/Z15-A7 Setup and RTH Button
1525 27 2016-6-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
bcdebusk
lvl.2

United States
Offline

I happen to have two LB2 systems -- it's a long story as to why.

- Connect LB2 to A3, RTH button works correctly.  Not testing Z-15 at this point.
- IOS app says controller needs updating.  Do successful update
- PC app says LB2 reciever needs updating.  Do successful update
- After update, RTH button stops working.  Pressing it just does nothing
- Play with Z-15, get it transmitting to IOS app, but RTH button still doesn't work

So against my better judgement, I open the second LB2 and repeat the same procedure.  I get exactly the same result.  The LB2 upgrades seem to "break" the RTH button.

But during one of my restarts after an upgrade, the RTH button mysteriously starts working again.  But I notice the Z-15 image isn't coming through anymore.

So I start everything back up, and the Z-15 image is back up and running -- but the RTH button is once again broken.

I sense an emergency patch in the near future.  I'm not going to try much until I hear a fix is out.  If this is broken, other things could break mid-flight.


2016-6-8
Use props
Tahoe_Ed
Administrator
Flight distance : 2605 ft
  • >>>
Offline

Can you show us a screen shot or a short video?
2016-6-8
Use props
bcdebusk
lvl.2

United States
Offline

Tahoe_Ed Posted at 2016-6-8 21:06
Can you show us a screen shot or a short video?

Here is a link to the dropbox video:  https://www.dropbox.com/s/pl9z3c ... %2033%20PM.mov?dl=0

I did say one thing incorrectly.  It's a standard A3, not an A3 Pro.

The AETR and landing gear switches work great.  And I have the RTH button mapped to the default channel on the A3.  But on the ground station itself, the RTH button is dead.  You can't turn it on no matter how often you try.

This is what's weird -- and I don't have a video.  Sometimes the LB2 video link won't work at all, but suddenly the RTH button starts working again.  I wouldn't mind making a video, but it would take me 60+ minutes of disconnection the iPad, rebooting the A3, rebooting the controller, etc. etc.  You basically have to try things until the Z-15 stops working.  The moment it stops working, you know the RTH button will start working again.

And what makes this particularly interesting, is how it is 100% reproducible on two identical LB2 units.
2016-6-8
Use props
bcdebusk
lvl.2

United States
Offline

And thank you for your help by the way.  It's easy to get flustered with problems like this, but I'm in it for the long haul.

I'm one of those customers who are dying to be a strong advocate, because I've been frustrated in the past by all the less-than-professional systems that are being sold.
2016-6-8
Use props
Tahoe_Ed
Administrator
Flight distance : 2605 ft
  • >>>
Offline


Thank you but I would rather see the channel mapping screen when you press the RTH button.  You cannot imitate RTH when on the ground, not armed.  
2016-6-8
Use props
bcdebusk
lvl.2

United States
Offline

Tahoe_Ed Posted at 2016-6-8 22:45
Thank you but I would rather see the channel mapping screen when you press the RTH button.  You can ...

I'll do that video for you tomorrow, but before the upgrade I could make that circular RTH light fire anytime simply by holding down the button.  After the upgrade, it stops doing that.

2016-6-8
Use props
Tahoe_Ed
Administrator
Flight distance : 2605 ft
  • >>>
United States
Offline

I look forward to the video.
2016-6-9
Use props
bcdebusk
lvl.2

United States
Offline

Tahoe_Ed Posted at 2016-6-9 06:27
I look forward to the video.

Here's a dropbox link to the video:  https://www.dropbox.com/s/6zuvm4 ... %2044%20PM.mov?dl=0

You can see all the channels working, except the RTH button.  But notice the RTH button doesn't even try to fire with the lighted ring.  All the other channels map just fine.

At first you might think it's just a bad button, but I have access to two LB2 units.  The first unit came out of the box with RTH working fine.  Pressing and holding the button made the channel start bouncing back-and-forth (it looked like about a one second cycle).  Then I did the upgrades and the button goes completely dead.

What makes this suspicious is that the second LB2 performed exactly the same way out of the box.  And again once the upgrades were done on the LB2, the button goes dead.

Also notice that when I rotate the wheel on the left side of the controller, it makes Channels 5 and 6 both roll.  The Z-15 rotates correctly (you can't tell that in the video), but it also cross-talks onto channels 5 and 6.

Thank you in advance btw -- this help is greatly appreciated.
2016-6-9
Use props
Tahoe_Ed
Administrator
Flight distance : 2605 ft
  • >>>
Offline

What happens in Assistant when you turn off the RC?
2016-6-9
Use props
bcdebusk
lvl.2

United States
Offline

Tahoe_Ed Posted at 2016-6-9 18:36
What happens in Assistant when you turn off the RC?

When I turn off the controller, the assistant software correctly reports that the A3 has gone into Failsafe mode.  Then when I power the controller back up, it goes out of Failsafe mode and back into the appropriate flight mode.  That part works 100% correctly.

I've speculated that the Failsafe button is non-responsive because the craft isn't armed.  But I vividly remember the button toggling correctly without arming prior to the recent LB2 update.
2016-6-9
Use props
bcdebusk
lvl.2

United States
Offline

So I verified that everything worked except the RTH button.

I went outside and calibrated the compass.

Then I armed the S1000+

... and then I disarmed it and chickened-out.  It's just too expensive to take chances.  I'm going to take it to a large field on Saturday and give it a real try.
2016-6-9
Use props
user6f9100deca
lvl.4
Flight distance : 31768 ft
Spain
Offline

I have the same problem, does not work the RTH button
has solved your problem?
2016-7-7
Use props
bcdebusk
lvl.2

United States
Offline

user6f9100deca Posted at 2016-7-7 07:44
I have the same problem, does not work the RTH button
has solved your problem?

No.  The RTH button still does not work for me since the aforementioned update.
2016-7-7
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

bcdebusk Posted at 2016-7-8 08:26
No.  The RTH button still does not work for me since the aforementioned update.

Have you attempted to get in contact with the North American support center to look into a possible diagnostics and repair?
2016-7-8
Use props
tochi
lvl.4
Flight distance : 31768 ft
Spain
Offline

what not is if the Matrice 600 that has this configuration has the same problem

I ask forgiveness, not be English and use the translator
2016-7-8
Use props
bcdebusk
lvl.2

United States
Offline

DJI-Jamie Posted at 2016-7-8 16:04
Have you attempted to get in contact with the North American support center to look into a possibl ...

I haven't.  Several people have reported it on this forum and I assumed all the DJI staff here would pass along the information.

I'm using the same approach for the Assistant bug where A3 IMU/Compass offsets can't be set beyond the values of +/- 128.  I"m sure there will be an update soon.

In general, my DJI strategy is "When something looks messed up, wait for an update."  I can play with other drones in the meantime instead of risking an expensive setup.  
2016-7-9
Use props
tochi
lvl.4
Flight distance : 31768 ft
Spain
Offline

but one thing not be working well to sell!
reminds me of HOVERFLY with gps
2016-7-9
Use props
tochi
lvl.4
Flight distance : 31768 ft
Spain
Offline

DJI does not report any problems with RTH button, perhaps the A3 + station DJI has RTH and I'm going crazy looking for a miracle
2016-7-11
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

bcdebusk Posted at 2016-7-9 20:25
I haven't.  Several people have reported it on this forum and I assumed all the DJI staff here wou ...

That's not a bad strategy to follow. A RMA may prove as a more course of action so that one does not feel like they are sitting on their hands, sort of speak. Just to clarify, had you tried reapplying the firmware update or have attempted to update the A3 as of late? There was a firmware update for the A3 not too long after your initial post.

Tahoe_Ed had asked for any visual on the issue, have you had the chance to make any short videos showing the issue?
-Edit- Sorry I overlooked the dropbox video, you can disregard the last question.
2016-7-11
Use props
Tahoe_Ed
Administrator
Flight distance : 2605 ft
  • >>>
United States
Offline

bcdebusk, I watched your video.  There is an issue with the Assistant 2 that does not allow you to map the RTH switch.  We will have a revised Assistant 2 available soon.  I hope that it will address this issue.  However, it is my understanding that if you turn off the RC and it enters FS then it is set up correctly.  No one wants to test because they cannot bench test first.  It would be prudent to wait for the update.  I have a A3 Pro with LB2.  I am not so concerned with RTH as I never use it.  I just fly it home.  If I loose RC then as you have tested it will enter failsafe and RTH.  Once RC is restored then you can take control again.  Just wait, it won't be long.
2016-7-11
Use props
user26b91deb95
lvl.1

Spain
Offline

Not only DJI assistant...
If you send RTH via DJI Go, the equipment makes a landing not an RTH. And it tells you: you slice the buttom when you push the rth in the screen and then the tablet says "landing"
2016-7-12
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

user26b91deb95 Posted at 2016-7-12 20:58
Not only DJI assistant...
If you send RTH via DJI Go, the equipment makes a landing not an RTH. And  ...

To clarify, did you verify that your landing settings are set to RTH and not automated landing? How far would you be from the home point when you activated RTH?
2016-7-12
Use props
user26b91deb95
lvl.1

Spain
Offline

Yes, I've verified in DJI assistant and DJI Go.
2016-7-13
Use props
tochi
lvl.4
Flight distance : 31768 ft
Spain
Offline

Tahoe_Ed
do you have proven your RTH button?
Or 3 are only those who have the problem
2016-7-20
Use props
user26b91deb95
lvl.1

Spain
Offline

Well. RTH is working...but only throught DJI Go app. You must be at least at 20 m if you want to make a RTH, if not, it will land.
Just the transmitter button to make it work.
But....
The sixth time I've proved this feature.....when the copter was in the fase on landing, all the motors stopped. The copter was dissarmed while landing. 10m free falling and no chance to read the DAT file....
No sticks where touched.
But the iphone told me something just before it happens...but I have no way to get the logs....

For your information, it was a dissarmed issue, when I get the copter it was on, but unnarmed.

Thanks a lot

2016-7-29
Use props
bcdebusk
lvl.2

United States
Offline

Tahoe_Ed Posted at 2016-7-11 17:30
bcdebusk, I watched your video.  There is an issue with the Assistant 2 that does not allow you to m ...

No worries.  I would rather it be 100% fixed 30 days late than 75% fixed and crashed.
2016-7-30
Use props
bcdebusk
lvl.2

United States
Offline

bcdebusk Posted at 2016-7-30 09:52
No worries.  I would rather it be 100% fixed 30 days late than 75% fixed and crashed.

Pssst... I've waited my 30+ days.

Is the RTH button completely fixed now?  I've noticed the DJI Assistant has been recently upgraded, as has the Lighbridge 2 software.  

Is everything good to go, or should I wait another 30 days?
2016-8-21
Use props
CamFly Films
lvl.2
Flight distance : 1074564 ft
United Kingdom
Offline

I have the same problem. No RTH button. Assistant says: RTH not set. Also: I had an auto landing on low battery, but the landing gear didn't deploy. (it works just fine at take of or triggered manually... But first the RTH: Is the problem solved, or is it me not able to set it up correctly?
2017-7-14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules