Please select Into the mobile phone version | Continue to access the computer ver.
X5 no video feed on Osmo or I1
665 5 2016-7-22
Uploading and Loding Picture ...(0/1)
o(^-^)o
TravisSRT
Second Officer
Flight distance : 5568658 ft
  • >>>
Offline

Hello, I have an Inspire 1 Pro, two standard Inspires and an Osmo. I purchased a second X5 camera and X5 adapter to use on my Osmo only.  Today I stuck the new X5 on the Osmo and it said firmware update required.  I downloaded the latest firmware from DJI.com and put it on the SD card and started the update.  A few minutes into the update the left hand LED turned red and it beeped constantly.  I saw on the app that the update failed.  I now get no video feed from the camera when connected to the Osmo or Inspire 1 Pro.  It will not complete an upgrade using the Osmo or I1.  My other X5 works fine on both so I think I can rule out hardware on the I1 and Osmo/X5 adapter front.  I called DJI Support US and the guy sounded like he was reading a script and was no help at all.  I tried the Trigger + Record + Power firmare reset with no success.  Any suggestions before I send the camera back to the vendor I purchased it from?  Oh, In the app it shows that it's on the latest firmware for both Osmo and I1..
2016-7-22
Use props
DJI-H.C
Administrator
Flight distance : 13602 ft
Offline

It sounds like the X5 you bought is defective and may need to return it.

2016-7-25
Use props
liammucklow
New

Canada
Offline

Any update here?

I have the same problem
2016-9-15
Use props
majed.side
lvl.1

Offline

Me too .

I need solution please .
2016-9-15
Use props
DJI-Thor
Administrator
Flight distance : 13602 ft
Offline

liammucklow Posted at 2016-9-16 10:42
Any update here?

I have the same problem

If you updated the firmware, and tried a different phone, still have no image transmission, it is a hardware issue and needs to be returned. Thank you.
2016-9-15
Use props
MajedHD
lvl.1

Offline

DJI-Thor Posted at 2016-9-16 12:29
If you updated the firmware, and tried a different phone, still have no image transmission, it is  ...

Thanks for your feed pack
2016-9-15
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules