Please select Into the mobile phone version | Continue to access the computer ver.
Problems with Ph3P after repair from 75 ft crash
557 3 2016-7-24
Uploading and Loding Picture ...(0/1)
o(^-^)o
craigmart75
Second Officer
Flight distance : 692625 ft
  • >>>
United States
Offline

1#
Hello,
My PH3P decided it wanted to crash in to the ground from about 75 ft the other day. I have been flying it in the area for about 10-12 flights , while flying it went from GPS mode to ATI then back and forth a few times then it started to go down fast i atempted to gain altitude with no luck. It started to rotate a few times then a rapid decent into the ground.
The camera gimbal broke and the camera came off, the landing gear without the compass broke and the craft looks like it took most of the impact on the front left arm.
I took the drone apart and looked at the damage and found 2 motors were bad, the ORDM reciever module camera conector broken off, non compass landing gear broken, top and bottom shell damage, and Gimbal yaw arm and roll arm with motor damaged, and the capacator next to the GPS plug loose on Main Board.

I ordered new landing gear, drone shell , a replacement ORDM reciever, 4 motors and the yaw and roll arms.

I have recieved all the parts except the gimbal arms.

I resoldered the capacitor onto the main board next to the GPS plug. The landing gear came with a new compass so i used that one on the drone.  I reinstalled the 4 antenna's to the new legs. Installed the new ORDM and Old Vision sensors ( conected all antenna conections) to the new lower shell. installed the new motors installed the main board into the lower shell. unsoldered the old motor and led leads and resoldered the new ones back. removed the gps module from the old top and looked at is( looked good no cracks or anything) installed it in the new top. conected the gps cable to the main board and inserted a 100 % battery into and powered it on. No gimbal attached)

Once powered on the drone makes the normal beep and ends with a Solid Red Led on Front arms and Fast Blinking Yellow on the Rear Arms.
I rebound the old controller to the new ORDM module and that worked.
I conected the app to the drone.It showed a GPS Home Lock on the app. and had 11 Satellites showing. So it looks like the GPS works.
I then goto the drone status and it shows the status as ok. Current firmware and stuff like that.
I then pick up the drone and move it around and you can see a change in alt and speed and its says ATI mode. I go back and look at the Drone Status And it now says Flight Error Records  Compass error exit P-GPS MODE...
It will not let me recalibrate the compass.
I can goto the Sensors page and it shows no numbers in any boxes on the IMU.
I have tried to check IMU settings and calibrate the IMU nothing happens. I can leave it there for 20 min and it won't go past 0%
The Firmware on the drone before the crash was 1.9.60 I had about 10 flight with it with no problems.
Now the System info shows a drone firmware of 1.1.5 and no Flight Controler Sn.
Do I need to have a complete working Camera and Gimbal to 1. Get Info to show up on the IMU sensors. 2 Update the firmware .

Any Help on the flashing Yellow Led , Compass Calibration and IMU Settings .

Thanks

Craig













1

1

2

2

3

3

4

4

5

5

6

6

8

8

7

7
2016-7-24
Use props
DJI-Paladin
DJI team
Flight distance : 2408 ft

Hong Kong
Offline

Hello Craig, I'd suggest you to update the drone and then relink the RC and the drone. If it doesn't help, it is recommended to send it in for fixing.
2016-7-25
Use props
craigmart75
Second Officer
Flight distance : 692625 ft
  • >>>
United States
Offline

DJI-Paladin Posted at 2016-7-25 06:19
Hello Craig, I'd suggest you to update the drone and then relink the RC and the drone. If it doesn't ...

Hello,
To trouble shoot what i did .

I replaced the ofdm module with my old one with the broken camera conector and rebound it ( it shows a solid green light  once bound) and the IMU shows information and I can check it and calibrate it. the OFDM version has the power plug for the fan on it. then I replaced it with the replacement OFDM unit ( It has the fan wires soldered on the board no plug) and I rebind it to the controller ( has a blinking red and green light ) and I get no data on the IMU sensors. And Flashing Yellow Lights.
It shows a older firmware on it.. Is that the problem?? or are they compatible with the older Main Boards?

Thanks

Craig

2016-7-25
Use props
DJI-Paladin
DJI team
Flight distance : 2408 ft

Hong Kong
Offline

craigmart75 Posted at 2016-7-26 03:02
Hello,
To trouble shoot what i did .

Sorry, I'm not so sure what will happen when the modules are not up to date. I think in this case you may need to update it again with the latest firmware.
2016-7-25
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules