Please select Into the mobile phone version | Continue to access the computer ver.
assistant 2 not working for M600
2226 14 2016-8-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
ricci2
Captain
Flight distance : 61158 ft
  • >>>
France
Offline

Greetings all,

Assistant 2 software is being a pain, I have been able to connect the windows version via a virtual windows on iMac but never on the mac version, I know my way around mac's and serial ports and there is no fault on the hardware that I can diagnose for now. I have tested on dedicated windows machines W10 on all, and since the upgrade firmware on the ground controller a few days ago "1.1.50" I have lost connection with the m600 pane on the assistant 2 app.

things that work:
assistant 2 connects with m600.
assistant 2 shows light bridge 2 pane and allows you to see version firmware no.

things that don't work:
m600 pane on assistant 2 software.
settings on lightbridge 2 pane will not connect just looks like its a workable link but is inactive.

conclusion is the connection link works to the craft because it sees the lb2 so either the new ground controller firmware has changed communication protocols effecting A3 link or there is an issue with the A3.
I have two questions:
1, is there meant to be any user options on the settings tab of the lb2 tab on the assistant 2 software? if no then disable it please and tell us so. if yes mine is broken and would like to find a fix.

2, Is there a backdoor way to communicate with the A3 should I have to use the setup parameters or imu location. I assume you have people working on the issue as so many people are having issues with the assistant 2 software.
If you don't have answerers because its being worked on please feel free to be honest with us as we have in good faith bought into the product as early adopters which means we have more tolerance when it come to new equipment problems.
looking forward to an interesting reply.
r
2016-8-10
Use props
SteadyWTF
Second Officer
Flight distance : 3963865 ft
  • >>>
United States
Offline

This is correct.  Hope you found a solution
2016-8-13
Use props
ricci2
Captain
Flight distance : 61158 ft
  • >>>
France
Offline

DJI are not responding through direct contact or this site, so don't hold your breath .
2016-8-13
Use props
brich12003.yaho
lvl.2
United States
Offline

I have several LB2's with A3's mounted on M600's and custom platforms what i found out is if you connect assistant 2 to PC and M600 you have a very limited menu (only LB update view and M600 motor test and basic setup config)but when using stand alone LB2& A3 you have more of a functional menu such as gimbal control type (D-bus or LB) intelligent gear, platform type etc. hope this helps a bit
2016-8-15
Use props
ricci2
Captain
Flight distance : 61158 ft
  • >>>
France
Offline

Hello,
thanks for your info, looks like DJI have limited the interface, probably to stop inquisitive folk poking items that don't need tweaking, I suspect its a firmware gate. Plugging into the A3 direct will have the same results.

thanks

R
2016-8-15
Use props
Ko2
lvl.2
Flight distance : 88953 ft
Turkey
Offline

Hi,
I have the same issue, but if I'm not mistaken I remember that I have seen the advanced menu at M600 screens. I was able to see the advanced menu at the first times I got connected to the m600. I believe after activating the M600 in order to fly, these advanced menus disappeared.

Did anyone find a solution or even a work around for this problem?

Thanks,
KY
2016-11-17
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

Ko2 Posted at 2016-11-18 15:30
Hi,
I have the same issue, but if I'm not mistaken I remember that I have seen the advanced menu at  ...

Just to clarify, what Mac OS do you have? Are you able to only see the LB2 option but not the M600? What version of the Assistant 2 Software do you have? Any screenshots that you have would be appreciated.
2016-11-18
Use props
mikes1
lvl.3
United States
Offline

Installed Assistant 2 version 1.0.7. I was thinking that it could help me solve an issue with the gps warring that several people are having. Looks like the connection is good both with the M600 and the Lightbridge. All firmware is updated and correct. My question is that when I connect to the M600 under the Basic Settings window I see the GPS1 and corresponding X Y Z values. Physically the GPS is pointing to the front of the aircraft with a solid connection and I have never removed it or purposely turned it since it first went in the air. The GO APP says I have 17 sats locked in. The values are X = 0, Y= -130, Z= -230. Sometimes firmware updates can upset these machines and I thought that maybe after the last update the GPS had become really sensitive and any misalignment might cause the warning. I have completed the compass and IMU calibration several times successfully. Was hoping to avoid "eye balling it" and use the assistant to fine tune. Anyone have any suggestion on what the values should be or if mine seems about normal. ALSO while I've been typing the M600 has been on and connected to the Assistant 2 and I just got the dreaded compass error message.  
2016-12-2
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

mikes1 Posted at 2016-12-3 01:54
Installed Assistant 2 version 1.0.7. I was thinking that it could help me solve an issue with the gp ...

I've responded to you on your own thread.
2016-12-2
Use props
fans306a1605
lvl.2
Flight distance : 182812 ft
United Kingdom
Offline

I have an S900, Lightbridge 2, A3 Pro, and X5. I'm having problems connecting to DJI Assistant 2. I power Up the controller, Then the S900. I connect the micro USB from the LED to my MacBook Pro.
In "Assistant 2" I can see the A3 Logo and click on it. The screen gives me the Menu on the left with the dashboard etc and on the right side of the screen I have the firmware details. I then get an "Arrow Cursor with No Entry Sign" on my cursor when i place it anywhere over the menu.

Does the A3 Pro need to know where I've placed  my flight controller and IMUs? I have no ability to click on anything on the page, nort even the firmware upgrade button.
Screen Shot 2017-02-18 at 22.13.04.png
2017-2-18
Use props
fans306a1605
lvl.2
Flight distance : 182812 ft
United Kingdom
Offline

Picture of cursor, sorry if it appears upside down.
IMG_4998.JPG
2017-2-18
Use props
dsenechal
lvl.2
United States
Offline

What a relief to find this post. I recently got a Matrice 600 Pro and was very concerned that the  Setup Section of Lightbridge on the Assistant 2 wasn't working. I talked to DJI customer support (different agents) for well over an hour, and after swapping cables, swapping computers, uninstalling and reinstalling, they told me to mail my Lightbridge in for service.  If the information in this forum is correct, though, there's nothing wrong, there are no settings to adjust. At least I'm guessing. If this is correct, and my Matrice and LB are working properly, then what a relief!
2018-4-24
Use props
ricci2
Captain
Flight distance : 61158 ft
  • >>>
Spain
Offline

dsenechal Posted at 2018-4-24 10:01
What a relief to find this post. I recently got a Matrice 600 Pro and was very concerned that the  Setup Section of Lightbridge on the Assistant 2 wasn't working. I talked to DJI customer support (different agents) for well over an hour, and after swapping cables, swapping computers, uninstalling and reinstalling, they told me to mail my Lightbridge in for service.  If the information in this forum is correct, though, there's nothing wrong, there are no settings to adjust. At least I'm guessing. If this is correct, and my Matrice and LB are working properly, then what a relief!

Hi,
you are reading these post correctly, there is no user adjustments that can be gained here…….so fly with confidence……..)))))))
2018-4-24
Use props
dsenechal
lvl.2
United States
Offline

ricci2 Posted at 2018-4-24 12:04
Hi,
you are reading these post correctly, there is no user adjustments that can be gained here…….so fly with confidence……..)))))))

Thank you very much for the confirmation!
2018-4-30
Use props
ricci2
Captain
Flight distance : 61158 ft
  • >>>
Spain
Offline

dsenechal Posted at 2018-4-30 08:32
Thank you very much for the confirmation!

your welcome
ricci
2018-4-30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules