Please select Into the mobile phone version | Continue to access the computer ver.
Osmo Cannot connect to camera (wifi problem)
25660 19 2016-10-5
Uploading and Loding Picture ...(0/1)
o(^-^)o
Hs4utwSZl1RU
New

Offline

Hey all,

I bought my first osmo a while ago. I set it up and it worked fine. A few weeks later I picked it up to film a project, but I ran into many issues.
I couldn't get the camera to connect to my phone. First, the OSMO wifi name could not be found in the list of hotspots. I would re-start my phone and camera a few times and if I was lucy I could find the osmo wifi. Then more issues followed. As soon as I selected the osmo wifi, I would get several different error messages "cannot connect to wifi" or "no internet connection".
If I was REALLY lucky, I would be able to connect them for just a few seconds before the screen went black. I dont have any other smart devices to use.. and I'm certainly not going to buy a new phone (im using an iphone 6 btw)- Everything is updated. I believe this is a problem with the osmo. I read a few other forums to reset the osmo but that didnt work either.

Has anyone had this issue? what was the resolution?
2016-10-5
Use props
LenMiddx
Second Officer
United Kingdom
Offline

I've had the same problems on more than one occasion.

The only solution seems to be ....... keep trying. Eventually it will connect.

And it will (on occasions) loose that connection.

I don't know of any solution -- sorry. It's just one of the Osmo's shortcomings.
2016-10-5
Use props
nigelbrinkmann
First Officer
Flight distance : 466332 ft
Australia
Offline

Hi, try and delete the app and then reinstall it, also try to restore the default WiFi settings on the osmo, refer to page 25 in the user manual under trouble shooting.
2016-10-5
Use props
joelmjohnsons
New

United States
Offline

I received my OSMO yesterday and have had a lot of problems trying to connect to its network. I have tried on several different devices (i.e. iPhone 5s, iPad Air 2, Android phones ,etc).
When I connect, I get a black screen and sometimes after a while the viewfinder will show up.
Is there any way to improve the network? I doubt reinstalling the software will fix anything.
2016-10-5
Use props
nigelbrinkmann
First Officer
Flight distance : 466332 ft
Australia
Offline

joelmjohnsons@g Posted at 2016-10-6 11:48
I received my OSMO yesterday and have had a lot of problems trying to connect to its network. I have ...

Have you tried 5ghz?
2016-10-5
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Offline

Hi Hs4utwSZl1RU, please make sure your mobile phone is operating at either 2.4Ghz or 5.8Ghz channel. Then you could try to reset the WiFi to default settings by using the key combination (hold down the Trigger and Shutter button at the same time, then pull the power switch down until the system status indicator blinks green, release the power button before you release the Trigger.)
You could also try to refresh your WiFi list on your phone.
Besides, it's normal it shows "no internet connection" after you connect Osmo WiFi, because it's used to connect Osmo instead providing internet network.
2016-10-7
Use props
fans89973e0a
New

United States
Offline

I had this problem as well, right out of the box.
Finally figured out the solution.
You must have your mobile divice in airplane mode. Then turn the wifi on and connect to the OSMO wifi.
Open the App and you're on your way. Your mobile divice will only display the airplane icon in the upper left but you will be connected.
Good luck!
2017-2-7
Use props
fans956173ce
New

United States
Offline

I've tried it all...2.x and 5, new app, reloaded app, upgraded firmware, Airplane mode, etc. the Osmo+ that I purchased will not maintain a reliable connection to any iOS device that I own. Going to exchange it, pray that I've got a faulty unit and try again.

I get that it's "new tech" and bound to be jinky from time to time. That said, it's a rehash of existing tech for DJI and the camera to screen connection feels like a step backwards.
2017-2-8
Use props
fansb196417f
New

Brazil
Offline

I have this problem too. I have two Android handsets. An LG G4 and a Pixel. In the LG G4, it connected to the Osmo via Wifi, but when I opened the DJI app, it only had the black screen. So I disabled the Smart Network Switch on the device and now it works. However, the option to do live broadcast does not appear to me. Do you know why?

In Pixel the problem continues. The device does not have the option to disable the Smart Network Switch, so it only works if I put in airplane mode. But I want to make a live broadcast and I can not do it that way.

Can you help me? Thank you!
2017-2-21
Use props
My V. Nguyen
lvl.2
Flight distance : 38537 ft
United States
Offline

From reading the reply blogs everyone, including me, has a problem with the Osmo+'s failure to connect the first time you open it out of the box. In my case, the battery wouldn't even charge in the charger until the second day. After that, the Osmo+ wouldn't connect to my mobile device. Finally, after connecting to the DJI GO app and "Activating The Account"(Important!), I had problems with the telemetry (ISO, speed, resolution, etc.) showing NA.
You have to try everything a few times for a few days before you can have your Osmo+ to take the first picture and video. That is a marketing flaw from DJI. When someone purchases an expensive camera, they open the box, take out the camera, and start shooting right away. Not so with this DJI Osmo+.
By the way, you can fix most common problems with the new Osmo+ under Troubleshooting section of the Osmo+ User Manual downloaded online. The manual is not included inside the box.
2017-2-26
Use props
ralibi
lvl.1
Indonesia
Offline

DJI Natalia Posted at 2016-10-7 00:38
Hi Hs4utwSZl1RU, please make sure your mobile phone is operating at either 2.4Ghz or 5.8Ghz channel. Then you could try to reset the WiFi to default settings by using the key combination (hold down the Trigger and Shutter button at the same time, then pull the power switch down until the system status indicator blinks green, release the power button before you release the Trigger.)
You could also try to refresh your WiFi list on your phone.
Besides, it's normal it shows "no internet connection" after you connect Osmo WiFi, because it's used to connect Osmo instead providing internet network.

I also have the same problem, accidentally switching wifi to 5.8Ghz. I tried using key combination to reset its wifi. It didn't work.
I also tried to connect using iPhone, but somehow the osmo is detected as Phantom 3.
Is there any other solution?

thx
2017-4-13
Use props
fans16e559f2
lvl.1
United Kingdom
Offline

I have an Osmo+ and iPhone 6. The first time I used it everything was fine. This time when I start DJI Go I can see the video link and the icons on the right but all the icons on the left are greyed out. Help! I need it for a shoot tomorrow! Also I cannot format the MSD card even though it is recording OK (I think)


2017-5-25
Use props
fans16e559f2
lvl.1
United Kingdom
Offline

Yesterday I reported that I had big problems getting the Osmo+ to connect to iPhone 6 even though it had been fine a week earlier. I deleted and reloaded the DJI Go app but then the app thought my Osmo was a Phantom and I could still not connect. Two hours on the chat to a tech did not help either.

The solution was to delete the app, restart my iPhone and re-install the app. I then started the Osmo, connected to its wifi and then opened the app. All was well. Happy now.
2017-5-26
Use props
Deckhand Camera
New

United States
Offline

There seem to be a lot of different solutions, so all I can say is what worked for me. The first thing I always try is going into Settings>Wifi>[your network name] and hitting "renew lease" all the way at the bottom. It might take a few tries, but it works eventually (at least for me). This video helps explain it better  
2017-6-13
Use props
fans1fbcdbe5
lvl.1

Brazil
Offline

LenMiddx Posted at 2016-10-5 13:37
I've had the same problems on more than one occasion.

The only solution seems to be ....... keep trying. Eventually it will connect.

Kd a opção de tradução do fórum, senão traduzir que pelos menos permita copiar o texto pra o tradutor da Google.
2017-12-9
Use props
capbat
Second Officer
Flight distance : 52726 ft
  • >>>
Canada
Offline

fans89973e0a Posted at 2017-2-7 18:22
I had this problem as well, right out of the box.
Finally figured out the solution.
You must have your mobile divice in airplane mode. Then turn the wifi on and connect to the OSMO wifi.

The Airplane Mode worked for me. I even try when connected to disable Airplane mode and the connection went off, had to re-enable Airplane mode and reconnect.
Thanks Fans......
2018-8-14
Use props
LAX1819
lvl.1
Australia
Offline

Help. I am moments away from throwing my Osmo+ i
2018-11-10
Use props
LAX1819
lvl.1
Australia
Offline

Help! I am moments away from throwing my Osmo+ in the trash (I won’t even give it away because I don’t want anyone else to suffer the same frustrations I have). The wifi connection to the camera is appalling. I have read multiple forums and have tried all the suggestions I have read. I’ve used multiple different devices. Disabled all radio comms except wifi. Reinstalled app multiple times. Etc etc. it just continuously looses wifi connection so I have no view of what is being filmed. Only way to reconnect is to power down and restart, and then it will drop out agaian and again and again. Surely DJI can put in some effort to fix this? Right now this is the most up functional device I have ever owned! This is a last desperate call for help before I drive over it with my car!
2018-11-10
Use props
fans382da290
New
United States
Offline

fans89973e0a Posted at 2017-2-7 18:22
I had this problem as well, right out of the box.
Finally figured out the solution.
You must have your mobile divice in airplane mode. Then turn the wifi on and connect to the OSMO wifi.

This needs to be upvoted! Airplane mode worked like a charm!
5-20 17:07
Use props
djiuser_XAxCzv2WZUv7
New

Offline

Greetings!
I am a Zenmuse x3 Osmo newbie. I thought I could help my dad connect the Osmo quick and clean, but as soon as everything is set up and it is time to take a picture it shows the below picture. Now, am I supposed to have a laptop that connects to my phone that’s connected to the Osmo? Or what’s the deal? I go into the WiFi network and connect to the Osmo link, and once I launch the app it says the Osmo is connected, but the Osmo reads “no internet connection” when I go back as if I was connecting to the Osmo “WiFi” in the first place. Help would be appreciated!
9-15 10:40
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules