Please select Into the mobile phone version | Continue to access the computer ver.
Downlink image terrible quality
12Next >
4136 57 2016-10-21
Uploading and Loding Picture ...(0/1)
o(^-^)o
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Morning all,

I did a firmware update to my Phantom 4 tx on Sunday, and since then, I've been having dreadful problems with the quality of the downlink displayed on my tablet(s).  I'm basically getting an unusable picture quality, where there are grey and coloured blocks and bands appearing over the image, randomly.  

At first I thought it might have been interference from a Wifi source or similar, as I was testing in my back garden.  However, I since tried it at a local park, and I have found the problem to be the same, if not worse.

Despite the dreadful breakup in the image, the TX and HD signal strength meters are showing full bars.  If I look into the HD screen in the options, ther doesn't appear to be any big red bars on the channel map that would indicate interfence.

I have also tried the 32 channel mod (I'm in the UK btw) and I am getting the same issue, regardless of whether the channel is set to auto, or any other fixed channel.  Changing the downlink Mbps setting has no effect either.

I have tried using two devices (Samsung S2 tablet, s7 edge phone) both with the same result.

Last week (before the update) I was getting a perfect image, and was able to fly FPV style out to sabout 600 metres at low level, with no issues at all.  Today, I am getting the image quality loss even whgen the TX is within a few metres of the Phantom 4.

Has anyone else seen this?  I've attached some screenshots, and I'm uploading a video showing the issue now.  Any advice would be appreciated thanks!
Screenshot_20161021-094310.png
Screenshot_20161021-094340.png
2016-10-21
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline

Hi Andy, it occurred after APP upgrading, or remote, aircraft upgrading? all are up to date recently, right?
Have you tried to delete the APP, then re-install it? Please cool it down and turn off all background programs.
Is an IOS device available for you to have a test?
2016-10-21
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

A couple more screenshots.

and a video here:



Screenshot_20161021-100054.png
Screenshot_20161021-095928.png
2016-10-21
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Hi DJI Natalia.

I'm on the latest firmware for the P4, and the v1.8.0 tx firmware.  App is 3.0.0 as updated on sunday.  I always close all the background programs before starting DJI Go.  Once I have the map cached too, I put my tablet in flight mode.

I don't have any ios devices unfortunately, we are an Android and Windows household.  I shall try deleting and reinstalling now though.

Thanks
Andy

2016-10-21
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Just tried deleting the DJI Go app, and reinstalling.  Same result = rubbish image quality, and grey/pink/green bars appearing randomly over the picture....

Andy
2016-10-21
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline

andy@andy-sayle Posted at 2016-10-21 19:05
Just tried deleting the DJI Go app, and reinstalling.  Same result = rubbish image quality, and grey ...

Sorry to hear about that, will transfer this feedback to our relevant department for further evaluation.
And may I know do you have another brand android phone to have a try?
Or you could try to re-install the old APP. Here is the link: https://apkpure.com/dji-go/dji.pilot
2016-10-21
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Thanks.  I only have Samsung devices running Android.  I have arranged for a mate to let me try his ipad out though, so I'll see if that helps.

I'll try the previous version of the app, and see how that goes.  Thanks

Andy
2016-10-21
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline

andy@andy-sayle Posted at 2016-10-21 19:33
Thanks.  I only have Samsung devices running Android.  I have arranged for a mate to let me try his  ...

No problem, please keep us posted, thanks for your patience and support.
2016-10-21
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

No problem.  So long as I can get it sorted before Wednesday, I'll be happy.  I have a job on that really needs a stable down link!
2016-10-21
Use props
Aardvark
First Officer
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

andy@andy-sayle Posted at 2016-10-21 12:53
No problem.  So long as I can get it sorted before Wednesday, I'll be happy.  I have a job on that r ...

As the trigger seems to be the controller update have you tried resetting controller and doing a re-link to the aircraft.

I believe the reset on the GL300C is C1+C2+'Shutter Button' (top right nearest antenna), and relink through DJI Go Remote Controller Settings menu.
2016-10-21
Use props
Aardvark
First Officer
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

DJI Natalia Posted at 2016-10-21 12:38
No problem, please keep us posted, thanks for your patience and support.

DJI Natalia

I believe the reset on the GL300C is C1+C2+'Shutter Button' (top right nearest antenna).

Can you please confirm that this is correct, I have mentioned it in replies and when I try it myself I get an audio indication (Da-DaDaDa). Reason I ask is that I have seen one or two alternative suggestions, which makes me wonder if my advice was correct.
2016-10-21
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

I'll try that today, a reset can't do any harm.  If no luck, I'll have a crack at downgrading the app, and possibly the firmweare on the TX if I get no luck.  I'm hopefully getting my hands on an iphone 6 to try out today too.  Fingers crossed this will help findout where the problem lies...

Andy
2016-10-22
Use props
bob.lionel.gmai
lvl.2
Flight distance : 89551 ft
  • >>>
United States
Offline

Having the same issues as are Apple users and everyone else. I know two other photos here locally that are having the issues as well. Do you have a problem and you need to fix this quickly. Do you not qa  your software releases? If you plug in goggles to HDMI the feed is fine.
2016-10-22
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

DJI Natalia Posted at 2016-10-21 12:38
No problem, please keep us posted, thanks for your patience and support.

I've ran a few more tests today.  No iOS device to test unfortunately, but another Android device (I think an S5 mobile phone) and that worked better than my s7 Edge, and s2 tablet.  There was still a lot of break up of the picture, grey bands, and purpley bits, enough to make it really difficult, at times impossible, to fly FPV style.

I have also done a couple of tests in a location where the closest habitation is about a mile and a half away.  In the past I have done a 1600m flight here with  my p4, with no issues at all.  Today, on every android device i tested, I couldn't get further than about 10 metres.

One thing I did notice, is that the video recorded to the sd card, is fine.  Nice and smooth as it has always been.  it is only the displayed image on the Go App (and the cached video on the device) that is all broken up, and covered with strange bands of colour.

The other test I have run, is flying my inspire Pro.  That works perfect.  No image break up, other than at distance, when the signal strength is dropping out (>1000m).  same app, same devices as tested and not working with the P4.  Different TX though.

I'm going to try a previous version of the app tonight, and report back.

Andy

2016-10-22
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Oh, and I've seen an info message pop up a few times now, but not managed to screenshot it. It said "Braking Now!  No use to move the stick right. Avoid the obstacle."  Which is odd, I've not seen it before, and it occured whilst I was flying about 50 metres up, and the nearest actual obstacle, was a tree that was around 250 metres away, and probably 25 metres at its highest point.  It's appearance almost always seem to coincide with the video break up (although I spent a lot of the flight flying line of sight, and not watching the video).

Someone else (thanks RemusE) on the forum captured it though, I've copied the image for reference here:
143508soep9e7fzuofenig.png
2016-10-22
Use props
MD_Icarus
lvl.4
United States
Offline

I would go back to 2.8.1 and start over, by creating a different app for each craft.
Then, once it gets proved out for all craft,  I will then add another app which will also have live streaming option.

Otherwise, our Green Screen Club will not be able to accept any more members!
2016-10-22
Use props
davejmer
lvl.2
Flight distance : 329140 ft
United States
Offline

Andy it seems like Remote control firmware 1.7 and 1.8 have the same bug you are describing. Maybe try rolling back to version 1.6. That's what I run without any issue although I can no longer get my HDMI out to work with streaming live via Tricaster HDMI to SDI input but it works fine when outputting straight to an HDMI monitor.  Just hope your previous firmware was 1.6...

https://www.youtube.com/shared?ci=JETmBe9SZTs
2016-10-22
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

I've just managed to roll back to a previous version of the android app (v2.9.1) so I'll give that a shot first.  If that fails, I'll try rolling back the TX firmware, and see if that helps.

I'm half considering splashing out on a little iPad mini to see if that is any better!

Andy
2016-10-22
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Right.  Rolling back the DJI Go App version to either 2.9.0 or 2.8.4 doesn't make a blind bit of difference.  Still horrible breakup of the image, even when the TX and P4 are in the same room.  I didn't even bother test flying it, as it was rubbish.

I've not rolled back the TX firmware from 1.8.0 to 1.6.0.  Everything is powered up next to me, and the picture has been fine for the last 5 minutes.  Actually, I have just seen some slight pixellisation of the image, probably because I am about 3 feet from my Wifi hub.  I'll see how it goes, and test fly in the morning.  Fingers crossed.

Andy
2016-10-22
Use props
Aardvark
First Officer
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

I just rolled back my RC to 1.6 (there is no 1.7) and tested with the following

App' 3.0.0 running on my Nexus 7 (2013)
Firmware 1.2.503 running on P4
Firmware 1.6 running on GL300C remote controller
Uninstalled and re-installed DJI Go

With USB debugging enabled and USB config' set to MTP all appears to work with no pixelation of screen.

Then upgraded RC again to 1.8

App' 3.0.0 running on my Nexus 7 (2013)
Firmware 1.2.503 running on P4
Firmware 1.8 running on GL300C remote controller
Uninstalled and re-installed DJI Go

Image on screen is pixelated.

All works well with my iPad pro 9.7 but not the Nexus 7 (2013) running Android 6.0.1

Not wholly conclusive, but points towards RC update 1.8 as being the culprit for pixilation on Android devices.
2016-10-22
Use props
MD_Icarus
lvl.4
United States
Offline

If possible,

Try app 2.9.1 and RC=1.8

I can not fly for days due to bad weather, but that combination seems to be doing ok when I test it idling. (some pixelation, but not too horrible as some have reported).  But then again, I have not flown for a week and we will have bad weather for another few days.
2016-10-22
Use props
kirk2579
Second Officer
Flight distance : 37415 ft
United States
Offline

andy@andy-sayle Posted at 2016-10-22 18:07
Right.  Rolling back the DJI Go App version to either 2.9.0 or 2.8.4 doesn't make a blind bit of dif ...

your not alone

10 months of perfect flights with p3p and shield k1
bought same week in December

worked fine until the rc update to fix the gl300a RC.
sadly MY GL300A that used to be perfect now has pretty colored banding all of a sudden.
same day as update of RC-----any connection you think!
2016-10-22
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

MD_Icarus Posted at 2016-10-23 04:53
If possible,

Try app 2.9.1 and RC=1.8

Just tried it.  No luck.  Still horrible banding, grey patches, and a really laggy video signal.  SD card recorded video is fine.

RC v1.6.0 and Go App v2.8.4 is working for me on the bench at the moment.  just waiting for some rain to blow over before trying a test at a few hundred metres range...

Andy
2016-10-22
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline

Aardvark Posted at 2016-10-21 20:14
DJI Natalia

I believe the reset on the GL300C is C1+C2+'Shutter Button' (top right nearest antenn ...

Aardvark, you are correct, pressing C1+C2+Shutter button can reset the remote.
2016-10-23
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline

andy@andy-sayle Posted at 2016-10-23 04:18
Oh, and I've seen an info message pop up a few times now, but not managed to screenshot it. It said  ...

Thank you so much for your updating with the result, for this message, we will transfer it to our relevant department to have a evaluation, thanks.
2016-10-23
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

DJI Natalia Posted at 2016-10-23 09:19
Thank you so much for your updating with the result, for this message, we will transfer it to our  ...

No problem.

I got out this afternoon to do some real world testing again.  If I use the rc firmware v1.6.0 and the app v2.8.4 it is working great.  I flew out to about 600 metres or so, with no breakup, other than when I shielded the antennas on purpose.

If I update the TX firmware to v1.8.0, I am getting the video break up consistently, regardless of range.

I'm leaving it on the 1.6.0 firmware for now.  I'll test out the v1.6.0 firmware with the v3.0.0 android app tomorrow.

Andy
2016-10-23
Use props
Aardvark
First Officer
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

DJI Natalia Posted at 2016-10-23 09:15
Aardvark, you are correct, pressing C1+C2+Shutter button can reset the remote.

Thank you
2016-10-23
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline

andy@andy-sayle Posted at 2016-10-24 06:17
No problem.

I got out this afternoon to do some real world testing again.  If I use the rc firmwa ...

Hi Andy, thank you so much for your updating, and glad to hear it's working with V1.6.0 and V2.8.4.
We will pay attention to it.
2016-10-23
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline


No problem~thank you so much for helping others on this forum, great!
2016-10-23
Use props
DJI Natalia
Administrator
Flight distance : 318 ft

Offline

andy@andy-sayle Posted at 2016-10-24 06:17
No problem.

I got out this afternoon to do some real world testing again.  If I use the rc firmwa ...

Hi Andy, we have tested S7 edge on our end with the latest version for APP, RC and aircraft, there is no issue with the image transmission.
We have released V3.0.1 app for android, would you please install this one and check again?
Please keep us posted with the result, thanks.
2016-10-25
Use props
vandruten
lvl.3

Indonesia
Offline

andy@andy-sayle Posted at 2016-10-23 03:18
Oh, and I've seen an info message pop up a few times now, but not managed to screenshot it. It said  ...

Reading the warning sign made me feel so hopeless, nothing I can do than just to hope that the super expensive bird will be aa okay...
2016-10-25
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

DJI Natalia Posted at 2016-10-26 04:09
Hi Andy, we have tested S7 edge on our end with the latest version for APP, RC and aircraft, there ...

I noticed there was an app update available today.  I'll get it installed after work today, and tested, hopefully this evening, if not tomorrow, and report back.

2016-10-26
Use props
rallred48
lvl.2
United States
Offline

Andy I know what your Problem is. I had the same after I updated my firm ware to 1.8.0 It took several hours with the help of my friends on here trouble shooting this issue.
Go back to the firm wear you were using  it was more than likely 1.6.0 we did and all my Tablet issue went a way.
Just thought I would share that with you.

Ron
2016-10-26
Use props
Aardvark
First Officer
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

I have just tried the latest Android DJI Go V3.0.1, and all now appears to be working well.

App' 3.0.1 running on my Nexus 7 (2013)
Firmware 1.2.503 running on P4
Firmware 1.8 running on GL300C remote controller
2016-10-26
Use props
rs1
New

United States
Offline

andy@andy-sayle Posted at 2016-10-21 03:43
A couple more screenshots.

and a video here:

Bought a brand new Phantom 4. It had to be sent in for DJI repair out of the box due to poor video signal. They replaced the camera and said there was something wrong with the board. Just got it back. It has the exact same problem. I've spent over 6 hours on the phone with DJI tech problem solving without success. Lost 9 days while the unit was being repaired. I've tried every thing under the sun and the only thing that works slightly is to lower image transmission all the way down and pick the best custom channel you can find out of the eight (tried installing the DJI config to see all 32 channels but that didn't work and only have eight still...apparently the latest firmware might prevent you from hacking to 32 channels). This is by far the worst product I've ever purchased in my life...
Bought a brand new Osmo too....that just got shipped out for repair also straight out of the box because it can't connect to the Osmo network which would not be a problem if you could just use a cable!!!!!!!!!! No, not a option to hook it up with a cable.....
So both my brand new purchases from DJI had to be sent in for repair straight out of the box....the Phantom was just returned after repair and it's still not working properly. Worst products I have ever bought!!!!!!!!!
2016-10-26
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Aardvark Posted at 2016-10-26 12:54
I have just tried the latest Android DJI Go V3.0.1, and all now appears to be working well.

App' 3. ...

That's good to hear.

I've got a comprehensive day of testing planned for the weekend, mainly because I have a Mavic sat on my bench ready to fly, but also to test out the new App with the P4.  I need to get to the bottom of a bit of vibration that seems to be affecting the X5 on my Inspire too.

Cheers
Andy
2016-10-27
Use props
Aardvark
First Officer
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

andy@andy-sayle Posted at 2016-10-27 10:07
That's good to hear.

I've got a comprehensive day of testing planned for the weekend, mainly beca ...

"mainly because I have a Mavic sat on my bench ready to fly,"

A good weekend ahead then, the deliveries must be arriving now. Will be interesting to see all the reports over the weekend from the new users.

Have a good one.

2016-10-27
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

Mavic 1st test fly done in the office carpark at lunch.  V. nice!
2016-10-27
Use props
Aardvark
First Officer
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

andy@andy-sayle Posted at 2016-10-27 13:23
Mavic 1st test fly done in the office carpark at lunch.  V. nice!



And first impressions are good ?

I assume it would be the same setup for them with the initial IMU, Gimbal, sensor, RC & compass calibrations ?

I'd better keep on topic, has that update sorted your image problem ?
2016-10-28
Use props
andy
lvl.4
Flight distance : 3358875 ft
  • >>>
United Kingdom
Offline

GOt a bit bogged down with work yesterday, but I've tested the P4 on rc firmware v1.6.0 and the latest android app (v3.0.1) and it is working good.  I'm planning on updating the P4 tx itoday, and will test fly soon after.

The Mavic is ace.  Only had chance for two flights so far, and it flies like a mini Phantom.  If anything it is slightly less stable in turbulent conditions, but that's to be expected given it's lack of gravity compared to the Phantom.  The TX is a bit toylike, but I can put up with that for compactness.  I'll be honest, and I just updated the firmware, and flew it.  I didn't do any calibrations, and it worked fine!  But yes, there are all the usual calibrations, and the interface in DJI Go is the same.

I haven't really tested the camera out yet, just a few snaps.  Will do that this afternoon hopefully, if SWMBO will let me out to play ha ha!

Andy
2016-10-28
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules