Please select Into the mobile phone version | Continue to access the computer ver.
Sudden Battery Failure
1539 12 2015-2-6
Uploading and Loding Picture ...(0/1)
o(^-^)o
MilspecJSC
lvl.3

United States
Offline

Today, after completing a successful preflight check of my P2V+ and with a fully charged battery, I launched for a quick flight around the local sports park. Less than a minute after launch and at ~200ft I received a warning message: Battery Error; Damaged Cell Warning, Not Recommand To Fly (BTW, exact spelling). I immediately landed and checked the battery. After completing the battery status check (10-second cell condition test) I was surprized that the battery was indeed failing (now only one indicator). It should be noted that I check the battery status as part of my pre-flight checklist. Before this flight, the battery checked out fine (all four indicators) with only 2 cycles on the battery. Battery version: 2.0, current firmware.
I believe the issue to be simply a defective battery but if anyone has experienced a similar situation, I would like to hear from you.


The attached screenshot is the error message I received. Note the battery percentage of 89% after less than two minutes of flight time.

IMG_1472.png
2015-2-6
Use props
PhantomHelp
lvl.4

United States
Offline

Is the battery puffy? Have you ever stored it fully charged for a long period of time?
2015-2-6
Use props
MilspecJSC
lvl.3

United States
Offline

PhantomHelp Posted at 2015-2-7 07:23
Is the battery puffy? Have you ever stored it fully charged for a long period of time?

No.

In fact, the battery was brand new, only two cycles. No signs whatsoever of bloat or mishandling. It was probably just a weak battery and all it took was a few cycles to show the problem. I'm glad that it happened close by and not at a distance.

I should have said that I also received visual confirmation from the rear LED indicators of the failure (fast-blinking RED) but they were only visible because of the close proximity to me.
2015-2-6
Use props
rod
First Officer

New Zealand
Offline

Hi, having done the 10 second cell test did you cross reference that on the assistant program when you got home, and did it confirm the 10 second test?
Rod
2015-2-6
Use props
markus2015
Second Officer

Germany
Offline

Try this, remove the battery and press/hold the on button for approx 8 seconds until it flashes, then let go and see how many of the 4 LED indcators are on. 4= up to 100% battery health, 3= up to 75% ...
2015-2-6
Use props
markus2015
Second Officer

Germany
Offline

sorry, you already did that, must have over read this.
2015-2-6
Use props
MilspecJSC
lvl.3

United States
Offline

rod Posted at 2015-2-7 07:31
Hi, having done the 10 second cell test did you cross reference that on the assistant program when y ...

I hadn't until you asked.

From the Assistant, everything looks just fine but testing the battery again, same one LED. Taking no chances and I'm returning the battery.

Screenshot 2015-02-06 15.38.25.png
2015-2-6
Use props
MilspecJSC
lvl.3

United States
Offline

markus2015 Posted at 2015-2-7 07:34
Try this, remove the battery and press/hold the on button for approx 8 seconds until it flashes, the ...

That's just what I did. Only 1 LED. Of note, prior to the flight, the same test resulted in all 4.
2015-2-6
Use props
rod
First Officer

New Zealand
Offline

MilspecJSC Posted at 2015-2-7 07:48
I hadn't until you asked.

From the Assistant, everything looks just fine but testing the batte ...

Hi again, thanks for confirming the results of both tests.  I am a great believer in data!  However, it now raises the question as to what is going on.  

The assistant isn't reporting a problem, and the 10 sec test is.  I notice that the MV levels on the cells have a range.  Maybe some of our more technical contributors could comment on what is acceptable and what isn't here.  My concern is that the assistant check seems to be invalid which makes its value questionable.   Hmmmmm---

Rod
2015-2-6
Use props
Gerry1124
Captain

United States
Offline

rod Posted at 2015-2-7 08:01
Hi again, thanks for confirming the results of both tests.  I am a great believer in data!  Howeve ...

When you connect it to the PT2 program, what does your battery page tell you on the individual cell voltage or any pop up messages?
2015-2-6
Use props
Jamie Hellmich
Second Officer

United States
Offline

MilspecJSC Posted at 2015-2-7 07:48
I hadn't until you asked.

From the Assistant, everything looks just fine but testing the batte ...

Yep, Cell 1 is out of balance range.  Send it back.  Or try cycling it, and if that doesn't fix it... then send it back.
2015-2-6
Use props
MilspecJSC
lvl.3

United States
Offline

Gerry, I attached a screenshot of the PT2 program. Cell voltages are unbalanced which may be the culprit. No pop-up messages received.

Jamie, I've already processed an RMA and a replacement is already on it's way (thanks DroneCampsRC).
2015-2-6
Use props
Gerry1124
Captain

United States
Offline

MilspecJSC Posted at 2015-2-7 09:54
Gerry, I attached a screenshot of the PT2 program. Cell voltages are unbalanced which may be the cul ...

I saw that after I had posted.
2015-2-6
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules