Please select Into the mobile phone version | Continue to access the computer ver.
Gimbal Disconnected?! - SOLVED?
13033 29 2016-11-16 13:08:34
ctopysf
lvl.2
United States
Offline

I have had fewer than 20 flights on my Mavic and now when I connect to it with the DJI Go App, the Gimbal Status says "Gimbal Disconnected". I have a (blurry) image and the gimbal appears to be powered, but it isn't responding to any commands. I can't focus it, and i can't adjust the tilt or change the mode. I tried removing and reinstalling DJI Go, rebooting the phone, I even tried a different device..with the same results.

The last time I flew, it was completely uneventful. I flew out, flew back, landed on flat concrete,powered it off, then put the gimbal clamp and cover on it and put it away.

Anyone seen this before?

I just spoke with support in chat, and they told me to go do an IMU calibration and then a gimbal calibration. oddly, the video they pointed me to was for the Phantom 3. Im guessing its the same process. I'll report back the results.
2016-11-16 13:08:34
Use props
dotfiles
lvl.3
United States
Offline

Yes, report back after both calibrations, you may also want to try resetting factory settings with the Assistant 2.
2016-11-16 13:26:26
Use props
ctopysf
lvl.2
United States
Offline

The IMU calibration completed, but it wasn't able to start the gimbal calibration. When I click ok to start, it doesnt do anything other than dismiss the window. Did the factory reset in Assistant 2 but it didn't help.



2016-11-16 13:33:50
Use props
DJI-Ken
DJI team
Flight distance : 444792
United States
Offline

ctopysf Posted at 2016-11-17 05:33
The IMU calibration completed, but it wasn't able to start the gimbal calibration. When I click ok t ...

Can you connect it to the Assistant2 and do a factory restore and then see what happens.
I do find it strange that one day it worked and the next day it didn't.If a factory reset or reinstaling the firmware doesn't clear it up then please contact support and send the aircraft in for repair.
2016-11-16 13:50:09
Use props
ctopysf
lvl.2
United States
Offline

I just reset it in Assistant 2. Didn't help at all.
I am totally baffled too. I should note that at one point, maybe my 5th flight or so, the gimbal became non-responsive. I landed the Mavic, reset it and it continued to work after that. I honestly just figured it was a temporary glitch, but it makes me wonder if perhaps the gimbal cable wasn't securely attached at the factory.





2016-11-16 13:56:16
Use props
ctopysf
lvl.2
United States
Offline

DJI-Ken Posted at 2016-11-16 13:50
Can you connect it to the Assistant2 and do a factory restore and then see what happens.
I do find  ...

Ok, so this is the strangest thing.

As I was packing up my Mavic to get ready to ship back, I replaced the 32GB microsd card that I had in there with the card that came with the Mavic and it occurred to me to just double check it, you never know. It started working again.

I checked the 32gb card in my pc using a flash memory toolkit to scan for errors, and it seemed to be fine. To see if that was really the cause, I put the 32gb card back in the Mavic, and the gimbal became non-responsive again.

I put the 16gb card back in, it started working again.

Should I still send it back? Should I just not use that card? I'm not sure what to do at this point.

Edit: I just popped the suspect card into my P3 Pro and it works just fine in there. Something unique to the Mavic, or perhaps just to my Mavic.
2016-11-17 13:37:09
Use props
Petroboy
Second Officer
Flight distance : 1122
Canada
Offline

ctopysf Posted at 2016-11-17 14:37
Ok, so this is the strangest thing.

As I was packing up my Mavic to get ready to ship back, I repl ...

Maybe try formatting the 32 GB card while it's in the Mavic and see if that makes the gimbal responsive again?
2016-11-17 13:53:18
Use props
ctopysf
lvl.2
United States
Offline

Petroboy Posted at 2016-11-17 13:53
Maybe try formatting the 32 GB card while it's in the Mavic and see if that makes the gimbal respo ...

When I do that, it gives a "Format timed out" error message.
2016-11-17 13:55:10
Use props
DJI-Ken
DJI team
Flight distance : 444792
United States
Offline

ctopysf Posted at 2016-11-18 05:37
Ok, so this is the strangest thing.

As I was packing up my Mavic to get ready to ship back, I repl ...

What exactly SD card is that. It has to be a Class 10 or UHS-1 ratiing.
Try some other cards that meet the specs and if they don't work then send it in.
2016-11-17 13:55:17
Use props
Petroboy
Second Officer
Flight distance : 1122
Canada
Offline

ctopysf Posted at 2016-11-17 14:55
When I do that, it gives a "Format timed out" error message.

I would say the card is corrupted and you should buy another one.  I had a micro SD card in a Net Camera once that got corrupted and would also not format.  Had to replace the card.  Sounds like a corrupted SD card will affect things on the Mavic.  Weird.
2016-11-17 14:01:24
Use props
ctopysf
lvl.2
United States
Offline

DJI-Ken Posted at 2016-11-17 13:55
What exactly SD card is that. It has to be a Class 10 or UHS-1 ratiing.
Try some other cards that  ...

Just trying a bunch of different cards, and they seem to be working.

The one that doesn't work in the Mavic is a "PNY Elite-X 32GB microSDHC Card UHS-I, U3". This card works in my P3P
2016-11-17 14:01:51
Use props
DJI-Ken
DJI team
Flight distance : 444792
United States
Offline

ctopysf Posted at 2016-11-18 06:01
Just trying a bunch of different cards, and they seem to be working.

The one that doesn't work in ...

That is strange, well at least you know it's the SD card.
Maybe it's damaged somehow, does it work in your other devices?
2016-11-17 14:05:12
Use props
ctopysf
lvl.2
United States
Offline

DJI-Ken Posted at 2016-11-17 14:05
That is strange, well at least you know it's the SD card.
Maybe it's damaged somehow, does it work ...

Very strange. I am very happy that I don't have to send my mavic back though.
It works in my PC and it also works in my P3 Pro...just tested it. I'll just put a sharpie mark on it so I know not to put it in the Mavic.
2016-11-17 14:07:00
Use props
Anoniem
lvl.4
Flight distance : 1732
Netherlands
Offline

put it in your PC and do a real format, not quick format. Then try again.
2016-11-17 14:09:52
Use props
DJI-Ken
DJI team
Flight distance : 444792
United States
Offline

ctopysf Posted at 2016-11-18 06:07
Very strange. I am very happy that I don't have to send my mavic back though.
It works in ...

Sounds good, and yes follow the above post and format in the computer and see what happens.
2016-11-17 14:20:28
Use props
ctopysf
lvl.2
United States
Offline

Anoniem Posted at 2016-11-17 14:09
put it in your PC and do a real format, not quick format. Then try again.

Did a full format in my PC. No luck. Tried 5 other cards that all seem to work fine though.
2016-11-17 14:28:32
Use props
StianGel
Second Officer
Flight distance : 151642
United Kingdom
Offline

I had a card that worked fine in my previous phone a while back. One day id stopped working in the phone, but worked fine in a camera and my pc.
Another thing to add for a troubleshooting guide.
2016-11-17 14:39:18
Use props
aesculus
lvl.2
United States
Offline

Man am I glad I found this thread!  I had the same thing happen to me today.  At first I thought it was caused by the ND filter I had just installed.  I was trying new filters out and assumed they were causing a gimbal error.  So when I took it off and restarted the Mavic I was dismayed to see the error was still there.  After swapping out the SD card for the one that came with the Mavic, all was well again.  The card is a SanDisk Extreme 64GB microSDXC UHS-I.  It is new but I had used it all weekend with no issues.

So then I remembered that I had copied a bunch of files to the card the night before using a Mac, and then deleted all of them on a Linux machine before I re-installed the card in the Mavic.  So apparently I did something to corrupt the card?  I went ahead and reformatted it to exFAT (not quick format) and now the Mavic likes the card again.

Who would have ever thought an SD card would cause the gimbal to malfunction?
2017-3-6 12:36:44
Use props
gjanumavic
lvl.1
Flight distance : 10121
United States
Offline

Scary experience: I finished flying my MAVIC Pro last night, everything was fine. Took out my SANDISK Extreme PRO 64Gb micro-SD card to view the film clips on my PC. Without much thinking about it, I changed, on the PC, the name of one of the files on the SD card to something more descriptive (normal MAVIC-generated file names are like DJI_####.MP4). This morning I put the SD card back in the MAVIC and I go to fly the MAVIC and in my DJI GO 4 app running on my iPad 2 mini, the "Aircraft Status" shows "Gimbal disconnected", the picture from the MAVIC is out of focus and blinking and all camera settings show N/A. It made me think that there is a hardware error, gimbal has a bad wire connection. I tried restarting the MAVIC, the RC, the app multiple times, but the problem would not go away. Fortunately I thought of asking Google and found this discussion thread! I put a different SD card in the MAVIC and everything is fine. I put back in the card with the changed file name and the problem was back. So a wrongly formatted SD card can generate an error message "Gimbal disconnected" and disable the MAVIC camera. Talk about misleading error messages.....
2017-4-1 10:30:49
Use props
Cgibsonmm
lvl.1
United States
Offline

Try a new cord, I had the same issue.. looks like an error with the cable that connects the phone to the controller.
2017-4-2 17:37:04
Use props
Cgibsonmm
lvl.1
United States
Offline

ctopysf Posted at 2016-11-16 13:33
The IMU calibration completed, but it wasn't able to start the gimbal calibration. When I click ok to start, it doesnt do anything other than dismiss the window. Did the factory reset in Assistant 2 but it didn't help.

Change the cable that connects the phone to the controller
2017-4-2 17:37:32
Use props
fans78acada1
lvl.1
Germany
Offline

Hi, I had the same problem of a gimbal that was disconnected. The solution was: when pulling out the SD card from the slot I unintentionally changed the tiny switch (Remote control setting) besides the slot from RC to Wifi. Putting it back to RC solved the gimbal disconnection problem. Hope this helps others. Best regards
2017-5-6 00:26:48
Use props
fans47c0bb7e
lvl.1
Brazil
Offline

I changed the SD Card and problem continues. Gimbal disconnects randomly. I tried without any SD card and having the same problem.
2017-6-25 16:46:47
Use props
Pa1nter
lvl.1
Flight distance : 127288
Australia
Offline

I just had the same problem,it flew perfect, landed,took memory card out and empty files in computer,put card back in,restart and no gimbal connection??
I did have a blurry vision on tablet but had no control over gimbal.
A couple of tell tale signs were, I couldn't reset camera settings? I couldn't find video record button and it said I didn't have a memory card in?
Consulted doctor google AKA dji forum and found memory card issue, found another card and now, Life is good again.The card was a 32gb Sandisk Extreme U3 and another thing is when I went to format properly in computer,it would freeze my computer when I went to right click to format.
I put the same type of card back in
2017-6-30 19:13:15
Use props
Backpacker
lvl.1
Ukraine
Offline

Gimbal disconnected error. I did everything, but did get success. Very strange it was not any crashes. Suddenly I'v got this error and I don't know what to do. Any suggestion ?
2017-7-16 13:54:22
Use props
fans0837537b
lvl.1
Flight distance : 10001
Netherlands
Offline

ctopysf Posted at 2016-11-17 13:37
Ok, so this is the strangest thing.

As I was packing up my Mavic to get ready to ship back, I replaced the 32GB microsd card that I had in there with the card that came with the Mavic and it occurred to me to just double check it, you never know. It started working again.

Hi
Format your card in your computer with exFat format. I did this on my MAC with the diskutility
Then put it in your MP again and format it within your MP in the DJO GO App
The all works fine again.

WARNING TO DJI
It is absurd that the card status influences the operating system on the Mavic Pro in such a manner that this can happen.
DJI solve this!
2017-8-13 06:16:55
Use props
VictorJW
lvl.1
Germany
Offline

I have had this error since unboxing my new Mavic a few days ago, both with the original and a replacement card. Is my Mavic DOA? I can usually get video back by rebooting the controller, and restarting the app, but I can't/don't want to do that in flight.
2017-8-22 12:20:15
Use props
VictorJW
lvl.1
Germany
Offline

I think I will have to return my Mavic. Finally got to fly it today. 3 flights all under 3 minutes, all the got a disconnection within a minute of starting. Only got 60 seconds of video recorded. After waiting so long to get a drone, 2 years in my case (1 year alone waiting for the Mavic) and then waiting after delivery for the insurance, this is more than frustrating.
2017-8-24 11:40:04
Use props
ImHereToCrash
First Officer
Flight distance : 538170
United States
Offline

VictorJW Posted at 2017-8-24 11:40
I think I will have to return my Mavic. Finally got to fly it today. 3 flights all under 3 minutes, all the got a disconnection within a minute of starting. Only got 60 seconds of video recorded. After waiting so long to get a drone, 2 years in my case (1 year alone waiting for the Mavic) and then waiting after delivery for the insurance, this is more than frustrating.

dont send it back its likely another issue somewhere., my samsung galaxy S8 will put a fight up against the RC OTG..constant and random disconnections and even disrupts normal mavic behavior!    i found the cure.. kill the app running and use the usb port on bottom of the RC (full size one) plug phone into that and let the RC auto launch the dji go app on phone automatically.. it may ask for setting it to default, click yes and agree.. this should in theory cure the issue...if still having an issue, kill the app again, turn of mavic pro, and RC restart phone.. dont start the app on phone or tablet yet.. start mavic first then RC then let the app auto launch or attempt to.. that should fix it..

ya i was pretty upset and p*ssed off too when at first my mavic was behaving badly with OTG to my S8 until i decided to reboot everything and use the buttom usb port..cured my issues not even a single crash since.. it was crash city using the port on the side of the RC
2017-8-24 12:06:45
Use props
James Dowlen
lvl.1
Flight distance : 4824
United States
Offline

ctopysf Posted at 2016-11-17 13:37
Ok, so this is the strangest thing.

As I was packing up my Mavic to get ready to ship back, I replaced the 32GB microsd card that I had in there with the card that came with the Mavic and it occurred to me to just double check it, you never know. It started working again.

I had a very similar episode with my Mavic. The gimbal suddenly would not transmitt signal to my controller. I got the "NO IMAGE TRANSMISSION  error. and GIMBAL DISCONNECTED error. I was ready to start the painful process of tech support etc. Thankfully I found this thread. I tried inserting different SD card and to my amazement the gimbal now is connected and camera works now.

I reformatted the SD card in my computer and retried it. This did the trick.

I had renamed some of the DJI files on that card (as was mentioned in an earlier post). I am suspicious that this was the culprit!


I will go test the camera now on on flight and hope for the best.
2017-9-20 10:19:44
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next