Please select Into the mobile phone version | Continue to access the computer ver.
Losing Connection between Mavic and RC-Controller with iPhone 7Plus
30481 196 2016-11-20
Uploading and Loding Picture ...(0/1)
o(^-^)o
MAHD
lvl.2

Spain
Offline

Latest FW upgrade didn't solve the problem. I have to use Apple Lighting cable or switch to airplane mode to avoid camera signal lost.
2017-2-14
Use props
GeeP
lvl.1
France
Offline

Woodwanger Posted at 2017-2-14 14:14
Thanks for the update....I will give it a try,
I thought you could fly the drone without the phone even connected? Just using the RC obviously you would loose all the options in the app and video feed but surly the RC shouldn't disconnect from the drone at random!
Or have I got this wrong?

So, I did 2 test flights this morning with this configuration:
- iPhone set to plane mode (no wireless communication)
- USB-lighthning cable replaced by an Apple cable (the one provided with every iPhones)
Result: no more disconnection, all went perfectly well.
As a a conclusion, I don't exactly know where the problem comes from (probably interferences between iPhone and DJI lightning cable) BUT, I now have a reliable configuration.

Additional tip&trick: When in airplane mode, the app is not able to load the map around you. So, initialize the Mavic with plane mode = OFF, give the App a minute to load the map from internet, and switch your phone to plane mode.
2017-2-15
Use props
GeeP
lvl.1
France
Offline

MAHD Posted at 2017-2-14 14:20
Latest FW upgrade didn't solve the problem. I have to use Apple Lighting cable or switch to airplane mode to avoid camera signal lost.

yep. same here.
2017-2-15
Use props
zaphforty7
lvl.4
Flight distance : 915928 ft
United States
Offline

Just got my repair report back from DJI. They're replacing the whole aircraft. They didn't say what the issue was though. Luckily it was fully covered (+$1000).
2017-2-16
Use props
DanH
lvl.3
Flight distance : 315177 ft
France
Offline

Hi all,

I received my Mavic Pro last thursday and am facing the same issue  with video signal loss when using the standard DJI cable.

Using Iphone 6plus, latest firmware for the Mavic and the controller, fully charged Iphone and Mavic batteries.

Losing video signal on 5 out of 5 times after a few seconds to 1 minute maximum.

When using a short (+/- 8 inches) lightning cable from Anker, connected to the bottom USB, everything is perfect during the latest couple of flights.
I was using that short cable to connect my Ipad to my Phantom 3 pro remote control for more than a year.

As an electronical engineer, I would suspect the DJI cable shielding... (or lack of it ! )

Regards,

Dan


2017-2-26
Use props
Towlie
lvl.2
Flight distance : 597795 ft
United States
Offline

I'm seeing the same issue but it's only happening at the park down the street so far.  First the video to the phone cuts out then the mavic starts blinking yellow.  The controller doesn't indicate a signal loss though.  If I restart the controller I get a connection again for perhaps 1 minute then it all happens again.  I'll keep monitoring if it has something to do with this location only.

Signal strength reported on the controller says it's strong and I'm not flying more than 100 years away.  I'm seeing the connection drop as close as 5 yards away.
2017-2-28
Use props
PeteB
lvl.1
United States
Offline

1st post, and first serious drone purchase.

Problem:
Right out of the box using my iPhone 7+, could not get the phone to connect to the RC using the side lightening connector to no avail.

Found a few on-line complaints about connection issues and connected the Apple lightening cable, and immediately I was able to complete the initial startup, Firmware update and everything was functionally correct.

Since I was unable to find out exactly why the DJi Lightening to side connector cable was not working, I ordered (2) replacements and had those shipped overnight suspecting there may have been a defect in the wire.

Proceeded to conduct several perfect test flights using the Apple lightening connector and everything worked flawlessly.

I then switched to my older iPhone 6+ that is no longer in use, and attempting to use the Dji lightening connector again found the iPhone 6+ would not connect.

More searching on the web and found that this is a VERY common issue with sketchy results mostly resulting in owners using the original Apple lightening connector to USB at the base.

After doing some reading here, saw a few mentions of switching the iPhone to "Airplane Mode". Guess what INSTANT FIX!

Solution:
If using an iPhone you must select "Airplane Mode" on the iPhone, no idea why, but its the defect solution.

iPhone: Version 10.2.1
RC&AC: most current firmware as of February 28th, 2017

All cables and hardware brand new and never used when the issue was discovered.

All batteries were fully charged, and in perfect operating condition.

Issue was discovered to occur with both iPhone 6+ and 7+ phones using iOS 10.2.1

I've tried to force a failure of the connection by unplugging and re-connecting the lightening cable, and every time it re-synced and worked perfectly (as long as the iPhone remained in "Airplane Mode".

Pete B
2017-2-28
Use props
thehippoz
Captain
Flight distance : 23 ft
United States
Offline

PeteB Posted at 2017-2-28 20:33
1st post, and first serious drone purchase.

Problem:

Probably cause wifi is never off on apple phones. I turn wifi off on android, can still get maps through lte
2017-2-28
Use props
KurtAsche
lvl.1
Flight distance : 223553 ft
United States
Offline

Hey fellow Mavic Pro peeps,
I've have had the same issue after my 2nd flight. I have found this issue is caused by the weak mini USB to lightning cable. When the controllers arms are opened fully and phone installed and pushed back together to snug against phone, I can see that thin cable is getting pinched into a very tight "S" shape. I'm sure this is what caused my issue. I have tried a new cable but plugging into the phone through the outside of left handle instead of the pinch area. I haven't had a disconnect since. That tells me that my cable was pinched, which damaged the cable. This cable should be more robust and not so easy to be pinched.
2017-3-1
Use props
Charis
lvl.1
Flight distance : 79262 ft
Netherlands
Offline

Also experienced the lost image issue during my last trip. Switching to the apple lightning cable via the usb port solved the problem. I upgraded to the latest firmware today and gave it a shot again in the house (its raining outside). No image loss but I only flew it for 10 minutes. Anyone tried it outside with the latest?
2017-3-8
Use props
fansffcd9c89
New

United Kingdom
Offline

Just got my Mavic Pro and having the same issues. Latest firmware carried out and using an iPhone 7 Plus.
Video lasts a minute, or so, and then goes blank with a return home message. The drone can still be controlled and restarting the app remedies it, briefly. It's pretty much unusable and I wouldn't venture far with it.
My first ever drone and am regretting the purchase.

Awaiting DJI's response to my email.
2017-3-21
Use props
digitalintruder
First Officer
Flight distance : 3652379 ft
United States
Offline

This problem exists on android - I really hope this issue is resolve with conviction from DJI - it really takes the mavic down a notch -- or at least provide reasons why this could happen...
2017-3-21
Use props
dv8ed
Second Officer
Flight distance : 360322 ft
  • >>>
United States
Offline

Are Mavic DJI Lightning cables MFI certified? It's so small doesn't seem like there's a chip at the lightning end of cable.

Probably is since it's priced higher than other Mavic cables at $19.
2017-3-21
Use props
Charis
lvl.1
Flight distance : 79262 ft
Netherlands
Offline

Ive flown 3 batteries since the last update with the DJI lightning cable without issues. I keep my iPhone lightning cable close for now just in case, but for me so far so good...
2017-3-29
Use props
VTomi87
lvl.1
Flight distance : 311178 ft
Hungary
Offline

The issue still exists.
I flew last saturday and randomly i lost video link (RC working fine).
Log is missing after the error.... I returned to home point manually with RC.

http://app.airdata.com/main?share=lThvoZ


2017-4-4
Use props
fansab1d7d56
lvl.1
Flight distance : 461565 ft
Netherlands
Offline

All the same here. Finally had time to fly ánd had nice weather. Constant signal loss and "disconnected gimbal", according to de go4 app. It also says there is no SD card even though the default one is still inside. Also using an iPhone 7+ and all of the original cables etc. Latest firmware and updates on DJI stuff and iPhone. Very annoying and as said before, time DJI comes up with a resolution. Went back to factory settings now. Will upgrade firmware again tomorrow and try the "flight mode option" although I think that shouldn't be the resolution. I like to get live feed on my maps also. I have unlimited data on my phone and really want to use it.

COME ON DJI !! MAKE IT WORK AGAIN!!!!

2017-4-4
Use props
ArtistFirst
Second Officer
Flight distance : 986716 ft
United States
Offline

Mooney Posted at 2016-11-21 06:44
I've been using i7 plus without any problems.

Try setting a homepooint at the RC (go to MC settings, thing that looks like a little fan) and try to set a home point at the RC and see if it does it. Please report back here and respond to this if it does or doesn't.

If it does, please let me know all your firmwares.

Also, please let me know if Follow Me works for you. These are the two things that use GPS from tab/phone.
2017-4-4
Use props
un hombre
lvl.3
Flight distance : 170830 ft
Ireland
Offline

Guys, this is probably a hardware issue and no software can fix it. From what I have gathered, it can be caused by interference from the phone (Wifi, Bluetooth, Data, mobile signal).

Try your next flight with Airplane mode on.

I had the same problem last time and will see if I can reproduce in Airplane mode.
2017-4-4
Use props
VTomi87
lvl.1
Flight distance : 311178 ft
Hungary
Offline

I got this message from DJI tech support:


Dear Mr. Tamas,


thanks for the email. Right now we dont have massiv cases regarding this issue,  so i dont know it is FW probem which caused the same Problem by other customers.  I would say I will wait for further reports.  If you think it is FW Problem, you could also wait.

Best regards
Technical support
DJI GmbH


So if we want to solve this problem by DJI, everyone have to open a case at tech support.....

http://www.dji.com/support/product/mavic



2017-4-5
Use props
fansf7075654
New
Belgium
Offline

Have received Mavic yesterday. flew it as 'beginner' around garden and video feed worked OK, and even recorded 1 session. started and landed a couple of times. Had problems understanding how to move the Gimbal - it only moved 90 in one row with the tiny joystick on right bottom screen corner of RC. Today, i did same thing - wanted to try out controlling the Gimbal - as I found (not in manual) on internet to use left wheel to move Gimbal gradually for Video. This worked ! One step forward ! But now I started loosing video live feed. As on forum thread, did 2 shutdown and restart cycles, but each time, after starting I loose video feed after about 10-20 secs - even when its not taking off yet.
I already also tried switching off WiFi and BT. Haven't tried Flight Mode .

Before I did the first maiden flight yesterday I already updated FW to latest offered by GO 4 - so between yesterday and today, nothing really changed on soft ar FW. Installed Go 4 yesterday, so hardly needs updating.

iPhone 6+ - latest IOS version
Go 4 -
2017-4-6
Use props
Alex's Mavic
lvl.2
Flight distance : 5423 ft
United States
Offline

Reading some of these posts, I have the identical issues to you guys.  Video disconnects on the side port, works fine on the bottom USB.  Speaking to Tech Support they said it is the cable, it is supposedly on order.  Tech support is pathetic.  They do not have any idea what they are talking about.  They do not have a systematic way of troubleshooting.  They claim that they are in Carson, Ca, whereas in fact they are in Manila Philippines.  
Putting the phone into airplane mode would result in loss of gps connection.  Oh wait, the GPS is an issue too.  I can't get follow me to work with my iPhone 7plus on AT&T network.  My friend was over and we tried his phone and my phone back and forth (his was a iPhone 6s Plus on T-Mobile).  His phone was able to use follow me every time, my 7Plus not at all.

Attempting to discuss it with tech support is pointless.  Curious if there is anyone who is knowledgable within DJI to talk to and how to get in touch with them.  Obviously they are having tremendous issues and are not willing to admit it.
2017-4-6
Use props
un hombre
lvl.3
Flight distance : 170830 ft
Ireland
Offline

Alex's Mavic Posted at 2017-4-6 09:58
Reading some of these posts, I have the identical issues to you guys.  Video disconnects on the side port, works fine on the bottom USB.  Speaking to Tech Support they said it is the cable, it is supposedly on order.  Tech support is pathetic.  They do not have any idea what they are talking about.  They do not have a systematic way of troubleshooting.  They claim that they are in Carson, Ca, whereas in fact they are in Manila Philippines.  
Putting the phone into airplane mode would result in loss of gps connection.  Oh wait, the GPS is an issue too.  I can't get follow me to work with my iPhone 7plus on AT&T network.  My friend was over and we tried his phone and my phone back and forth (his was a iPhone 6s Plus on T-Mobile).  His phone was able to use follow me every time, my 7Plus not at all.

If you put iPhone in airplane mode, its GPS will get lock much longer and be a bit less precise. I have unlocked version of 7 plus, European, Intel modem. Last time I was flying Mavic in Airplane mode and tried setting home point to controller's (phone's coordinates) I got a message that it is not accurate enough to do that.

I would recommend starting the app with radios on, and once GPS is locked and maps preloaded, turn on offline mode. Then start up Mavic and controller.

I will try that next time I fly.
2017-4-6
Use props
Alex's Mavic
lvl.2
Flight distance : 5423 ft
United States
Offline

This would not solve the follow me weak god as the app requires an active gps. If you put it in airplane mode that is gone.
2017-4-6
Use props
un hombre
lvl.3
Flight distance : 170830 ft
Ireland
Offline

I can confirm in my case video loss problem goes away if iPhone is put into offline/airplane mode.
2017-4-9
Use props
thunderstruck
lvl.3
Flight distance : 545043 ft
France
Offline

Sadly I am having the same issue after many many good flights since I got the Mavic in Nov. !!

I pulled it out of the bag launched it and the problem started out of the blue! Never had the issue before. Could it be related to an iOS update ??
2017-4-9
Use props
fans356f81b3
lvl.1
United States
Offline

I've had the same problem using my iPhone 6.  The vido feed either cuts off completely, or freezes at 400-500 feet out.
I tried my buddies iPhone 6 (Who also has a Mavic Pro, but not this problem) Video feed cuts off just like my phone.
I purchased a brand new iPhone Mini 4, with 128GB for the purpose of using it with my Mavic Pro.  Nope!  Nothing different.  Same problem.
So, I tried my iPad Air 3...........guess what?  Yup, you guessed it.  Same problem.
Only thing I have left is my iPad Pro, but there's no device big enough to hold this thing to the remote.  So not gonna lug it around to get what
I can only guess will be the same results.

I've tried pushing the cord in tighter......No go bro!
And again, I've tried every cable I own, (9 different ones, and 7 of them are Apple OEM cables) only to get the same results!

My Mavic is barely 4 weeks (And some change) old.  I shouldn't be having these kinds of problems for a drone I paid almost $2000 (With all the extra accessories) for!!!
C'mon DJI, let's get some answers to this obvious problem!!!

Contacted Tech Support twice now.
Was told to put phone in Airplane Mode.  That worked for about 30 minutes.
Next?........................
2017-4-22
Use props
UCBarkeeper
lvl.4
Flight distance : 616982 ft
Switzerland
Offline

same problem here (phone loosing connection to the remote), iphone 7, latest firmware.
did not try airplane mode yet. i made one flight with the original apple cable, as i suspected the cable to be the problem.
2017-4-24
Use props
fansd2d94a00
lvl.2
Flight distance : 291555 ft
United Kingdom
Offline

I'm having the same problem flying my Mavic in the UK with both my Galaxy s7 Edge and NVIDIA SHIELD LTE tablet.

This Saturday (22/04/17) I had several disconnects where the Mavic RTH after about 1-2minutes of flight (if that). On 2 of 4 occasions I was unable to land the Mavic until I had turned off the remote and then turned it back on so it reconnected. All flight attempts failed in succession with no joy in between.

I stopped for a coffee and then reconnected. I then flew 5x 4km round trips with a max distance of 1km away from home location with no problem (2.5 batteries).

I stopped again and charged my batteries. 1 hour later I again tried with several disconnects in succession... I noted that the s7 edge was connected to the remote with the cable entry from the right side on this occasion however in previous successful flights it had been the other way round, so I rotated and reconnected the phone. Following this I had 3 perfect flights to about 1km of the location that I was located and got some amazing shots. I wandered if by turning the phone round helped separate the 2.4GHz transmitters in the phone and the remote. Unfortunately there are several other variables to do with the phones WiFi being on and my home being in close proximity to my flight location that may have had an effect.

I used the same reasonable quality spiral USB cable for all flights.

I'm going to try turning off the WiFi next flight to see if this helps as I was flying outside with my phone connected to the WiFi in the house (or possibly scanning for connection to WiFi if I lost signal). I shall also turn off accurate location positioning on the S7edge which uses WiFi even when its switched off for accurate location information.

Interestingly the week before over 3 days I had no flight issues flying in Menorca ES and range was about 1km distance flown from the RTH location.

The NVIDIA Shield tablet is a mystery as there is a problem with the firmware on this which causes the pad to sometimes become slow and laggy so it difficult to determine if the issue is the pad or Mavic.

2017-4-24
Use props
Indy
New
Flight distance : 1105663 ft
France
Offline

Hi,
I just got my new Mavic Pro bundle 25.04.17, couldn't upgrade the firmware with DJIGO. I could upgrade the quadcopter with DJI Assistant 2, then I had to update the remote controller still with DJI Assistant, it downloaded the firmware, but it took a long time to start to transfer the data and finally upgrade the remote controller.
Then trying to set everything up in my living room, the connection between my iPhone 6s Plus and the remote controller keept on getting lost. Same with iPad mini 3.

1. Couldn't upgrade firmware with DJIGO
2. Took a long time to connect the remote controller after downloading when upgrading with DJI Assistant 2
3. Keep on loosing connection between iPhone 6S plus and remote controller or iPad 3

I'm not very motivated to fly since I've read lots of same issues going along with return home...
And besides that it'd raining all the time...

Thanks for your support,

2017-4-25
Use props
FLYBIGSKY
lvl.2
United States
Offline

Add me to the list of people with disconnect  problems. I am using  .600 firmware / iPhone 6 Plus / and the Large USB Port. I am afraid to fly very far because the disconnect happens a lot. I do hope it's a firmware problem and DJI gets it fixed.  DJI .....  START LISTENING TO YOUR CUSTOMERS !
2017-5-6
Use props
fans3a41fc2f
lvl.2
Flight distance : 1244337 ft
Russia
Offline

same problem. airplane mod fix it. wtf? 1st flight and mobile connect off, pff.
2017-5-6
Use props
DougMillen
lvl.1
United States
Offline

I just got my Mavic...and a new iphone 7 + to go with it. With my first flight I lost connection to the phone, same as everyone else on this thread. I was disappointed after reading the posts here. But I was helped by what I read. I put the phone in airplane mode and problem was fixed. Had a full battery flight with no problem. I put another battery in, not in airplane mode and the problem returned. I hope DJI can figure out the problem. Seems like their customer support is not that good.  All the best...
2017-5-7
Use props
MavicSub
New
Czechia
Offline

I had the same issue with one year old iPhone 6s Plus. When I used brand new small iPhone 6s it was working fine. Both using original DJI cable with no airplane mode. Latest firmware.
2017-5-7
Use props
Chandler
lvl.2
Flight distance : 1244337 ft
Russia
Offline

I had the same issue with one year old iPhone 6s Plus. When I used brand new small iPhone 6s
its very strange.  maybe problem in phone modem ? one of it break connection.
For example in iphone 7 plus we have  qualcomm or intel modem. maybe we need statistic ?
my is A1784


2017-5-8
Use props
tomp
lvl.1
Flight distance : 16289 ft
Czechia
Offline

Same issue here with latest firmware and iphone 7.
2017-5-8
Use props
fans27a314b8
lvl.1
Flight distance : 1501198 ft
Finland
Offline

Same issue....... i'm €&@&€€& now.{:4_142:}
2017-5-11
Use props
HaBo
lvl.1
Flight distance : 18645 ft
Sweden
Offline

Same issue here. Got my Mavic about a week ago. iPhone 6+, latest FW 11/5. Tried 3 different dji cables with same result. But when I use a short regular USB cable - No problems at all!
2017-5-12
Use props
StephenGSY
lvl.4
Flight distance : 814232 ft
Falkland Islands
Offline

Had one good flight till battery was at level to return to home. All good
2017-5-14
Use props
fansc20aa0bd
lvl.2
Flight distance : 22772 ft
Poland
Offline

StephenGSY Posted at 2017-5-14 12:08
Had one good flight till battery was at level to return to home. All good

I have the same issues with a iPhone 7 plus. No matter if I use the DJI cable or an iPhone cable I loosing the video. Sometimes late, sometimes less then 2 seconds.
To get the video back again: switch to another app with double klick the home button and than back again to the DJI GO 4 app and the video should be back again.... until it will disappear again. So this can only help for a while.

I have played around with some iPhone settings:

- airplane mode: no problems
- wifi and bluetooth off: no improvement

Somewhere I have read that switching of the mobile data will help. But this its like the flight mode.
So I tried first to switch LTE off in the data options.

for 30 minutes on the ground playing around with the app all was good!!! I will test this when I fly and report again.

Try this out and confirm if it will work for you!
2017-5-22
Use props
UCBarkeeper
lvl.4
Flight distance : 616982 ft
Switzerland
Offline

GeeP Posted at 2017-2-15 03:52
So, I did 2 test flights this morning with this configuration:
- iPhone set to plane mode (no wireless communication)
- USB-lighthning cable replaced by an Apple cable (the one provided with every iPhones)

you don't need the airplane mode, the apple cable is usually enough.
2017-5-22
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules