Please select Into the mobile phone version | Continue to access the computer ver.
DJI GO bugs!
1317 12 2016-12-14
Uploading and Loding Picture ...(0/1)
o(^-^)o
Risharde
lvl.2
Flight distance : 2881 ft
Trinidad and Tobago
Offline

Hi, I have a DJI Phantom 3 Standard for a few months now. Yesterday, the new firmware notice appeared on the DJI Go app for 1.7.90. I went ahead and did the update to the remote control and aircraft. Before the update, the video lagged about 2-3 seconds. After the update, it lags more than 6 seconds. This of course seems to be related more to the firmware than the app. So I tried to downgrade to the previous firmware but the app keeps saying it cannot determine the firmware and there is no firmware in the drop down list to downgrade to. I need the remote control downgraded. It seems the new firmware breaks the FTP access to the remote control. I'm extremely upset with DJI over the poor quality in both the firmware and the DJI Go App.

How do I revert back to the old firmware for the controller?
2016-12-14
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Offline

Really sorry to hear about the issue, actually speaking, the firmware is working fine.
The firmware cannot be downgraded for phantom 3 standard.
Please help confirm what mobile device you are using, and make sure you upgrade both RC and AC successfully.
You can also try to change the mobile devices to check again.
Besides, may I know the firmware version before you upgraded it?
2016-12-15
Use props
BillW50
lvl.4

United States
Offline

Before was 2-3 second video lag is awful! What kind of device are you using? I too am using firmware 1.7.90. I use either a Samsung Galaxy J3 (2016) or a Motorola Moto G3 (16GB) and the lag time with them are about 220msec. Which is what DJI specs them at. You know if the camera gets really warm, it is said that the video lag can increase due to the electronics becoming more unstable with heat.
2016-12-15
Use props
Risharde
lvl.2
Flight distance : 2881 ft
Trinidad and Tobago
Offline

BillW50 indeed it is! You can see the progress I've made on the following thread: http://forum.dji.com/thread-76255-1-1.html

DJI Natalia, thanks for your response, I upgraded from the latest FW 1.6

I was also using version 2.8.3 of the DJI Go App
2016-12-15
Use props
TX_Bounty
lvl.1

United States
Offline

I'm missing the access to the tutorial or the Scan QR. It drops down in the menu but trying to click it does no good. Also not able to use the more advanced features like flight simulator, or app goodies like the follow or orbit options I was shown when I bought it. Maybe I will have to take it back and let the salesman show me what I'm missing
2016-12-28
Use props
fans492b5fcc
lvl.2

Philippines
Offline

How about the escape error after a up date
2016-12-29
Use props
Digitalwizard
lvl.1

United Kingdom
Offline

I'm also having loads of problem errors since updating the app and the Phantom 4. No longer getting "GPS safe to fly" message. Getting wireless connection messages & compass that were never there before.
Have tried all the various calibration items it suggests, downgrading and upgrading again, reinstalling the app etc
My compass are both green as are the other items on the screen.

This is when the app will actually stay open beyond the start screen for more than a few seconds, Mostly I get a brief glimpse of the main flight screen then it all disappears off the screen. I reopen the app and the same thing occurs. When I can get in it is very buggy and slow to operate the app functions. I have never had a problem before with this.

The drone can still fly ok from the controller but with no proper feedback as to what is going on.
Is anyone else having these issues since the latest update?
2017-1-3
Use props
Digitalwizard
lvl.1

United Kingdom
Offline

Well I think I have sorted this problem out.

Delete the faulty updated DJI Go app from your android. Ideally use something like ccleaner app to do this so that all of the updated APK file info is removed.
Go online and download the older V2.9.1 APK file, place it in the downloads folder on your Android and click on the file.
Let it install and hey presto - everything is back to normal. You will have to go into settings on your android and tick "allow apps from unknown sources" because you will not find it on Play Store.

The file can be located on APKpure.com all of the older DJI GO revisions are listed on there.
search for DJI GO_V2.9.1_apkpure.com.apk

I have just tested it outdoors, everything works as it should do, GPS ok, Compass ok, Obstacle sensing ok, Remote control signal ok, My Sanity.... restored!
Thankyou to members of the forum on www.phantompilots.com

Maybe DJI should look on there for their answers. Lol
2017-1-3
Use props
Krazzor
lvl.1
Flight distance : 152067 ft
United States
Offline

I too am having issues with the most recent update to DJI Go.

nVidia shield k1, fully up to date.

My app continues to have the same exact error. Distance doesnt seem to effect it as I have had it happen a mile out and 40 yards out.

My app just starts hits a frame and then stutters almost like its frozen. The app can be force closed and reopened and the camera feed is fine. All the other funtions of the app still work. The video seems to fail more often than not.

I have uninstalled and reinstalled the application and the same error persists.
2017-1-7
Use props
Krazzor
lvl.1
Flight distance : 152067 ft
United States
Offline

Side Note:

All video recorded from the live stream to the app and on the sd from the flight was smooth and shows zero issues. Thus just appears to happen in the app.
2017-1-7
Use props
Nigel_
Captain
Flight distance : 388642 ft
United Kingdom
Offline

If you rotate the map so that North is on the left instead of the top, the aircraft pointer still points to the top when it is facing north.  Thus you can't navigate back home by pointing the aircraft pointer along the track as you should be able to do.  Also occurs on playback.
2017-1-7
Use props
Struan
lvl.1

United Kingdom
Offline

Similar problems with my Phantom 3 Advanced.  Flying well, but some gimble problems led me to update the app to 3.1.1.  First flight, video froze after a few seconds of recording (last frame stayed on screen 'jittering').  Upgraded all firmware etc, but problem persisted.  Rolled back to a previous version of the app as described in this thread and problem solved.  Thankyou Digitalwizard for your advice.  I knew it must have been the app, just didn't know where to get the older version!  
2017-1-14
Use props
Krazzor
lvl.1
Flight distance : 152067 ft
United States
Offline

Yeah, same exact thing happened to me again twice in a row. Ill be rolling the go app back to 2.9.1 to see if it improves. Thanks for the suggestion!
2017-1-17
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules