Please select Into the mobile phone version | Continue to access the computer ver.
P3A Gimbal Ribbon Cable Issue
745 1 2016-12-27
Uploading and Loding Picture ...(0/1)
o(^-^)o
smokincigar
lvl.4
Canada
Offline

Hi friends,

I encountered a power line a few weeks ago. I have replaced my shell and gimbal yaw arm successfully. Phantom flys great, but one problem lingers.

When I press the shutter button to take a photo, I lose video down links for several seconds while the camera appears to be "thinking". When I switch over to capture video, I lose video connection completely until I switch back to 'photo' mode.

My ribbon cable does have some scratches from the crash and was twisted several times. I'm wondering if there is a chance a break in one of the conductors in the ribbon cable may cause this issue? I was able to format the SD card in the dji go app, but no photos are being saved to the card either. I can set shutter, ISO and have great video while flying, but just when I attempt to capture, I experience this issue.

Could this be a symptom of a ribbon cable issue, or likely the camera/gimbal circuit boards be toast from the crash?

It seems like the camera isn't able to send data to the CPU board in the gimbal assembly, so I think it may just be the ribbon....

Here's screen shot video of what I am experiencing..


I appreciate your thoughts,
Greg
2016-12-27
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Hi Greg, since the aircraft has been crashed before, I'd suggest you to send it in for further evaluation.
Please send an e-mail to support@dji.com with the following info, the subject should be " Forum support". We'll help you create a case.
Case illustration:
Country:
Full name:
Email address:
Phone number:
Shipping Address:
Zip Code:
Forum link for your case:
2016-12-28
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules