Please select Into the mobile phone version | Continue to access the computer ver.
OSMO Won't Boot Up - System Status Solid Red
4108 14 2017-1-4
Uploading and Loding Picture ...(0/1)
o(^-^)o
sgflybywire
lvl.2
Flight distance : 4124 ft
Thailand
Offline

When I insert the battery and boot up the OSMO, the gimbal will move and fan can be heard. After a few seconds, fan will stop and the system status LED becomes solid red. According to manual, this is due to non-DJI battery. However, I got all three batteries from DJI.com. two of the 3 batteries were still working yesterday but today, all three batteries have the same result.

Video below to show the problem. Not sure if the battery is faulty or the OSMO is faulty. I do not have another OSMO to test the batteries.


2017-1-4
Use props
DJI-Thor
Administrator
Flight distance : 13602 ft
Offline

I'm very sorry to say that you may need to send the Osmo back, please find online chat on www.dji.com/support and follow instructions to send it in.
2017-1-4
Use props
sgflybywire
lvl.2
Flight distance : 4124 ft
Thailand
Offline

DJI-Thor Posted at 2017-1-4 18:52
I'm very sorry to say that you may need to send the Osmo back, please find online chat on www.dji.com/support and follow instructions to send it in.

Thanks Thor. Interestingly, today when I tried again, 2 of the batteries worked. Not sure what is causing the intermittent issue. Could be loose connection issue - see below.

Managed to get in touch with Justin from DJI. He advised to tape some plastic on the battery (presumably to thicken the battery so that it fits in the OSMO better). When I did that on the 3rd battery that didn't work, the OSMO turns on well. I put 3 layers of electrical tape at the location shown in the picture.
Hopefully, this is not the OSMO going crazy. Will monitor and update.
Screen Shot 2017-01-05 at 19.08.54.png
2017-1-5
Use props
veronkilla
lvl.1
Nigeria
Offline

sgflybywire Posted at 2017-1-5 04:14
Thanks Thor. Interestingly, today when I tried again, 2 of the batteries worked. Not sure what is causing the intermittent issue. Could be loose connection issue - see below.

Managed to get in touch with Justin from DJI. He advised to tape some plastic on the battery (presumably to thicken the battery so that it fits in the OSMO better). When I did that on the 3rd battery that didn't work, the OSMO turns on well. I put 3 layers of electrical tape at the location shown in the picture.

I have a similar issue. Not the exact same since the green light comes on for a few seconds before it turns red. Exact same issues as in this video



Any way to resolve this myself?
2017-1-21
Use props
sgflybywire
lvl.2
Flight distance : 4124 ft
Singapore
Offline

veronkilla Posted at 2017-1-21 10:48
I have a similar issue. Not the exact same since the green light comes on for a few seconds before it turns red. Exact same issues as in this video

https://www.youtube.com/watch?v=fuwU_ZxIlqU

Seems to be similar. It appears that the battery doesn't fit well in OSMO. Did you try the above method to get the battery "fit" better in the battery compartment?

One way to test - after you insert the battery, leave the cover open and use your finger/thumb to push the battery upwards (forcing the battery and contact pin to be closer). See if this works.
2017-1-21
Use props
kall
lvl.1
India
Offline

sgflybywire Posted at 2017-1-21 20:09
Seems to be similar. It appears that the battery doesn't fit well in OSMO. Did you try the above method to get the battery "fit" better in the battery compartment?

One way to test - after you insert the battery, leave the cover open and use your finger/thumb to push the battery upwards (forcing the battery and contact pin to be closer). See if this works.

same problem persist even after using the tape. both lights turn solid green and after 5 seconds the right goes red. cannot connect to phone as well. help.
2017-8-15
Use props
kall
lvl.1
India
Offline

veronkilla Posted at 2017-1-21 10:48
I have a similar issue. Not the exact same since the green light comes on for a few seconds before it turns red. Exact same issues as in this video

https://www.youtube.com/watch?v=fuwU_ZxIlqU

did you find a solution?? i have the  same problem.
2017-8-15
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

kall Posted at 2017-8-15 22:09
did you find a solution?? i have the  same problem.

It seems that the communication between the battery and the handle is abnormal,  please try to wipe the  battery contact with 95% alcohol and cotton swab. Let the alcohol air dry. If it does not work, wipe the copper sheet inside the battery compartment
2017-8-15
Use props
fans0c24a214
lvl.2

United States
Offline

I've had the same issue with my osmo since I've owned it. I got tired of using it because of its unrealiblity but today I tired to use it again and the same problem I will try this fix but if it doesn't work what next?  I've got the osmo pro so it wasn't cheap and I shouldn't be expected to pay for repair if it's a defect.
2017-11-25
Use props
sya
lvl.2

Russia
Offline

The same trouble with External Battery Extender. Solved it after an hour of cleaning, patching, pressing, contact scratching etc. After many power cycles, it seems to work. I do not touch it now.

It is not the best solution with these spring-loaded pins and over-protection against battery cloning.
2017-11-30
Use props
wikey
lvl.1

Sri Lanka
Offline

Is some one fund solution for this issue
2017-12-6
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

wikey Posted at 2017-12-6 20:10
Is some one fund solution for this issue

Hi, Wikey, please check my post in 8#.
If the problem persists, please send in the device for diagnosis.
2017-12-7
Use props
Kunal Agarwal
New
India
Offline

I am having the exact same issue

I tried cleaning the battery contacts as well but it did not work. I use the osmo professionally and work is suffering. Please help me out.
2018-3-10
Use props
fans15a92f92
lvl.1
Flight distance : 443809 ft
  • >>>
Italy
Offline

sgflybywire Posted at 2017-1-5 04:14
Thanks Thor. Interestingly, today when I tried again, 2 of the batteries worked. Not sure what is causing the intermittent issue. Could be loose connection issue - see below.

Managed to get in touch with Justin from DJI. He advised to tape some plastic on the battery (presumably to thicken the battery so that it fits in the OSMO better). When I did that on the 3rd battery that didn't work, the OSMO turns on well. I put 3 layers of electrical tape at the location shown in the picture.

Had the same problem. 2-3 layers of tape worked perfectly! Thanks a lot!
2018-5-6
Use props
djiuser_n94idlaMR7Ig
lvl.1

Cameroon
Offline

Je constate que je ne suis pas le seul a vivre se calvaire
J'ai déjà tout essayer mais toujours rien
7-25 06:18
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules