Please select Into the mobile phone version | Continue to access the computer ver.
OSMO BLACK SCREEN OF DEATH
1484 13 2017-1-18 02:00:17
M!!
Beginner
Canada
Offline

my DJI OSMO had been BRICKED for months and tech support had been not helpful.

the DJI OSMO powers on, joystick moves, gimbal works, sends out WIFI, connects to DJI GO app v2.9.1 (2612) on iphone 6.
the DJI OSMO does NOT have a live view, does NOT record, does not even have a firmware.  
firmware is empty!

attempt to upload firmware via a formatted SD card with the .bin file at root directory, DJI OSMO does not blink to upload. just the green lights.

I emailed tech support several times, and they keep asking me to look for the hidden MISC files.
I told them the SD Card can see hiden files but there is NO 'MISC' folder.

It is 6 months since i contacted them, and I am giving up.
Anyone have this issue or can help?
Thank you in advance.
2017-1-18 02:00:17
Use props
ChrisNL 8
Beginner
Netherlands
Offline

Does it connect with your Laptop/Pc or does it not show up at all? Did it get bricked while updating the firmware?
2017-1-18 05:13:26
Use props
M!!
Beginner
Canada
Offline

ChrisNL 8 Posted at 2017-1-18 05:13
Does it connect with your Laptop/Pc or does it not show up at all? Did it get bricked while updating the firmware?

hi, it does not connect to pc/computer.
don't know what happen, it does not have a firmware, but the app can see its battery status.  the joystick can still move it around. no image.
2017-1-18 12:07:46
Use props
ChrisNL 8
Beginner
Netherlands
Offline

M!! Posted at 2017-1-18 12:07
hi, it does not connect to pc/computer.
don't know what happen, it does not have a firmware, but the app can see its battery status.  the joystick can still move it around. no image.

If it is still moving it must have firmware, but it's probably damaged (maybe through an incompleted firmware update). Try to update the firware through the dji go app..
2017-1-18 14:32:03
Use props
fans0e5a7cda
Hobbyist
Canada
Offline

I have the same problem, tryed with ios and android...black screen grgrgrgrgr....weird is that on android my osmo is as an inspire 1 recognised...no clue where the problem is....just ennoying! in ios my osmo is an osmo but I have only black screen
2017-1-19 08:38:49
Use props
fans0e5a7cda
Hobbyist
Canada
Offline

Good news, I managed to get the screen back...
my way:
1) downloard FW 1.6.2.10 (previous FW from 2016-03-24)
2) format uSD
3) copy FW on it and update the Osmo, restart and it was good...then a popup screen comes up with update online with the GoApp
hopefully it helps all...
BTW same for me in android I had to stop in the appl manager DJI Go 4!
2017-1-19 09:05:40
Use props
Big Z
Beginner
United States
Offline

fans0e5a7cda Posted at 2017-1-19 09:05
Good news, I managed to get the screen back...
my way:
1) downloard FW 1.6.2.10 (previous FW from 2016-03-24)

hey did you happen to have a picture because my osmo is doing the same
2017-5-20 18:11:21
Use props
Justin Thomas
Beginner
Kuwait
Offline

I Live in Kuwait and purchaed an osmo camera on April 24 , 2017. During the first use itelf , I lost the video feed  but the Ginbal is still working. I RE-installed the OSMO App . tried to reinstall the firmware but it didnt work. I took it to the authorized dealer (Falcon) they took the device and told me that they will let me know  the issue. Since there was no communication from them, Today i went to them again.  They told me that its a software error and they have to send the device back to China to get it rep[aied and they have no gaurantee when i will get the device back. Also they even didnt give me a reciept for receiving the device, they just wrote it on a paper in the store and gave me the business card of the Store and told me to keep it.
2017-5-21 06:14:15
Use props
Big Z
Beginner
United States
Offline

Justin Thomas Posted at 2017-5-21 06:14
I Live in Kuwait and purchaed an osmo camera on April 24 , 2017. During the first use itelf , I lost the video feed  but the Ginbal is still working. I RE-installed the OSMO App . tried to reinstall the firmware but it didnt work. I took it to the authorized dealer (Falcon) they took the device and told me that they will let me know  the issue. Since there was no communication from them, Today i went to them again.  They told me that its a software error and they have to send the device back to China to get it rep[aied and they have no gaurantee when i will get the device back. Also they even didnt give me a reciept for receiving the device, they just wrote it on a paper in the store and gave me the business card of the Store and told me to keep it.

I think you should have just sent it to DJI. Go get it back and you send it DJI.
2017-5-21 07:11:48
Use props
Justin Thomas
Beginner
Kuwait
Offline

Big Z Posted at 2017-5-21 07:11
I think you should have just sent it to DJI. Go get it back and you send it DJI.

Thanks for the info, i will send it to DJI
2017-5-21 11:51:39
Use props
mike.thetreeguy
Beginner
Flight distance : 147127
United States
Offline

so..... is that the fix?   it needs to be sent to DJI? I am having same problem.   
2017-7-9 11:34:31
Use props
Svilnit
Beginner
United States
Offline

That's a horrible fix
2017-9-13 10:01:42
Use props
Svilnit
Beginner
United States
Offline

Just spent some time on the phone with service...  I need to send mine back in.   I bought the camera for an event and now I won't be able to use it.   Fantastic.  
2017-9-13 10:32:15
Use props
DJI Mindy
Administrator
Japan
Offline

Svilnit Posted at 2017-9-13 10:32
Just spent some time on the phone with service...  I need to send mine back in.   I bought the camera for an event and now I won't be able to use it.   Fantastic.

Do you have the same problem with OP? How about removing SD card? What does the indicator show?
2017-9-14 00:56:11
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next