Please select Into the mobile phone version | Continue to access the computer ver.
Progression and issues on a two month old Mavic
550 3 2017-1-30
Uploading and Loding Picture ...(0/1)
o(^-^)o
sarge43
lvl.3
United States
Offline

I see all the issues people are having with their Mavics and figured I'd share my experience with my Mavic that I purchased from Ebay in October as an "in hand" transaction to get it quickly.  The Mavic showed up and despite it being my first drone, I found the instructions and setup fairly straight forward, but fairly time consuming.  Some steps had to be done repeatedly before they took effect, but that's not a whole lot different than many other electronic devices I've purchased in the past.  First flight I couldn't get the advanced modes to work (POI, tracking etc) - they simply didnt work.  No biggie, I was having a blast flying it and the video was great.  In the next few flights, I did have issues with the RC disconnecting altogether and the Mavic just flying slowly around on it's own for a minute or two.  I eventually tracked this down to strong wifi signals in the area that I was flying at those times.  Going to another, less populated area resulted in great connections.  The firmware update came out in December of last year, and VIOLA! the advanced modes all work now.  I have learned to really like them and use them once in a while - they're great!  Until yesterday, I had not had an occasion or reason to use the RTH function, but kept reading of Mavics shooting off into the sky and flying away when the RTH was used, so I got the Mavic out and went to a large field to try it out.  The Mavic confirmed that the new home point had been recorded, so I flew to a spot a couple hundred feet away and put it about 20 feet off the ground, and just let it sit there for a minute.  I hit the RTH button, got the beep and the mavic started climbing up and up and up.  I have the RTH height set to 90 feet, which is above the vast majority of trees anywhere near me, but the Mavic climbed to 110 before pausing.  It stayed there for a few seconds and then slowly started to climb again.  At no time did it make any movement towards me (standing on the home point) but slowly climbed.  It hit 150 feet and paused again, then started climbing yet again.  It repeated this process, and when it finally reached 240 feet without coming towards me at all, I turned off the RTH and took control again.  There was nothing in the area at all, so I wasn't all that worried about it, just figured if it was ever going to come home, it would have made some progress by that time.  Total time of this exercise was about 5 minutes from hitting the RTH button to disengaging it.  I had full control when I shut the RTH off and simply flew it back to me without issue, but I do hope that the next firmware update addresses the RTH issues, as it certianly seems to be a prevelant problem.  
Anyway, no major issues so far that haven't been fixed with updates.  
Sarge

2017-1-30
Use props
Petroboy
Second Officer
Flight distance : 3681 ft
Canada
Offline

Are you sure it was 90 feet and not meters?  I find that even when I set the units to "Imperial" it still shows the RTH height in meters.  I have not had a chance yet to try it because of... you know... WINTER.
2017-1-30
Use props
cluc
lvl.4
Flight distance : 85682 ft
Australia
Offline

I've recently got my Mavic and tested out the RTH during my maiden flight.
  • First try, worked fine.
  • Second try, it flew over and past the home point, at that point I was like "Oh no, it's going to fly away", but then it stopped, waited for a bit and turned around, flew back to the home point, hovered for a bit, then slowly descended until it land.

2017-1-30
Use props
Jason Lane
Second Officer
Flight distance : 260144 ft
Australia
Offline

Sounds like the problem I and a few others reported here: http://forum.dji.com/forum.php?mod=viewthread&tid=75543
2017-1-30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules