Please select Into the mobile phone version | Continue to access the computer ver.
DJI Go thinks it's connecting to Mavic instead of Osmo after flying Mavic
1286 7 2017-2-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
fans1259d806
lvl.2
Flight distance : 374331 ft
  • >>>
United States
Offline

After finally getting the Osmo to connect to the DJI Go app and being able to record, I went out to shoot, first with the Mavic, then with the Osmo and X5R. Instead of connecting to the Osmo, DJI Go thinks it's connecting to the Mavic, AND keeps connecting disconnecting, exactly like the 'Osmo is connected with another mobile device' error that people were experiencing.

Anyone else having this issue?
2017-2-9
Use props
GtoJon
lvl.3
Flight distance : 5054964 ft
  • >>>
United States
Offline

I just got a used X3 camera & it works great with my Inspire, but does exactly what you are describing with my Osmo.  I have never connected to a Mavic.  
2017-2-16
Use props
GtoJon
lvl.3
Flight distance : 5054964 ft
  • >>>
United States
Offline

Did you find anything?
2017-2-16
Use props
fans1259d806
lvl.2
Flight distance : 374331 ft
  • >>>
United States
Offline

Nothing yet.
2017-2-22
Use props
fans56ceaa10
lvl.2
Flight distance : 327815 ft
United States
Offline

This is a serious bug. They are going to have to combine the Go 4 and the Go apps. I cannot even use the osmo and GO because Go 4 that I use with the Mavic will randomly start up and destroy the Go + OSMO connection.
2017-6-27
Use props
fans56ceaa10
lvl.2
Flight distance : 327815 ft
United States
Offline

It is as if you cannot use the Mavic and the OSMO on the same device (phone), because they need different software that conflicts with each other.
2017-6-27
Use props
DesertSweeper
lvl.1
Flight distance : 344 ft
United Arab Emirates
Offline

Same problem - my Osmo thinks it is an Inspire 1...how I wish ! I have only ever had a Phantom 4 and the Mavic connected. Tried three different devices (all Android which is all I have) - same problem on all three.
2017-9-26
Use props
DJI Elektra
Administrator
Hong Kong
Offline

DesertSweeper Posted at 2017-9-26 04:07
Same problem - my Osmo thinks it is an Inspire 1...how I wish ! I have only ever had a Phantom 4 and the Mavic connected. Tried three different devices (all Android which is all I have) - same problem on all three.

Did you try to flash the firmware of osmo? Please try it first and see if it can work well. Thanks.
2017-9-27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules