Please select Into the mobile phone version | Continue to access the computer ver.
Help with bad motors or bad ESCs or both!
423 3 2017-3-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
RobOnSamui
lvl.2

Thailand
Offline

After a crash with my P2V+ it looks like there is more damage than I first thought  I have 2 motors that are just stuttering - one is twitching round very slowly in little leaps and  the other one is twitching first one way then back again . . .

I took it all apart today to try to tell if it's just the motors or the ESCs as well. It looks like both the motors and the paired ESCs have gone - not easy for me to tell.

So first question - a couple of the mosfets have bubbly surfaces - is that a bad sign?

Second question - I've have the 2212 motors and  the basic ESCs (V1). I've seen an upgrade kit on Ali Express, but the matched ESCs look nothing like the originals (see pic). Will these work? The seller says they are for the P2 . . . anyone have any experience of these?

Thanks in advance.


HTB1hWvSOXXXXXa_XXXXq6xXFXXXe.jpg
HTB1ymwSJFXXXXaXaXXXq6xXFXXXw.jpg
2017-3-9
Use props
Steve-76
Second Officer

United States
Offline

escs if you want to double-check swap the good motor for the one pulsating I had a couple that I built myself and did the same thing
2017-3-9
Use props
Steve-76
Second Officer

United States
Offline

And I have those same escs on my bult one
2017-3-9
Use props
RobOnSamui
lvl.2

Thailand
Offline

Steve-76 Posted at 2017-3-9 06:34
And I have those same escs on my bult one

Do these red ESCs come with the color-coded LED lights on the underside?
2017-3-9
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules