Please select Into the mobile phone version | Continue to access the computer ver.
Camera works until card is inserted!
478 5 2017-3-12
Uploading and Loding Picture ...(0/1)
o(^-^)o
smatthews62
lvl.1

United States
Offline

I can't figure this out. Mavic records video to DJI GO 4 video cache and camera works fine as long as no card is in the Mavic. As soon as I insert a card, the ability to record video or take photos disappears. The DJI GO 4 screen shows the image from the camera in real time, but the image seems to hunt for focus and the screen itself flickers every few seconds. The camera status info disappears and the record button for the video doesn't work (it's not even red). Similar behavior for still photos.

If I power down Mavic and remove the SD card, all is well again. I can record video and photos to video cache in DJI GO 4 app, but of course I can't record to SD card because I had to remove the SD card to get the camera to function.

I've tried two different SD cards that I've used successfully before. Both cards are fine. Inserting either one into the Mavic effectively turns off the recording ability of the camera and throws off all of the camera controls.

In summary, inserting an SD card breaks the camera.

Any ideas?
2017-3-12
Use props
Landbo
First Officer
Flight distance : 502792 ft
Denmark
Offline

Format your SD card in Mavic from the app, and see if it could solve your problem.

Regards Leif.
2017-3-12
Use props
R&L Aerial
Captain
Flight distance : 298100 ft
  • >>>
United States
Offline

Put your card in your computer and wipe it clean then try.
2017-3-12
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Please try above advice and keep us posted.
And did you try the original SD card came with the aircraft?
If the error persists, please make a short video or provide some screenshots for better assistance.
2017-3-13
Use props
superjet96
lvl.4
Flight distance : 142743 ft
United States
Offline

Putting in SD card before powering up correct?
2017-3-13
Use props
smatthews62
lvl.1

United States
Offline

Well I reformatted one of the two SD cards and that seems to have solved the problem. I have no idea why 2 cards that worked fine before suddenly quit working. Pro Allen solved, though. Thanks everyone for your comments.
2017-3-18
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules