Please select Into the mobile phone version | Continue to access the computer ver.
Arming an A3 Pro using a Futaba 14SG
317 1 2017-3-20 19:46:31
David G.
United States

-2014 S1000 (formerly operating with an A2 and 2.4GHz data downlink)
-A3 Pro FC (current firmware)
-Futaba 14SG (formerly setup for the A2) in FASST-TEST 14CH mode
-Futaba R7008SB Reciever connected to A3 via Sbus
-Latest DJI Assistant 2 software and a known good USB cable

I have verified the controls are properly acknowledged and set in the Assistant 2 software. The 4 basic flight controls, mode switch and IOC switch have been calibrated and verified in the software. The simulator does not do anything. It starts "simulating" and I see the controller input register in the data column, but the craft does nothing. Manually moving the craft does not register on the screen either. I even went through an IMU calibration. Just to mention it throttle is reversed in the radio, not in the assistant software. I tried it both ways but returned to that.
Arming attempts have been as follows with the props off for testing. After powering on the A3 I wait for the slow blinking green light. Then verify LED color for modes (yellow for ATTI and fast green for Sport) and back to green for mode P. I have tried powering cycling the A3 many times and have re-connected it to the PC many times. I cannot get it to arm. I even bumped up the motor idle power one notch above the middle to try that but it did not help.

What am I missing to arm the A3 using the Futaba 14?
2017-3-20 19:46:31
Use props
DJI team
Flight distance : 34239
United States

Could you happen to provide a screenshot of how you have the RC set up in the Assistant 2 Software?
2017-3-21 16:07:15
Use props
You need to log in before you can reply Login | Register now

Credit Rules


DJI RecommendsPrevious /1 Next