Please select Into the mobile phone version | Continue to access the computer ver.
A3 1.7.0 - Simulator - Linux Sample App
762 2 2017-3-22
Uploading and Loding Picture ...(0/1)
o(^-^)o
FlyingDice
lvl.1

Israel
Offline

Hi,
I am trying to connect the A3 (1.7.0 firmware) to DJI Assistant 2 (ver 1.1.0) Simulator and then use the OnBoard SDK sample for Linux to control the simulated flight.

Before the upgrade, when I used A3 with 1.5.0 firmware everything worked correctly but after the upgrade the situation is as follows:

The sample Linux app Activates and Obtains Control correctly.
When I open DJI Assistant and press "Start Simulating' button, the LED light is blinking yellow for a few seconds and then becomes red.
When I try to use sample app functionality like "Takeoff" it says "Takeoff failed. Aircraft is still on the ground." and nothing happens.

It id very frustrating because before the firmware upgrade everything worked perfectly.

Will be grateful for any help.

Thanks.
2017-3-22
Use props
FlyingDice
lvl.1

Israel
Offline

Update:
I have also connected RC to the A3 and tried to start the simulation using the RC.
And it shows me the following message:
Unknown error (code: 113). Cannot takeoff. Contact DJI support.
2017-3-22
Use props
FlyingDice
lvl.1

Israel
Offline

Found the problem. Turns out that compass must be also connected and calibrated even when running the simulation. This is very strange and wasn't been needed on previous version so looks like a bug to me.
2017-3-22
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules