Please select Into the mobile phone version | Continue to access the computer ver.
Vision Sensor Errors APP OR MAVIC?
765 5 2017-4-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
Chaser720
lvl.4
Flight distance : 400190 ft
United States
Offline

I've been having vision not responding errors for the last few months. After firmware update to .0550 today, I am getting the error in the screenshot.

I am able to takeoff and use (for example) TapFly for 15 seconds or so. The Mavic will then stop and show an error for "Forward Obstacle Sensing not Responding" when trying to restart. I am able to land, restart then takeoff again where I am able to use TapFly for another 15 seconds before another error.

Is this an app error or a Mavic hardware error?


IMG_4438.PNG
2017-4-8
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

Has the app ever told you to calibrate the sensors?
You can connect it to the Assistant2 on your computer and run the calibration so see if it resolves it.
And you said it's been like that for a few months, has it been crashed or hard landed and are the sensors clean?
Do the above and if it still shows the error then contact support and send it in for evaluation.

http://www.dji.com/support
2017-4-8
Use props
dronist
Captain
  • >>>
United States
Offline

Did you take the clear plastic sticker off the sensor???
2017-4-8
Use props
Chaser720
lvl.4
Flight distance : 400190 ft
United States
Offline

DJI-Ken Posted at 2017-4-8 17:51
Has the app ever told you to calibrate the sensors?
You can connect it to the Assistant2 on your computer and run the calibration so see if it resolves it.
And you said it's been like that for a few months, has it been crashed or hard landed and are the sensors clean?

Ok. So I've calibrated sensors 10x before with no luck. No crashes, sensors are clean, I've done IMU calibration and everything else I could think of.

I got a full battery today of TapFly without any errors. Below is a list of what I did last night. Not sure if it is fixed but so far so good.

1. Delete DJI GO 4 from iPhone 7.2. Update to iOS 10.3.1 (hadn't done that yet so I figured it would be a good time)
3. While this was happening, plugged Mavic to DJI Assistant 2 app and pressed "reset factory defaults" on firmware update page.
4. Refreshed the firmware with .0550 (which every computer updates in the past has failed)
5. Calibrated visual sensors
6. With fresh iOS update, downloaded DJI GO 4 again

So I have reinstalled firmware and calibrated sensors before so I think this was an DJI GO 4 issue. That was the first time I had uninstalled and reinstalled the app.

I'll keep this thread updated as there are very few other occurances of this issue anywhere else online.

And yes the stickers are off the sensors.
2017-4-9
Use props
Chaser720
lvl.4
Flight distance : 400190 ft
United States
Offline

Scratch that. Still f*cked up.
2017-4-9
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

Chaser720 Posted at 2017-4-9 07:48
Ok. So I've calibrated sensors 10x before with no luck. No crashes, sensors are clean, I've done IMU calibration and everything else I could think of.

I got a full battery today of TapFly without any errors. Below is a list of what I did last night. Not sure if it is fixed but so far so good.

I'm sorry if it's still giving errors, you've done all the troubleshooting steps. You will need to send it in for evaluation.
http://www.dji.com/support
2017-4-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules