Please select Into the mobile phone version | Continue to access the computer ver.
Using Go App to Check for Firmware Updates
2379 6 2017-5-15
Uploading and Loding Picture ...(0/1)
o(^-^)o
BearDrone
lvl.4
Flight distance : 2887251 ft
United States
Offline

Today, after about a 20 mintue flight, I had just landed my month old Phantom 4 and I got a message on my iPhone 7 that read something along the lines of, "Some of the firmware between modules is incompatible. Do you want to proceed with the udpate?". I foolishly did not get a screen shot of this message. This is the second time in approximately 10 hours of flight time that this has flashed across my screen.

Since the P4 battery was at 19% and my phone in the 30%'s, I declined the update, packed up, and went home. If I go to the Go App, and in General, Settings, About, I clicked the check for updates, the little video wheel spins, and then nothing happens. I am assuming that this means I am up do date on this software, but is this the version checker for the Go App, or for the firmware?? I suspect that if for the DJI GO App.

How do I check my P4 to see if I have the latest firmware?

If I don't have the latest firmware, how do I update it using the GO App? I have a MacBook Pro, and from what I am reading on this forum, OS X and the DJI Assitant 2 do NOT like each other, and there are several threads of people who either cannot get the installer to run DJI Assistant, or worse, they got it to run, hook up their bird, and now are in an endless loop of not having the new firmware actuall install successfully.

Thanks in advance for the help and guidance.
2017-5-15
Use props
Crack The Sky
lvl.4
Flight distance : 123402 ft
United States
Offline

Excellent question & I have been wondering the same thing. I don't have the Mac issue, though. Can't wait for an answer.
2017-5-15
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

Had you tried reinstalling the app to see if the message pops up again? Have you tried using the Assistant 2 Software on your Mac?
2017-5-15
Use props
Grizz 1
Second Officer
Flight distance : 120066 ft
United States
Offline

that sounds like a battery needs the update.
2017-5-16
Use props
BearDrone
lvl.4
Flight distance : 2887251 ft
United States
Offline

DJI-Jamie Posted at 2017-5-15 20:47
Had you tried reinstalling the app to see if the message pops up again? Have you tried using the Assistant 2 Software on your Mac?

I have not tried to load the DJI Assistant, and I don't think I will. I might try it on an old PC to see if it will run.

Here's the message I got; Inconsistent Firmware Found. Incompatibility issues may occur between some modules and the device".

So, even though I had on 19% battery on the AC, I hit yes, and it took about 1 minute to do the update. It gave me no other information, but I guess that is that for now.

However, it still does not answer the question; how do I do a firmware update from the Go App for the AC and the RC ??
2017-5-16
Use props
BearDrone
lvl.4
Flight distance : 2887251 ft
United States
Offline

Grizz 1 Posted at 2017-5-16 03:59
that sounds like a battery needs the update.

That would make sense. I just got a hi cap battery, and I have not always been running the same battery when I fly. Thanks for the idea.
2017-5-16
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

BearDrone Posted at 2017-5-16 16:52
I have not tried to load the DJI Assistant, and I don't think I will. I might try it on an old PC to see if it will run.

Here's the message I got; Inconsistent Firmware Found. Incompatibility issues may occur between some modules and the device".

For updating the firmware via the Go app, the app itself would provide a prompt to update via an orange bar on top of the equipment page.
2017-5-16
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules