Please select Into the mobile phone version | Continue to access the computer ver.
IMU Error. Calibrate IMU when P4 starts up
1004 24 2017-7-7 21:16:57
ibuyufo
Hobbyist
Flight distance : 160388
United States
Offline

I was wondering if this message is normal when the P4 starts up?  I upgraded to the newest firmware yesterday and have done calibration via the DJI assistant 2 for the VSP.  I calibrarted the IMU, Gimbal, and Compass after the upgrade.  I don't remember if it used to say this but now whenever I start up the P4, it says IMU Error and to calibrate the IMU.  I've tried to do multiple IMU calibrations and it's always the same message.  Can anyone chime in and let me know if this is normal?  Thanks!
2017-7-7 21:16:57
Use props
Punchbuggy
Second Officer
Flight distance : 88452
Australia
Offline

Did it go away? I noted that message on the main screen, but also that the sensor page reported 'IMU warming up...'. When it then displayed the IMUs as both good, the message had gone away on the main page as good to go. I think the error message is a bug.
2017-7-7 22:35:41
Use props
Suhail78
Beginner
Flight distance : 164449
United States
Offline

i had this same issue after my first flight using the new firmware.  instead of displaying the normal "IMU Warming up" message, it gave me the "IMU Error: Calibrate IMU", and all 4 LEDs were solid red....  but also the sensor page showed "IMU Warming up..."   After  a few seconds i got the green "Good to Fly  (GPS)" message, and the flight went pretty smooth after that.....seems like a firmware bug...hope they fix this soon...

2017-7-8 07:06:29
Use props
Chief RM
Hobbyist
Flight distance : 41515
United States
Offline

I had the same when I flew today. So tried to do the IMU calibration and the bar graph on IMU 1 went to about 95% and a green light came on. Then went to 2 and stayed there for at least a half hour. Never did calibrate and now I get the warning to calibrate the IMU. To hot to fly now so will try and fly in the morning and see what happens. May have to go to DJI Assistant 2 and revert back to previous firmware.
2017-7-8 10:17:32
Use props
Dnerve
Student Pilot
Flight distance : 159654
Ireland
Offline

Punchbuggy Posted at 2017-7-7 22:35
Did it go away? I noted that message on the main screen, but also that the sensor page reported 'IMU warming up...'. When it then displayed the IMUs as both good, the message had gone away on the main page as good to go. I think the error message is a bug.

Exact same behaviour, message clears up after IMU has finished its warm-up cycle.

I re-calibrated and same occurs, all readings are in the green when the IMU comes online.

I just guess the new firmware sends some signals the app hasn't been updated for the P4 in regards to the IMU warming-up sequence.
2017-7-8 12:43:44
Use props
ibuyufo
Hobbyist
Flight distance : 160388
United States
Offline

Thanks all.  I hope it's just a software bug and I also hope DJI addresses this in "future" update(s).
2017-7-8 15:58:18
Use props
fester
Hobbyist
Flight distance : 12325
United States
Offline

ibuyufo Posted at 2017-7-8 15:58
Thanks all.  I hope it's just a software bug and I also hope DJI addresses this in "future" update(s).

Same here. I think its just a bug that flags a "recalibrate IMU" instead of "IMU warming up". The warning disappears shortly and gives a Ready To Fly, so probably just a bug.
2017-7-8 17:29:25
Use props
ibuyufo
Hobbyist
Flight distance : 160388
United States
Offline

I can't fly my p4 today and couldn't fly it yesterday as well because it's super windy here.
2017-7-8 17:52:17
Use props
Chief RM
Hobbyist
Flight distance : 41515
United States
Offline

Chief RM Posted at 2017-7-8 10:17
I had the same when I flew today. So tried to do the IMU calibration and the bar graph on IMU 1 went to about 95% and a green light came on. Then went to 2 and stayed there for at least a half hour. Never did calibrate and now I get the warning to calibrate the IMU. To hot to fly now so will try and fly in the morning and see what happens. May have to go to DJI Assistant 2 and revert back to previous firmware.

to calibrate the IMU with the new firmware pay attention to the positioning the P4 while doing the calibration. I didn't and didn't get a good calibration. After a tip on the P4 facebook page I followed the positioning during calibration and the P4 calibrated perfectly. Still get the calibrate the IMU prior to take off but the bird flies perfectly.
2017-7-9 05:05:13
Use props
Jgrimmy
Hobbyist
United States
Offline

Glad to see I'm not the only one!
2017-7-14 09:33:07
Use props
P4 Roy
Student Pilot
Flight distance : 189406
United Kingdom
Online

I get the message too since updating firmware, it went away once warmed up.
2017-7-14 10:17:02
Use props
Callatis
Student Pilot
Flight distance : 53650
Canada
Offline

I am getting the same IMU error every time I turn on the P4. Waiting to warm up the error goes away.
2017-7-14 17:57:01
Use props
Oz Phantom
Hobbyist
Flight distance : 24220
Australia
Offline

me too DJI P4 IMU warning everytime, unstable jerky  flight and the feed cuts out and gimbal shoots off to weird angles, all since update had none of these issues day prior to firmware update
2017-7-14 20:16:52
Use props
mrdarbab
Beginner
Flight distance : 8747
Canada
Offline

Oz Phantom Posted at 2017-7-14 20:16
me too DJI P4 IMU warning everytime, unstable jerky  flight and the feed cuts out and gimbal shoots off to weird angles, all since update had none of these issues day prior to firmware update

That makes me feel better, I  thought I had a bad IMU. Do you get advanced flight modes in the sim, I don't after the update.
2017-7-15 13:33:28
Use props
fansa84fe8a4
Intern Pilot
Flight distance : 1
United States
Online

New firmware had me do all six sides of the P4 (old one) now.  Before it just sat there on level ground.  Flies pretty well now and better than my recently updated I2 too which is sort of wonky (Hovers crooked, but gimbal is level.).

2017-7-15 14:38:04
Use props
djikev333d
Beginner
United States
Offline

is everyone just flying with this error on startup? I have this same issue "ever since" the latest firmware update to v02.00.0106 mid july...from this I tried updating the firmware via a pc it must have messed up something, I got a "camera Sensor Error" black video output on ipad. anyway I had to send it to DJI and the gladly fixed that error, but sent it back with this same IMU error, they flight tested back in California too. I dont see how they could miss this error on startup other than not paying attention, because once the GPS picks up, the error goes away, but I have noticed that sometime I will see a message that the IMU redundant switch occured, and if I check sure enough the DJI Go app indicates it switched to IMU ACC #2.... Im waiting to hear back from DJI email support
2017-8-11 15:46:39
Use props
fansfb11ee43
Hobbyist
Flight distance : 15735
Australia
Offline

djikev333d Posted at 2017-8-11 15:46
is everyone just flying with this error on startup? I have this same issue "ever since" the latest firmware update to v02.00.0106 mid july...from this I tried updating the firmware via a pc it must have messed up something, I got a "camera Sensor Error" black video output on ipad. anyway I had to send it to DJI and the gladly fixed that error, but sent it back with this same IMU error, they flight tested back in California too. I dont see how they could miss this error on startup other than not paying attention, because once the GPS picks up, the error goes away, but I have noticed that sometime I will see a message that the IMU redundant switch occured, and if I check sure enough the DJI Go app indicates it switched to IMU ACC #2.... Im waiting to hear back from DJI email support

It started happening to me to after the firmware update, most likely it happening to everyone, fortunately it goes away, unlike the map section in the app going suddenly blank and then having to reinstall the GO4 app to get it working again.
2017-8-11 21:48:47
Use props
FredAstra
Beginner
Flight distance : 40543
United Kingdom
Offline

Suhail78 Posted at 2017-7-8 07:06
i had this same issue after my first flight using the new firmware.  instead of displaying the normal "IMU Warming up" message, it gave me the "IMU Error: Calibrate IMU", and all 4 LEDs were solid red....  but also the sensor page showed "IMU Warming up..."   After  a few seconds i got the green "Good to Fly  (GPS)" message, and the flight went pretty smooth after that.....seems like a firmware bug...hope they fix this soon...

Ditto - Exactly the same with me
2017-8-12 14:09:48
Use props
FredAstra
Beginner
Flight distance : 40543
United Kingdom
Offline

Chief RM Posted at 2017-7-8 10:17
I had the same when I flew today. So tried to do the IMU calibration and the bar graph on IMU 1 went to about 95% and a green light came on. Then went to 2 and stayed there for at least a half hour. Never did calibrate and now I get the warning to calibrate the IMU. To hot to fly now so will try and fly in the morning and see what happens. May have to go to DJI Assistant 2 and revert back to previous firmware.

I had this same problem.. which is because the NEW IMU calibration method which requires you to move the position of the phantom at each stage of the IMU calibration. check this   
2017-8-12 14:14:53
Use props
djikev333d
Beginner
United States
Offline

I got a reply from DJI, its now a known issue, they have read this thread and are working on a fix in a firmware update, kinda ironic.
For now the recommend "warming up" longer,  read below.....from DJI

We are glad that the steps you have taken in calibrating the IMU has alleviated your concern for a bit. Our Team is working on the double in finding a fix for this particular concern that you are encountering with your drone.

For now, we would recommend you to warm up your aircraft first before using for  any intended purpose while we are seeking a fix of the issue.

Rest assured that we will notify you once we got an update for any firmware or hardware concerns that is a suitable fix for the issue.
2017-8-17 03:37:10
Use props
ninjapimp
Beginner
Flight distance : 33627
Offline

same exact issue. i've not found a fix yet for this.
2017-8-17 06:07:58
Use props
rudyasho
Hobbyist
Flight distance : 41067
Indonesia
Offline

saya juga mengalami ini pada android   seri menengah dan terakhir selalu saya paksakan sehingga kini  tidak bisa digunakan
2017-8-17 07:34:51
Use props
djikev333d
Beginner
United States
Offline

ninjapimp Posted at 2017-8-17 06:07
same exact issue. i've not found a fix yet for this.

read the response from DJI right above your post, there is no fix for this. Period.
2017-8-17 09:54:24
Use props
ibuyufo
Hobbyist
Flight distance : 160388
United States
Offline

djikev333d Posted at 2017-8-17 09:54
read the response from DJI right above your post, there is no fix for this. Period.

Anything can be fixed if they put some damn time into it.
2017-8-17 20:28:40
Use props
rudyasho
Hobbyist
Flight distance : 41067
Indonesia
Offline

This is not normal. I experienced this kind of incident on android with a small RAM of only 2 gb, when I changed devices then this did not happen again
4 days ago
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next