Please select Into the mobile phone version | Continue to access the computer ver.
DJI Go 4 Compatibility - S7 Edge
205 4 2017-3-15 13:06:57
Danny-B-
Intern Pilot
Flight distance : 69527
United Kingdom
Offline

Howdy!

Can anyone remember where the official compatibility list is? My S7edge has always performed flawlessly but now i've just got an update notification to Android 7.0 Nougat, i have a horrible feeling that when i update i'll break DJI go 4 compatibility ... any official info on this?

Cheers,
2017-3-15 13:06:57
Use props
alaska42
Hobbyist
Flight distance : 27466
United States
Offline

I would not update. I did on my S7 and now can not seem to keep a connection. Not a problem until now. It was disconnecting several times a flight . I am now using Litchi and it is stable.
2017-3-15 13:11:25
Use props
chalde
Hobbyist
Flight distance : 92276
United States
Offline

Yeah, don't update FW if you can. Read a few posts with users having issues with S7 and Nougat update.
I did the upgrade on my S7 Edge and it crashed multiple times during a single long flight. The drone is still controllable tho with controller itself, but if you lost line of sight, better hope your RTH is set properly.

2017-3-15 15:03:18
Use props
Danny-B-
Intern Pilot
Flight distance : 69527
United Kingdom
Offline

Cheers lads, i'll hang fire for now
2017-3-15 15:58:05
Use props
Lemonsorbie
Hobbyist
Flight distance : 956
Offline

http://www.dji.com/mavic/info#specs
2017-3-18 12:14:51
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next