Please select Into the mobile phone version | Continue to access the computer ver.
Osmo Mobile Gimbal Issue
3903 9 2017-8-31
Uploading and Loding Picture ...(0/1)
o(^-^)o
Rosey
lvl.1
Flight distance : 21135 ft
United States
Offline

Hello All,

I think my Osmo Mobile is broke...but would love any help in a possible solution before sending it to DJI and losing it for a good two months (that's how long it took them to fix my Phantom 3 a while back, which was a manufacturing defect, not from a crash).

I used my Osmo Mobile earlier today (it's used rarely and in mint condition). I went to use it again this evening, and it won't work. I get a bluetooth connection on the left, but when I turn it on it goes green for a second and then just flashes. I also noticed that the rear gimbal (the one where you would first balance it so it was even) is hard to move. Even with the osmo mobile completely powered off, it does not move freely like it always has in the past.

Any help would be greatly appreciated! I did not drop it, and it worked fine earlier today when I was using it. Nothing changed, I used it and put it right back in its foam protective case.

Thank you in advance.
2017-8-31
Use props
Rosey
lvl.1
Flight distance : 21135 ft
United States
Offline

I should also mention, I noticed it moves from the top to center rather easy, but to move it below parallel it gets much harder...almost like something is rubbing together in there.
2017-8-31
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

You do have balance the gimbal before powering on, do you?
Please try to close the ''Mobile Device Check'' in Gimbal Settings. Mobile device Check.png
But if there is friction during moving, I would suggets to send in for evaluation, sorry that it took 2 months to repair the Phantom, it is not normal, please keep me updated if there is anything wrong during repair process, I would try my best to help.
2017-8-31
Use props
PAGR_FARO
lvl.1
Portugal
Offline

DJI Mindy Posted at 2017-8-31 23:21
You do have balance the gimbal before powering on, do you?
Please try to close the ''Mobile Device Check'' in Gimbal Settings.[view_image]
But if there is friction during moving, I would suggets to send in for evaluation, sorry that it took 2 months to repair the Phantom, it is not normal, please keep me updated if there is anything wrong during repair process, I would try my best to help.

I have the same problem, does any one found a solution? iPhone 6s
2017-9-1
Use props
PAGR_FARO
lvl.1
Portugal
Offline

I have the same problem, does any one found a solution? iPhone 6s
2017-9-1
Use props
PAGR_FARO
lvl.1
Portugal
Offline

DJI Mindy Posted at 2017-8-31 23:21
You do have balance the gimbal before powering on, do you?
Please try to close the ''Mobile Device Check'' in Gimbal Settings.[view_image]
But if there is friction during moving, I would suggets to send in for evaluation, sorry that it took 2 months to repair the Phantom, it is not normal, please keep me updated if there is anything wrong during repair process, I would try my best to help.

I have the same problem, does any one found a solution? iPhone 6s
2017-9-1
Use props
PAGR_FARO
lvl.1
Portugal
Offline

I reset the iPhone 6s. I reset the OSMO MOBILE. I did resest in the DJI Application. Problems continue! 1º Does not complete the automatic stabilization. 2º loses connectivity between OSMO MOBILE and iPhone 6s. 3º Films in Time Laps for 10 minutes / 5/15 but only records in memory 01 seconds. Both OSMO MOBILE and the DJI App are up to date, as is the iPhone 6s. Made experiences with Android system and have the same problems. Shipped to arrangement on 09/09/2017 by UPS. Disappointed with OSMO MOBILE. Thank you for your attention. Paulo Ribeiro
2017-9-5
Use props
aaukhan
lvl.1

Pakistan
Offline

Hi All

My osmo mobile is not working, using it after 3 months. I am not sure what has happened but the indication light keeps on blinking even I stable the device.

Please let me know how to fix it.


Thanks
2019-8-16
Use props
Nik T
lvl.1
Russia
Offline

Hello. I also have this "wonderful device". And my DJI Osmo Mobile also have hard moving in rear "hand". I guess that something is broken inside, and small broken part stuck between other parts. I have ordered my device from far place because there are no dealers of DJI in my place. So also here is no service.
So what should I do? To throw it away? And also throw 300$? Good thing, nothing to say.
2019-12-29
Use props
djiuser_lHB1cqytz1ED
New

Singapore
Offline

DJI Mindy Posted at 2017-8-31 23:21
You do have balance the gimbal before powering on, do you?
Please try to close the ''Mobile Device Check'' in Gimbal Settings.[view_image]
But if there is friction during moving, I would suggets to send in for evaluation, sorry that it took 2 months to repair the Phantom, it is not normal, please keep me updated if there is anything wrong during repair process, I would try my best to help.[Image]

I can’t see “mobile device check”, i’ve updated my app. Quite frustrated with my device unable to auto calibrate and is not smooth turning
2-7 19:10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules