Please select Into the mobile phone version | Continue to access the computer ver.
Warning....Radio Channel Quality Poor
5504 34 2018-9-22
Uploading and Loding Picture ...(0/1)
o(^-^)o
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

Under the Aircraft status screen I am seeing the above message highlighted in red. With the message below reading "strong interference fly with caution"  I have tried several location with the same results.  This is only happening with the mavic 2 ...........My  Inspire, Mavic Air  and Phanton 4 pro do not show this message.   
Has any one else seen this message pop up ?......... You will see it on the Aircraft staus screen.

2018-9-22
Use props
DRONE-flies-YOU!
First Officer
Flight distance : 1182441 ft
United States
Offline

Possibly your device. I’d try airplane mode first. Then we go from there.
2018-9-22
Use props
DJI Natalia
Administrator

Offline

Hi, we're sorry for the inconvenience caused. Can you please try to uninstall and reinstall your DJI Go 4 App? Then try to test to fly again. Let see if this will work. Thank you.
2018-9-22
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DRONE-flies-YOU! Posted at 2018-9-22 10:35
Possibly your device. I’d try airplane mode first. Then we go from there.

Ok I tried tried airplane mode with the same results.  I just confirmed this is an isolated issue with my radio,  all my other drones do  not show this warning.   I will be sending back to DJI on Monday.............
2018-9-22
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DJI Natalia Posted at 2018-9-22 10:47
Hi, we're sorry for the inconvenience caused. Can you please try to uninstall and reinstall your DJI Go 4 App? Then try to test to fly again. Let see if this will work. Thank you.

Hi DJI Natalia,  I just uninstalled and reinstalled DJI Go 4 App and I still see the same message.  
Thank you for your help.

Who do I call to  get an RMA # for return.  
2018-9-22
Use props
DJI Natalia
Administrator

Offline

Raiderfan Posted at 2018-9-22 12:12
Hi DJI Natalia,  I just uninstalled and reinstalled DJI Go 4 App and I still see the same message.  
Thank you for your help.

May I know what mobile device are you using? Can you please try to use a different device? Again, we're very sorry for the inconvenience caused.
2018-9-22
Use props
Alex B.
Captain
Flight distance : 21105262 ft

Spain
Offline

Have you tried launching from a completely different place?

Fly safe
Alex
2018-9-22
Use props
Dec01123
lvl.3
Flight distance : 23428 ft
Offline

I noticed this too with my Zoom, but traced the issue to the fact that my dell computer was within range (about 4 metres) during the switch on period. Once the warning is triggered it tends not to leave for the entire session. Try selecting your channel manually in the video transmission settings. There is a little display graph showing the noise on the frequency band , if you select a range where there is no noise, this always reset the warning for me and helped me trace the source of the interference . I was surprised how sensitive this was to some wifi devices.  A devolo power line wifi extender was another culprit.
2018-9-22
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DJI Natalia Posted at 2018-9-22 12:37
May I know what mobile device are you using? Can you please try to use a different device? Again, we're very sorry for the inconvenience caused.

I am using an apple 7 plus and an I pad with the same results.
2018-9-22
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

Alex B. Posted at 2018-9-22 13:02
Have you tried launching from a completely different place?

Fly safe

I have tried several location.  This is only happenning with my mavic 2  I have no issues with my other DJI drones.  This seems to be an isolated issue with my mavic 2 and controller.  

Does anyone else have this issue.  
2018-9-22
Use props
Paul_
Captain
Offline

Raiderfan Posted at 2018-9-22 13:54
I have tried several location.  This is only happenning with my mavic 2  I have no issues with my other DJI drones.  This seems to be an isolated issue with my mavic 2 and controller.  

Does anyone else have this issue.

Had it happen to me yesterday, had flowen from same spot earlier in the day with no issues. I powered everything down and restarted, all well after that.
2018-9-22
Use props
Alex B.
Captain
Flight distance : 21105262 ft

Spain
Offline

I guess you have a faulty mavic 2

Fly safe all
Alex
2018-9-22
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

Alex B. Posted at 2018-9-22 14:55
I guess you have a faulty mavic 2

Fly safe all

I guess I do
2018-9-26
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

Hello mavic pilots do me a favor, check the aircraft status screen, do you see this message ...........Warning radio channel quality poor........"strong interference fly with caution"  Please check you status screen and share your findings.......Thank You.
2018-9-29
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

Hello fellow Mavic pilots,  I may have solved my problem with the RADIO CHANNEL QUALITY .......POOR  I re-installed the the firmware through DJI assist 2.  Everything went well with the down load and now my RADIO CHANNEL QUALITY has changed to GOOD.  I am glad that I did not send my mavic for service.
2018-9-29
Use props
Lucas775
Captain
Flight distance : 14416503 ft
  • >>>
United States
Offline

You can go to settings and change your connection strength.
2018-9-29
Use props
Drone-Pilot
First Officer
Flight distance : 2131073 ft
  • >>>
Offline

That has happened to me and what I do is I turn off the remote and the Drone and I moved away a few feet and I power everything back on that's what I have done in it has work for me
2018-9-30
Use props
fansfcc89423
lvl.3
United States
Offline

I have been getting this same message as well, happens here at the house sometimes and other time it don't. But when i go out to fly some where  it doesn't happen art all. So just maybe its picking up some interference here at the house. I thought the Mavic 2 would switch to the strongest signal on tits own without the pilot going into the settings to do so. I use to have to do this for my Mavic air and spark when flying around my house, anyway I will go into to the setting for my Mavic 2 and chose a good setting for it.
2018-9-30
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

Bad news...........The message is back  " Warning....Radio Channel Quality Poor"   This is only happening with my Mavic 2 zoom ...............I have no issues with the Mavic air, Mavic, pro, Phantom 4 pro and inspire .......all flown in the same location with only the mavic 2 zoom showing .............. Warning....Radio Channel Quality Poor I have a case number for a return on Monday for service.  I believe I have a bad controller...........I wil be sending in for service on Monday.
2018-9-30
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

fansfcc89423 Posted at 2018-9-30 07:38
I have been getting this same message as well, happens here at the house sometimes and other time it don't. But when i go out to fly some where  it doesn't happen art all. So just maybe its picking up some interference here at the house. I thought the Mavic 2 would switch to the strongest signal on tits own without the pilot going into the settings to do so. I use to have to do this for my Mavic air and spark when flying around my house, anyway I will go into to the setting for my Mavic 2 and chose a good setting for it.

I have tried choosing channels manually at different locations with no luck,  This seems to be an intermittent issue with only the mavic 2 series .........Pilots beware you will not see this message pop up you need to go in to the status screen, there you will find radio channel quality ............GOOD/POOR you should see  GOOD and not POOR.  I have already opened a case with DJI and will be sending back my mavic 2 zoom on Monday.  
2018-9-30
Use props
fansfcc89423
lvl.3
United States
Offline

Raiderfan Posted at 2018-9-30 08:40
I have tried choosing channels manually at different locations with no luck,  This seems to be an intermittent issue with only the mavic 2 series .........Pilots beware you will not see this message pop up you need to go in to the status screen, there you will find radio channel quality ............GOOD/POOR you should see  GOOD and not POOR.  I have already opened a case with DJI and will be sending back my mavic 2 zoom on Monday.

I myself try to do the custom setting but every time I would try slide to the less interference side of the graph it was sidle back silty to the side that has more interference so that didn't work. But here is the test that was very interesting when I turn of the internet router in the house I wasn't getting the poor radio quality warning anymore. And I also notice I would get better signal strength even when I would try to Stand behind trees that was in between the RC and the Aircraft. So to conclude it looks my Internet router is interfering with the radio channel of the drone. One thing to note is the while watching the graph its like the RC would go back and forth between good and the bad signal strength instead of just locking on to the good signal. So maybe thats something that can be fixed with an update. I am going to try some other things to see if can get the it to lock on to the stronger signal like it supposed to.
2018-9-30
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

The RC radio channel quality also goes back and forth between good and the bad signal strength instead of just locking on to the good signal.  
2018-9-30
Use props
jwt-873
First Officer
Flight distance : 5946467 ft
Canada
Offline

I'm getting the "channel poor fly with caution" message on the startup screen as well.  It doesn't happen all the time.   Offhand I can't recall what my surroundings were when the message appeared.  I'm going to start remembering what's around me when I see the message and report back.

One thing I have noticed is that it doesn't really have much of an affect on the operation.   I can fly out a mile and still be in control with full bars on the signal strength display.     But, I do get the odd video glitch/freeze when I'm out that far.   

2018-9-30
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DJI ........... will this be fixed in the next upgrade or is it a hardware issue with the controller.  I  have no issue with distance......... I do start to  have issues with video lag/freezing when only out 200 yards.
2018-9-30
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
United States
Offline

DJI.....I now see other post on this issue...........do we have a problem here?............
2018-10-1
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DJI............??????? I have not heard back from any one on this issue.  
2018-10-2
Use props
jwt-873
First Officer
Flight distance : 5946467 ft
Canada
Offline

Further to my post  (#23.above).

I needed to calibrate my compass yesterday evening.   I live in the country so I headed out to the middle of a large field near my house.  Apart from the controller, the Mavic, and my iPad, there was nothing electrical within 100 meters of me.  I sill got the 'channel interference' error.
2018-10-3
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DJI Natalia Posted at 2018-9-22 12:37
May I know what mobile device are you using? Can you please try to use a different device? Again, we're very sorry for the inconvenience caused.

DJI NATALIA........................Talk to your superiors and get back to us on this issue.  DJI you are ignoring this issue ....WHY?
2018-10-3
Use props
Squashpile
Second Officer
Flight distance : 214019 ft
United States
Offline

I see this on every device I have tried. Total of three. I bought a new $500+ phone (Oneplus 6) just because of this issue so I could test it. The issue is not phone related. It is RC/AC /Software related. I still think it is massive interference, but the channel/freq changing is not working correctly in Dual or 5.8 on power on. The sig meters/graphs do not show this though. At least that is what I think.
2018-10-3
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DJI........WHY DO YOU CHOOSE TO IGNORE THIS ISSUE!!!!!!!
2018-10-3
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
Offline

DJI Natalia Posted at 2018-9-22 12:37
May I know what mobile device are you using? Can you please try to use a different device? Again, we're very sorry for the inconvenience caused.

DJI NATALIA..........................HELLO
2018-10-3
Use props
DJI Natalia
Administrator

Offline

Raiderfan Posted at 2018-10-3 21:41
DJI NATALIA..........................HELLO

Hello, sorry for the late reply. Can you please provide me a screenshot of the error message you encountering right now? I'll forward this concern to our R&D department for further clarification. Thanks for your understanding.
2018-10-4
Use props
jwt-873
First Officer
Flight distance : 5946467 ft
Canada
Offline

Here's mine..   It's appearing about 80% of the time when I fly.   I'm out in the country with no sources of RF noise around me.   I opened and captured the Transmission Settings screen about two seconds after the poor radio quality message appeared.
channel-error.jpg
2018-10-4
Use props
jwt-873
First Officer
Flight distance : 5946467 ft
Canada
Offline

2018-10-4
Use props
Raiderfan
lvl.3
Flight distance : 810869 ft
  • >>>
United States
Offline


Thank you jet-873 for posting this screen shot.  This is exactly whats happening and I can't believe DJI has not addressed this issue.  I hope it can be taken care of with a future update

2018-10-4
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules