Please select Into the mobile phone version | Continue to access the computer ver.
Can't connect A7 to ronin SC with cable
12Next >
44588 43 2019-8-7
Uploading and Loding Picture ...(0/1)
o(^-^)o
Divil22
lvl.2
Netherlands
Offline

Hello everybody. I have a problem with my camera (Sony A7) or with my Ronin-SC. If I use the included cable that runs from the ronin to my camera, my A7 remains to say "check the connected device" with a black screen that prevents me from filming. I have already tried to use other USB settings but have not yet found a solution yet. Does anyone know a solution? Thank you for reading
photo_2019-08-07_14-26-00.jpg
2019-8-7
Use props
Peter von Frosta
lvl.3
Flight distance : 39659 ft
Germany
Offline

Did you turn on the Ronin first?
2019-8-7
Use props
Divil22
lvl.2
Netherlands
Offline

Peter von Frosta Posted at 8-7 06:13
Did you turn on the Ronin first?

I powered first the ronin and then the A7. But have tried all kind of different orders
2019-8-8
Use props
Divil22
lvl.2
Netherlands
Offline

Peter von Frosta Posted at 8-7 06:13
Did you turn on the Ronin first?

I powered first the ronin and then the A7. But have tried all kind of different orders
2019-8-8
Use props
Peter von Frosta
lvl.3
Flight distance : 39659 ft
Germany
Offline

Which Firmware Version is installed (on the Sony)?
2019-8-8
Use props
Divil22
lvl.2
Netherlands
Offline

Peter von Frosta Posted at 8-8 21:41
Which Firmware Version is installed (on the Sony)?

The latest version (Ver.3.20)
2019-8-9
Use props
Sprut
lvl.2
Flight distance : 153406 ft
Russia
Offline

Try to flip the cable you plug into the ronin
2019-8-9
Use props
Divil22
lvl.2
Netherlands
Offline

Sprut Posted at 8-9 11:56
Try to flip the cable you plug into the ronin

That does not work
2019-8-12
Use props
djiuser_UWYyzUny3y1T
New

United States
Offline

Hi.. Sony A7RII is not connecting to Ronin SC. I have set the USB connection to PC Remote and also Remote Control is on. Cable I used is Multi to Sony.
2019-8-13
Use props
Divil22
lvl.2
Netherlands
Offline

djiuser_UWYyzUny3y1T Posted at 8-13 10:42
Hi.. Sony A7RII is not connecting to Ronin SC. I have set the USB connection to PC Remote and also Remote Control is on. Cable I used is Multi to Sony.

Hi  i have the same. Such a bummer
2019-8-13
Use props
Basab
New

United States
Offline

Divil22 Posted at 8-13 11:08
Hi  i have the same. Such a bummer

Hi..How are approaching the issue? Are talking with DJI support?
2019-8-13
Use props
eddiepapi
lvl.1
Flight distance : 94865 ft
United States
Offline

Try it with remote control off.
2019-8-15
Use props
Divil22
lvl.2
Netherlands
Offline

Basab Posted at 8-13 19:04
Hi..How are approaching the issue? Are talking with DJI support?

Not yet. I don't have the time to write an email and live chat doesn't help me because it is a professional product
2019-8-15
Use props
Divil22
lvl.2
Netherlands
Offline

eddiepapi Posted at 8-15 10:45
Try it with remote control off.

Doesn't work
2019-8-15
Use props
fansadf34918
New

Switzerland
Offline

Me too. Sony A7RII is not connecting to Ronin SC. I have set the USB connection to PC Remote and also Remote Control is on. Cable I used is Multi to Sony. What to do please????????
2019-12-22
Use props
fansadf34918
New

Switzerland
Offline

IS GOOD NOW
2019-12-23
Use props
djiuser_AbQvr2p0tArn
New

United States
Offline

fansadf34918 Posted at 12-23 11:36
IS GOOD NOW

I am having this issue. What fixed it for you?
2019-12-31
Use props
hummels
lvl.1
Germany
Offline

I have exactly the same problem: camera is Sony A7Riii. Latest Software Vers. 3.10.
Firmware update for the Ronin SC combo is made. Cable from Ronin SC to the Sony is in the right position and right direction.
But I have the same message on the Sony: "Check the connected device".
@fansadf: How do you solve the problem?
2020-1-2
Use props
djiuser_uQ8N6tLMpY4J
New

United Kingdom
Offline

fansadf34918 Posted at 2019-12-23 11:36
IS GOOD NOW

I have the Sony a7rii and for 12 hours I’ve tried every different alternative I can think of to get the record button on the ronin sc to work, it just won’t work , can anyone help?
2020-1-23
Use props
nightsoundsmedi
lvl.1
South Korea
Offline

Hello,


Did anyone solve this issue for them selfs? I’m experiencing the same problems with my Sony a7iii and I just can’t get it to work...
2020-3-13
Use props
Jeremy J
New
United States
Offline


I'm looking for the same answers, a7iii and ronin sc (latest firmware)
any configuration of usb C and/or multi cable has yet to work.

"check the connected device"
2020-4-4
Use props
pjaustin21
New
United States
Offline

Make sure that on the Network 1 menu "ctrl w/ smartphone" is set to off.  
2020-5-1
Use props
djiuser_VWNca5ZUUMLT
New

United States
Offline

Go to menu, then to setup.  On page 4 you see usb connection, change that to pc remote. This worked for me
2020-5-5
Use props
djiuser_Wo31ytRS81Sj
lvl.1
Germany
Offline

Hi guys, THIS IS THE SOLUTION: Make sure that the end of the cable that goes into the gimbal IS FULLY PLUGGED IN. It has sort of two stages: The first engages and holds the cable in place, which is what all beginners do (i did the same) but which is not actually fully inserted and thus the connection to the gimbal and the camera does not work.
HOWEVER if you just gently apply a bit more pressure on the end that goes into the gimbal, you'll notice that the connector sort of plunges one step further into the slot, locking it in place even more firmly. That is this "second stage". Once you've got it fully inserted that way, the connection between gimbal and camera (and all of its buttons) starts to work instantly.
2020-5-7
Use props
djiuser_Wo31ytRS81Sj
lvl.1
Germany
Offline

By the way : Control with Smartphone does NOT have to be off for the connection between gimbal and phone to work. In fact, if say you're on Sony A7III and you want to use your phone as a field monitor, you can achieve this by turning on Wifi, Bluetooth and Control with Smartphone, then connecting to the Sony Imaging Edge app and the use it with the gimbal simultaneously.
All of the buttons (mainly just the recording button of course) on the gimbal is still going to work and your phone can communicate to the camera to wirelessly transmit the image using Wifi. It's pretty neat.
2020-5-7
Use props
Highranger
lvl.2
Australia
Offline

I cannot either. After 2 months have given up! Even tried the other USB C cable that comes when you buy the focus motor option.
Yes I have turned on Ronin then Camera.
Yes I have selected 'PC remote' and turned off 'Control w/Smartphone'.
I either get the message "Check the connected device" on the camera or else I get no message and the camera is deaf to the record button on the Ronin. I have also reversed the cable.


It has never worked since I bought the Ronin. Using Sony A7r3 with current FW version 3.10.
2020-6-11
Use props
ggFF
lvl.1
Germany
Offline

1) check your cam + cable with another brands gimbal 2) check the RoninSC with another cam / cable combi to find out about the problem.
2020-6-16
Use props
Sebastian1993
New

Germany
Offline

I have the same issue... is it possible to fix it? I see on youtube that some ppl doesnt have the issue b using same equipment as me.
2020-6-23
Use props
Billy Amann
New

United Kingdom
Offline

I just turned control with smartphone off and then went into USB connections and made sure it was set to PC remote. Solved the issues instantly for me.
2020-11-22
Use props
fans140d66fb
New

Netherlands
Offline

I also have this problem with the sony a7RIII

Is there any fix for this already! I hate DJI for it not fixing this!
2020-11-26
Use props
djiuser_y193RxKmnTOY
New

Kuwait
Offline

So I had the same problem and fixed it by turning the PC Remote on.
I have sony a7s iii and everything was perfect.
2020-12-10
Use props
Francis Bau
New

Canada
Offline

Had the same problem. The multi to sony cable didnt work and probably bad. I used the usb c to camera cable and used an adapter on one end to fit sony. The 90 degree side goes in the ronin sc and the straight side on the camera. If i try flip it it doesnt work.
Set on movie mode
Usb connection on Pc remote
Sony a7s and sony a7rii and sony a7ii all working that way.
Just sharing.
2021-1-17
Use props
-Samas-
New

New Zealand
Offline

fans140d66fb Posted at 2020-11-26 04:58
I also have this problem with the sony a7RIII

Is there any fix for this already! I hate DJI for it not fixing this!

I was having the same problem for about an hour, then I realized there are two cables that look pretty much the same, one is called Type C to micro usb and one is called type C to Multi. The micro cable will go in, but only half way and will still charge the camera. The multi cable worked immediately
2021-3-8
Use props
amberanywhere
New

United States
Offline

I found a solution:

for Sony A7S iii to Ronin SC2
Menu > Network > 1. Transfer/Remote > Ctrl w/Smartphone > OFF
Menu > Network > 1. Transfer/Remote > PC Remote Function > ON

Cable USB-C to USB-C
connect camera to the USB-C port on Ronin that is on the same plane as the quick release plate and has the camera icon.

Turn on Ronin FIRST
Turn on Camera SECOND

Hope this helps


2022-3-12
Use props
fans0a1f2368
New

United States
Offline

Hi I've tried everything on the previous threads and nothing works. I keep getting this message,  
Cannot select the USB connection mode during USB cable connection with this setting.
I'm not sure what to do or what setting to change I'm on movie and I've tried Network options and nothing seems to work and everything that you had previous is done.
I even remove the USB cables and still get that message
2022-3-28
Use props
Hebbare Manikantha Rao
New

India
Offline

The DJI Ronin S Cable not working with my Sony Alpha VII M4 Camera.
Please suggest the settings  to me #yesreach



2022-5-23
Use props
dergachoff
New

United Arab Emirates
Offline

amberanywhere Posted at 2022-3-12 19:15
I found a solution:

for Sony A7S iii to Ronin SC2

Thanks so much for this reply! Even had to register to post it.
For those who get there through google search like me:
I have A7C and RS3 Mini. And couldn't figure how to make the connection for half an hour. Tried everything, was ready to hard reset the camera and then go to the service center. Turns out all this time I was plugging in the wrong port on gimbal. Don't plug it into handle – it's a charging only port. PLUG IT NEAR THE TILT AXIS in the usb-c port with camera icon and RSS text.
2023-2-10
Use props
djiuser_n8sGsXYNbDb6
New

United States
Offline

dergachoff Posted at 2-10 09:53
Thanks so much for this reply! Even had to register to post it.
For those who get there through google search like me:
I have A7C and RS3 Mini. And couldn't figure how to make the connection for half an hour. Tried everything, was ready to hard reset the camera and then go to the service center. Turns out all this time I was plugging in the wrong port on gimbal. Don't plug it into handle – it's a charging only port. PLUG IT NEAR THE TILT AXIS in the usb-c port with camera icon and RSS text.

After about 2 long hours of wanting to find the nearest building and dive off of it. This is the only solution that helped. My dumbass was plugging it into the charger port. Didn't even know there was another port. I owe you a round of beers. Thank you
2023-2-22
Use props
djiuser_yLid9AXNn8cF
New

United States
Offline

djiuser_Wo31ytRS81Sj Posted at 2020-5-7 12:18
Hi guys, THIS IS THE SOLUTION: Make sure that the end of the cable that goes into the gimbal IS FULLY PLUGGED IN. It has sort of two stages: The first engages and holds the cable in place, which is what all beginners do (i did the same) but which is not actually fully inserted and thus the connection to the gimbal and the camera does not work.
HOWEVER if you just gently apply a bit more pressure on the end that goes into the gimbal, you'll notice that the connector sort of plunges one step further into the slot, locking it in place even more firmly. That is this "second stage". Once you've got it fully inserted that way, the connection between gimbal and camera (and all of its buttons) starts to work instantly.

This was it for me!! THANKS SO SO SO MUCH!!!
2023-3-21
Use props
djiuser_WSBDCabI5u3V
New

United States
Offline

Billy Amann Posted at 2020-11-22 12:27
I just turned control with smartphone off and then went into USB connections and made sure it was set to PC remote. Solved the issues instantly for me.

THIS WORKED FOR ME. Thank you!!!
2023-4-13
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules