Please select Into the mobile phone version | Continue to access the computer ver.
XT2 640 Horrible Picture / Halo Effect
2212 13 2019-10-30
Uploading and Loding Picture ...(0/1)
o(^-^)o
tonymangia
lvl.3
United States
Offline

I just purchased a M200 V2 and Zenmuse XT2 640 13mm camera.  The images I'm getting from the XT2 while flying at night is terrible.  I will attach screenshots in various color palettes for your review, but basically they are all washed out and have a really bad halo ring effect in them.  They're definitely not useable.  Has anyone else had this problem?  Any suggestions on what to do?

BTW, the latest V01.00.00.20 firmware is installed on the camera.  Thanks so much...

Tony
Screenshot_20191030-065758_DJI Pilot.jpg
Screenshot_20191030-065834_DJI Pilot.jpg
Screenshot_20191030-065943_DJI Pilot.jpg
Screenshot_20191030-070033_DJI Pilot.jpg
Screenshot_20191030-070047_DJI Pilot.jpg
Screenshot_20191030-070054_DJI Pilot.jpg
Screenshot_20191030-070132_DJI Pilot.jpg
2019-10-30
Use props
petur92
lvl.1

Iceland
Offline

What was wrong with the camera?
2019-12-21
Use props
tonymangia
lvl.3
United States
Offline

petur92 Posted at 2019-12-21 11:03
What was wrong with the camera?

Nobody can tell me what's wrong.  The camera was replaced three times, so it seems to not be the camera.  I'll report back when I get more answers.  Very frustrated...

Tony
2020-2-24
Use props
NordicDroneSolutions
First Officer

Denmark
Offline

We have the same happening for us.

Going to send it in but if that doesn't  fix it, that's not very reassuring :/

2020-2-28
Use props
tonymangia
lvl.3
United States
Offline

So you got the same issue, Nordic?  It's so weird what I'm getting.  Sometimes the camera works, and sometimes I get that "halo" effect, very grainy picture, and crazy temp numbers.  I'll attach a photo of what I got the other day.  

So, after I got the bad pictures and video again, I flew the M200 with an X5s and of course that worked just fine.  After a set of batteries flying the X5s, I put in a new set of batteries and swapped to the XT2 640 camera.  The camera worked flawlessly.  I was happy for that, but just two days ago, I flew the XT2 camera again, and the bad colors, grainy picture, halo effect came back!!!!

What's even more frustrating is the finger pointing.  The folks at FLIR say there's nothing wrong with the camera.  And, DJI maintains there's nothing wrong with the drone.  I've had the camera replaced three times and the drone replaced twice.  I personally believe that the problem lies in either the gimbal, connection, or software interface between the drone and camera.  That's just my opinion, and I may be wrong.

This equipment is outrageously expensive and should not be acting up like this.  And, as you know, it's not easy to deal with DJI returns or warranty issues on these bigger drones.

Please let me know how you make out and what issues or resolutions you find regarding this.  Thanks so much.

Tony

IMG_20200223_131438.jpg
2020-2-28
Use props
AntDX316
Captain
Flight distance : 2982907 ft
  • >>>
United States
Offline

tonymangia Posted at 2-24 05:40
Nobody can tell me what's wrong.  The camera was replaced three times, so it seems to not be the camera.  I'll report back when I get more answers.  Very frustrated...

Tony

I had the same issue w/ the XT1 V2 13mm.  The cold spots on the right, most likely because of the weather (heatsink cold from the gimbal arms).  You need to let it heat up or something.

If you adjust the DDE and other things some section (mine said User 1, User 2, User 3), you can make it look way better.  I sold it though, broke even.  I had no use for it.
2020-2-28
Use props
IPGP
lvl.4

France
Offline

Hi,
With our M210 RTK and XT2, we can see some huge vignetting in our thermal pictures. I am not it is normal. We have two XT2 and they have the same problem

2020-11-17
Use props
dzal
lvl.1

United States
Offline

Was anyone ever able to resolve this problem? I am having the exact same issue with an XT2 camera however I have seen other XT2s without the halo effect.
2020-11-23
Use props
Hunter4CH4
lvl.2
Flight distance : 106919 ft
United States
Offline

We experienced exactly the same issue with an XT2 purchased a couple years ago.  I went around and around with both FLIR and DJI.  We returned the XT2 to DJI for analysis and they reported that the sensor met all manufacturing specs.  Through our own testing we learned that the prop wash in colder weather created the halo.  The lower the temps the greater the halo.  DJI admitted this in their response to us:

'We received word from FLIR that your XT2 is within their Spec. They also stated there is no clear fix for Vignetting. They also stated your described issue is “attributed to the camera housing being heated by electronics in the vehicle, or lens being cooled by the propeller slipstream. The different color pallets will show (vignetting) more than others.'  Sam Marquez - DJI (2/19/2019)

It is a BS response since neither DJI or FLIR admit this to being a faulty design though vignetting affect resolution and usable pixels.  It eliminated our ability to create orthomosaics.

It's unfortunate to hear of another customer with the same issue - one that should be corrected by DJI asap!
Attached:  3 photos showing the vignetting we experienced with the XT2


M2 (35).JPG
DJI_0088.jpg
DJI_0001_R.JPG
2020-12-2
Use props
IPGP
lvl.4

France
Offline

Hunter4CH4 Posted at 12-2 18:59
We experienced exactly the same issue with an XT2 purchased a couple years ago.  I went around and around with both FLIR and DJI.  We returned the XT2 to DJI for analysis and they reported that the sensor met all manufacturing specs.  Through our own testing we learned that the prop wash in colder weather created the halo.  The lower the temps the greater the halo.  DJI admitted this in their response to us:

'We received word from FLIR that your XT2 is within their Spec. They also stated there is no clear fix for Vignetting. They also stated your described issue is “attributed to the camera housing being heated by electronics in the vehicle, or lens being cooled by the propeller slipstream. The different color pallets will show (vignetting) more than others.'  Sam Marquez - DJI (2/19/2019)

Thanks for your feedback.
Can you share what was the weather conditions for this flight ? Maybe we can discover what are the "real" weather specs for this sensor.
2020-12-17
Use props
Drone GVA
lvl.2
Flight distance : 598323 ft
Switzerland
Offline

Hello, exactly the same issue with mine.

I flew with a 13mm and a 19mm at the same time and the halo was only on the 13 mm one... This is a shame for an expensive sensor as the XT2...
a lot of grain on the image

A big Halo

And temperature are not correct with the reality...


2-7 08:36
Use props
Olivier Vietti-Teppa
First Officer
Flight distance : 10695331 ft
Switzerland
Offline

we noticed this on the dual dials, the propeller blows directly at the camera, this is not visible on the m200 or m300 with the camera in the center ;-)
2-16 01:31
Use props
jason_rmh
lvl.3
Flight distance : 2676171 ft
United Kingdom
Offline

I have this issue with both M200 v1 (single gimbal) and M210 v2 (dual gimbal).
Even when the drone is sitting on the desk, motors not running.

I think it associated to warm weather or high humidity  (20°C  >60% humidity) I do not seem to experience this during colder weather (<20°C).

The sensor is pretty much un usable in this state.
7-12 01:36
Use props
jason_rmh
lvl.3
Flight distance : 2676171 ft
United Kingdom
Offline

I have been having a raft of issues with an XT2 I have hired in for a job.
The halo effect was the final issue, I was convinved the sensro was faulty.

This is a 13mm XT2 640 resolution / 30Hz suffering halo effect as others have noted, even when just sat in the office so I cannot be related to prop wash!

Today I left the XT2 mounted on the M210 with a full charged battery and just left it in the garage, hoping it will acclimatise to the environment.
it worked! However it took a long time!

After 4 hours of sitting idle (drone turned on / motors not active), auto FFC enabled, the sensor has stablised and the halo effect has cleared.
Usually, it should take no more than 40 minutes, but the longer time may be due to being in storage for so long and the change in environment.

I made a short test slight upto 40m agl, pointed the camera straight down as this is when halo is most noticeable, the issue has gone.

This generally happens more on the 13mm due to the wider FOV making it more noticeable.

As for my others issues with firmware, gimbal etc, see here for the solutions:


There are a couple of posts from FLIR on the matter also, although no real solution or advice:
https://flir.custhelp.com/app/answers/detail/a_id/3494/~/halo-or-vignetting-image-on-a-vue%2C-vue-pro%2C-vue-pro-r%2C-duo%2C-duo-pro%2C-duo-pro-r

https://flir.custhelp.com/app/answers/detail/a_id/3495/~/how-can-i-reduce-halo-effects-or-vignetting-in-my-uas-camera-images

I wish this kit would just work, but after several hours trial and erro, my XT2 is now up and running.

Hope this helps anyone else.

Thanks
Jason


7-12 05:48
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules