Please select Into the mobile phone version | Continue to access the computer ver.
No OSD displayed.
9045 9 2020-4-25
Uploading and Loding Picture ...(0/1)
o(^-^)o
djiuser_FV21VpX1VZ1d
lvl.2

United States
Offline

Before the latest update I was able to view what little Betaflight OSD there was.  After the update, my goggles don't display any BF OSD.  I'm using the newbeedrone infinity 30 FC.  I have a Matek GPS wired to it.

I have betaflight v.4.1.0  I have enabled OSD and GPS.  I am able to configure OSD on the BF screen.

In the goggles I have enabled Custom OSD.

Do you have any suggestions?
2020-4-25
Use props
fans14253033
lvl.2

Switzerland
Offline

Hi
I am using betaflight configurator 10.6.0 and sometimes I have the same issue that no betaflight osd is displayed.
I have not really a consistent case when it happens and when it doesn't.
but what I realized is that it sometimes helps to disconnect the the battery of the copter again and I keep standing close to the copter.
If this does not help I switch off all the equipment again (dji transmitter, goggles and copter) and plug in the battery of the transmitter and goggles first. then I plug the battery of the copter again and keep all the equipment close together (let's say within 1m).
But I really have no clue if it happens because the devices are too far apart from eachother.
sometimes the above procedure helps.
2020-4-25
Use props
Syko
lvl.2

United States
Offline

fans14253033 Posted at 4-25 23:32
Hi
I am using betaflight configurator 10.6.0 and sometimes I have the same issue that no betaflight osd is displayed.
I have not really a consistent case when it happens and when it doesn't.

Thanks for the reply, friend.  I have 10.6.0 as well.  I've tried what you've suggested, probably about 30 times during the past week without success.  What's horrible is I cant fly with it until I can at the very least see pitch and roll as I'm flying a helicopter.  Landing without those is too risky.    Be safe out there...
2020-4-26
Use props
Zhiran
lvl.3
Flight distance : 1061115 ft
Iraq
Offline

I had the same issue after updating to the latest version my osd was gone, but after a while, my air unit died.
2020-4-26
Use props
dungfling3rgmail.com
lvl.1
Flight distance : 309462 ft
  • >>>
United States
Offline

I have the same problem.  Prior to the update from 1.00.0200 I had lat, long, number of sats.  batt Voltage and a center reticule.  after the update they are all gone and I'm am pulling my hair out trying to get them back..
2020-4-28
Use props
DungFlinger
lvl.1
Flight distance : 309462 ft
  • >>>
United States
Offline

dungfling3rgmail.com Posted at 4-28 16:05
I have the same problem.  Prior to the update from 1.00.0200 I had lat, long, number of sats.  batt Voltage and a center reticule.  after the update they are all gone and I'm am pulling my hair out trying to get them back..

Figured out my issue.   I had to go back to FC manual and figure out what UART my grey and what was one from the air unit and then enable MSP on that port in the configurator.
2020-4-28
Use props
Syko
lvl.2

United States
Offline

DungFlinger Posted at 4-28 16:29
Figured out my issue.   I had to go back to FC manual and figure out what UART my grey and what was one from the air unit and then enable MSP on that port in the configurator.

I'll have to look into that.  Thanks!
2020-4-29
Use props
Syko
lvl.2

United States
Offline

Problem solved.  I threw out the Infinity FC and hooked up the Holybro Kakute F7 HDV.  I now enjoy OSD.  
Cheers!
2020-5-8
Use props
MattBrownson
lvl.1

Canada
Offline

Same problem with the Brainfpv Radix.. I have a Transec F7 and it works on that without fail. I tried many uarts on the Radix and I got no osd on any of them.. pulling my hair out, I tried rewiring the harness because I thought fresh wires would solve it.. nope.. sad to say, this nice flight controller is now kinda trash if I cant swap back and forth.. I recommend using a F7 flight controller that can support dji . Problem solved!
2020-8-1
Use props
thesign
lvl.2
Flight distance : 266601 ft
Puerto Rico
Offline

DungFlinger Posted at 2020-4-28 16:29
Figured out my issue.   I had to go back to FC manual and figure out what UART my grey and what was one from the air unit and then enable MSP on that port in the configurator.

turned out to be the solution to my loss of OSD as well
2021-3-27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules