Please select Into the mobile phone version | Continue to access the computer ver.
Go 4 won't install on my Motorola G5S ???
319 2 2020-4-27
Uploading and Loding Picture ...(0/1)
o(^-^)o
RCPilot
lvl.1

United Kingdom
Offline

I'm currently thinking of buying a Mavic 2 Pro but was curious if Go 4 would install and run okay on my 3 year old Motorola G5S

I load up Firefox on the G5S, navigate to Google Play and install it from there. After a while it says INSTALLED

Below that it says:


'This app is compatible with your device'


Despite this I can't see the app on my Smartphone. What am I doing wrong?

The G5S is fully up to date and is running Android 8.1.0



Incidentally, it also states 'Contains ads' - assuming I can get the ap working are the ads intrisuve or can they be disabled?


2020-4-27
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Hi RCPilot, Motorola G5S is not in the recommended list, the compatibility cannot be fully ensured. You could also download APK on the DJI website to have a try: https://www.dji.com/mavic-2/info#downloads
We hope other users who have the same phone could give you some advice, sorry for any inconvenience caused.
2020-4-28
Use props
RCPilot
lvl.1

United Kingdom
Offline

Thanks but that didn't work either.

After also looking into Fly running on the same phone (it can't) I'm extremely unimpressed with DJI's Android support. Seemingly even many relatively new Android phones (my G5S is only 3 years old) won't run your software. These issues are going to put off some buyers and make the initial investment cost higher for those that do take the plunge but who currently have an incompatible Android phone  (because they then have to buy a phone or tablet that is compatible).
2020-4-28
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules