Please select Into the mobile phone version | Continue to access the computer ver.
Wrong Firmware on P3A?
Uploading and Loding Picture ...(0/1)
o(^-^)o
ljwsteenbergen
lvl.4
Flight distance : 959783 ft
Netherlands
Offline

Last Fridy I downloaded version 1.2.8 from the DJI website and updated my copter and the RC (Did not download the release of earlier this week, so expected to need to update the RC FW as well).
Update process went well for both the Phantom and the RC.
Apart from eing prompted that there is a newer firmware in my app (latest Android version) it indicats that the FW is version 1.1.5. When (Probably) following another s/u sequence of the app/tablet and remote, the Firmware notifciation does not appear. However the app indicates I have version 1.2.6...but I honestly downloaded and installed v1.2.8.
Can someone tell me what is behind this?

By the way the FW is not that briljant, previous version was better (however no a bit less Jello)/ more stable no strange messages. Could be the combination of the newer App and at the same time the new FW, but still....
I hope DJI is working hard on the issues and will issue a new FW shortly.

(N.B. did the compass dance (outside in open field), calibrated the IMU (my aircraft was at ambient temperature) and calibrated the Gimbal)
2015-6-21
Use props
PhantomAtAK
lvl.3

United States
Offline

Are you flying a P3 Pro, or a P3 Advanced?

FW 1.2.6 is the current FW for the Professional

FW 1.2.8 is the current FW for the Advanced.

Make sure you are using the correct version for your bird, and make sure to verify the same version is on both your controller and your P3.  

Nothing wrong with re downloading the appropriate current version and re doing your update process.  Worst case you will get a message that the version you are trying to install is the same.
2015-6-21
Use props
kiwichrish
lvl.4

Offline

See my long post about the upgrade...

With the new app & firmware it occasionally reports that it needs updating, but it's fine...  Seems if the transmitter is not on and running for a while before you start the app you get that message?

Also flying a P3A, with 1.2.8 and with VPS disabled have no issues.

FYI: http://forum.dji.com/forum.php?mod=viewthread&tid=22222
2015-6-21
Use props
ljwsteenbergen
lvl.4
Flight distance : 959783 ft
Netherlands
Offline

Thanks Kiwichrish
2015-6-21
Use props
ljwsteenbergen
lvl.4
Flight distance : 959783 ft
Netherlands
Offline

PhantomAtAK Posted at 2015-6-22 05:25
Are you flying a P3 Pro, or a P3 Advanced?

FW 1.2.6 is the current FW for the Professional

I downloaded the correct version, but as you say worthwhile retrying to see what happens then.

Will try this evening.

2015-6-21
Use props
musman1978
lvl.3

United States
Offline

ljwsteenbergen@ Posted at 2015-6-22 15:03
I downloaded the correct version, but as you say worthwhile retrying to see what happens then.

W ...

DJI support suggested to reinstall DJI pilot app,
resolved issues on my side.

Br,
2015-6-22
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules