Please select Into the mobile phone version | Continue to access the computer ver.
Loss of image transmission when switching camera
311 11 3-8 14:51
Uploading and Loding Picture ...(0/1)
o(^-^)o
djiuser_n5FUXR1QIn8N
lvl.2
Flight distance : 197510 ft
United States
Offline

I have a long-out of warranty Mavic 2. I swapped the camera from a zoom camera to a pro camera. Everything is good with the camera in general, but the controller loses image transmission when I change the camera mode. The drone typically takes off in video, I click to switch the camera to still, and it loses image. This happens with the aircraft close to the controller, even testing indoors with the drone on the same desk as the controller.

Things tried so far:
- Relinking controller
- Removing SD card
- Downgrading and upgrading firmware on aircraft
- Reinstalling firmware on controller
- Checked signal reception, showing strong signal even after image transmission is dropped
- Reseating the connector cable for the camera

I don't believe it is a hardware failure as the camera works fine recording video, has taken some stills when it has survived camera switching (happens occasionally), and still allows full control of pan/tilt after lose of image transmission. Everything returns to normal after rebooting the aircraft.

I've swapped it back to the zoom camera which is behaving fine, and then back to the pro which is now working 50/50. Do I have a bad camera? Is this likely a symptom of something else? Is this a known issue for others? Intermittent loss to me says camera gimbal connection, but I've reseated the connector several times and the connector has no signs of damage or foreign debris in it – and the failure is always when switching mode in one direction or the other, never at random times.
3-8 14:51
Use props
DJI Stephen
Super Moderator

Offline

Hello there. I am sorry for the trouble this has caused and thank you for reaching out. May we know what is the model of the mobile device that you are using on your DJI Mavic 2 Pro please for us to be able to isolate the said issue? Thank you.
3-8 19:36
Use props
redbassett
lvl.2
Flight distance : 197510 ft
United States
Offline

DJI Stephen Posted at 3-8 19:36
Hello there. I am sorry for the trouble this has caused and thank you for reaching out. May we know what is the model of the mobile device that you are using on your DJI Mavic 2 Pro please for us to be able to isolate the said issue? Thank you.

Device is Pixel 2 XL or Pixel 3 XL. I've already worked with support, but after having me refresh firmware and check signal levels, the only step they could recommend was shipping the unit in for diagnostics.
3-8 23:34
Use props
djiuser_unHUu1gThFGy
lvl.1

Germany
Offline

Ist the mavic 1 pro gimbal flex cable the same on the mavic 2 pro?
3-9 02:55
Use props
redbassett
lvl.2
Flight distance : 197510 ft
United States
Offline

djiuser_unHUu1gThFGy Posted at 3-9 02:55
Ist the mavic 1 pro gimbal flex cable the same on the mavic 2 pro?

I have never used a first gen Mavic, so I do not know the specific details of the hardware, but the cameras are different from the second gen. My understanding is that the gen 1 pro camera is physically more similar to the mavic 2 zoom, as the mavic 2 pro is based around a larger sensor that was new for that model.

Regardless of the camera details, I would not expect the cable to be the same. While the first gen had a similar design of airframe and gimbal, the components are engineered differently and while the cameras in both gens use a flex cable routed along the back of the gimbal supports, I would expect the similarities to end there.
3-9 03:47
Use props
travelerbyheart
lvl.2
Flight distance : 319275 ft
Czechia
Offline

sometimes I was loosing signal out of nothing, so I disconnected the cable from my phone and connected it again ... sometime it helped, sometime I got signal for 10 seconds and had to repeat it like 10 times
3-9 08:32
Use props
redbassett
lvl.2
Flight distance : 197510 ft
United States
Offline

travelerbyheart Posted at 3-9 08:32
sometimes I was loosing signal out of nothing, so I disconnected the cable from my phone and connected it again ... sometime it helped, sometime I got signal for 10 seconds and had to repeat it like 10 times

I have checked the connection to the phone, but I don't know if I tried disconnecting and reconnecting, so I'll check that out when I get a chance. The phone still has signal from the controller, including alerts from the aircraft and the ability to start return to home, it just shows no image signal and the camera control buttons are disabled.

Now that I think of it, I think I also saw the gimbal tilt indicator going a bit crazy when this happened, jumping rapidly through various numbers, though looking at the actual aircraft the gimbal was stationary and responded to my tilt wheel inputs. I'll test further, but I do not know if this random tilt feedback would be a software behavior with the controller or a symptom of a bad camera connection.
3-9 10:01
Use props
DJI Stephen
Super Moderator

Offline

redbassett Posted at 3-8 23:34
Device is Pixel 2 XL or Pixel 3 XL. I've already worked with support, but after having me refresh firmware and check signal levels, the only step they could recommend was shipping the unit in for diagnostics.

Hi there redbassett. Thank you for the reply and for these given information. Since this issue is still happening on your DJI Mavic 2 Pro. It would be best to contact our DJI Support Team for us to be able to assess the said DJI drone and assist you with regards to this matter. Thank you.
3-10 03:35
Use props
redbassett
lvl.2
Flight distance : 197510 ft
United States
Offline

DJI Stephen Posted at 3-10 03:35
Hi there redbassett. Thank you for the reply and for these given information. Since this issue is still happening on your DJI Mavic 2 Pro. It would be best to contact our DJI Support Team for us to be able to assess the said DJI drone and assist you with regards to this matter. Thank you.

As already noted in the thread I have already spoken to support, they can't do anything but ask me to refresh firmware, check signal strength, and with those steps failing, send the drone in for assessment, which is why I am here: looking for input from people who have experienced a similar issue as to how to actually troubleshoot the problem rather than a support script.

This may be a bad camera and I may need to return it to the person who sold it to me, and I am trying to asses that before I make that call. I am not going to pay DJI full cost of the camera plus labor just to get this one fixed. Given that DJI support cannot actually connect me to a support engineer who can troubleshoot remotely, I would like to exhaust the community support option before I send the unit in for diagnosis where the answer will almost definitely be "new camera at full cost plus labor".
3-10 08:36
Use props
redbassett
lvl.2
Flight distance : 197510 ft
United States
Offline

Update with more troubleshooting: The issue only seems to occur when the drone is upside right? I've been testing switching cameras a lot. If the drone is uspide-down either on my desk or in my hand, the issue doesn't occur, but if I flip it right-side up, in almost all cases the image transmission will fail when I next try to switch the camera.

I guess there is a small chance this is a hardware problem, but it sounds much more likely to be a firmware issue? Something to do with sensor data maybe? The same aircraft with a zoom camera has no issue. The problem camera works fine besides this one issue, and I can still pan and tilt the gimbal plus I see accurate tilt data on screen after image loss.
3-10 15:19
Use props
travelerbyheart
lvl.2
Flight distance : 319275 ft
Czechia
Offline

redbassett Posted at 3-9 10:01
I have checked the connection to the phone, but I don't know if I tried disconnecting and reconnecting, so I'll check that out when I get a chance. The phone still has signal from the controller, including alerts from the aircraft and the ability to start return to home, it just shows no image signal and the camera control buttons are disabled.

Now that I think of it, I think I also saw the gimbal tilt indicator going a bit crazy when this happened, jumping rapidly through various numbers, though looking at the actual aircraft the gimbal was stationary and responded to my tilt wheel inputs. I'll test further, but I do not know if this random tilt feedback would be a software behavior with the controller or a symptom of a bad camera connection.

I was thinking It might have something to do with strong transmitters or directive antennas, but I cant confirm this yet. Once I also thought It might have something to do with lack of phone service signal, but this doesnt make any sense.
3-11 12:11
Use props
redbassett
lvl.2
Flight distance : 197510 ft
United States
Offline

travelerbyheart Posted at 3-11 12:11
I was thinking It might have something to do with strong transmitters or directive antennas, but I cant confirm this yet. Once I also thought It might have something to do with lack of phone service signal, but this doesnt make any sense.

Happens in multiple locations, all of which are very rural and far from any large transmitters. At any rate, I have sent the aircraft with camera to DJI as their support requested to have them look at the unit. Hopefully they can pinpoint an issue with the camera module that can be fixed easily.

I don't believe it is an actual transmission issue because it only occurs when switching camera modes, I can fly a good amount  with no issue, but even with the aircraft within 20ft of each other it fails instantly when I switch camera modes. An actual transmission issue due to antennas or radios would not occur at that short a range, nor would it happen reliably with switching camera modes.
The aircraft also performs as expected in the same test situations with the zoom camera module, just not this pro camera.
3-11 16:14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules