Please select Into the mobile phone version | Continue to access the computer ver.
new Ronin RS3 will not turn on a second time
2532 4 2023-3-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
chasg
lvl.2

Switzerland
Offline

Hi All,

I took delivery of my Ronin RS3 yesterday afternoon. I charged the battery, turned it on successfully, registered successfully (successful connection to app), and then turned it off.

This morning I tried to turn it on, and it will not power up. I've checked the battery charge (full), disconnected the battery for 30 minutes and reconnected, held down the power button, no joy: it will not turn on. The app does not see the gimbal either (naturally).

I was going to work with it today, and then do a test shoot tomorrow. But that's not going to happen now :-/

Can anyone help?

Chas
2023-3-11
Use props
DJI Susan
Administrator
Offline

Hi Chas, sorry to read about your issue. Just to double confirm, you were able to see the power left on the battery if you only press the power button on the battery, yet the gimbal will not be powered on if you connected the battery grip and gimbal, right?
Please check the connection pins on the gimbal and battery grip, clean them if they are dusty. If you have a different battery grip, you may also try it with the gimbal.
If it still can not be powered on, please send the gimbal back to DJI for further diagnosis and service.
If you only received it yesterday, you can start a replacement claim at https://repair.dji.com/uk/repair/replacement
Thank you for your cooperation.
2023-3-11
Use props
chasg
lvl.2

Switzerland
Offline

Hi Susan, thanks very much for your reply.

I'm afraid that I already tried all of your suggestions (battery is definitely charged, contacts are cleaned).

I visited a rental place today, and tried one of their RS3 batteries (that was confirmed working): and my gimbal would still not turn on. Sadly, I'm going to have to return it. For today's shoot, I borrowed an RS3 Mini, and it was barely adequate for the job (camera + lens too long to balance with the shorter arms of the Mini), so it's another RS3 for me! This time I hope it works, as I've had to reschedule my shoot for next week :-/
2023-3-13
Use props
SimbullSym
New

Australia
Offline

I have missed so many shots because of this issue.
As soon as I power down, to either replace camera battery, or even if its an accident cos I miss the record button and hit the power button by accident, as soon as it powers down I have serious issues getting it to function after power up again.

Some solutions I have found that aren't satisfactory are,
1. Putting the Gimbal in sleep mode and then waking it up (doesn't always work). I put to sleep either through the app or with a light tap on the power button not a long hold.
2. Turning off raven eye and unplugging it and re-connecting the cable. (also doesn't always work)
3. Powering down and leaving it for about 10-40mins and then turning it back on again

These work arounds are shooting in the dark. This is a bug that should not only be addressed in the firmware (which on my machine is the latest as of July 2023),
but aside from the email support and tech support (which is incredibly lacklustre considering the price and popularity of the machines, I paid for RS3 Pro with Raven eye),
please explain why DJI is so cagey with sharing info with solutions in these forums for people obviously suffering from a very serious problem.
Honestly these issues, especially on set, defeats the purpose of having a DJI device in the first place. Its very stressful and unprofessional on set when time is money and schedules kept are paramount.

I'm lucky enough in Melbourne to have a local DJI HQ so I'll go in and talk to a human with the hopes that it will help, but this isn't my first DJI product. From the 4k Osmo+, to the several kinds of drone and now the RS3 Pro, I have found the support to be dismally lacking. And the products to be incredibly buggy at times. In fact often very buggy.

Don't get me wrong, when it works its great. Shots w RS3 are beautiful and great for a lil cinema cam rig with no internal cam or lens stabilisation, but the bugs and the support are not very good in my experience.
2023-7-7
Use props
Devgrp
lvl.2
United States
Offline

It's like there is no quality control. I just received a brand new rs3 and it won't switch to fpv mode even though the switch position is on fpv.
2023-7-24
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules