Please select Into the mobile phone version | Continue to access the computer ver.
Battery Related to Video Signal Loss?
416 2 2015-10-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
Topviewpics
lvl.3
Flight distance : 623232 ft
United States
Offline

Hi There,
I have a P3 Pro running latest firmware. Uploade firmware on batteries but I think they still have the previous version on them (Latest firmware was meant to the copter only)


I flew for a month with this question in mind before posting it today.
This morning I flew 4 packs. With two of my battery packs I got 95% of the signal strong and reliable, was able to fly 2km rountrip with no loss of refernce or video.
With two other packs, I got video signal loss for most of the flight, in the same area, same home point. How is that possible?

I've been trying to correlate these two and if someone has experoienced the same I would love to hear a solution.
Why would the Battery pack affect the video signal?
How can I make sure my batteries have the same firmware that the ones that are working?

I am sure they are related but I cannot find a solution
Would it help to dray batteries to bare minimum and trie e full charge?

Any help would be appreciated!
Topviewpics

2015-10-11
Use props
Sling Shot
lvl.4

United States
Offline

There is really no way of telling of what update you have on the batteries. If you are in doubt update them again via your Phantom. I number all my batteries and log them with the latest firmware updates. Also with the batteries in question (through the DJI Go app) check to see if ALL cells are equal in discharge. This procedure has worked for me. Just a thought for you....
2015-10-11
Use props
Topviewpics
lvl.3
Flight distance : 623232 ft
United States
Offline

Sling Shot Posted at 2015-10-11 12:02
There is really no way of telling of what update you have on the batteries. If you are in doubt upda ...

Thanks Sling Shot.

What I was really hopping is to find a connection between a battery and the signal quality (loss of video only). It is too much coincidence that I am only getting bad signal with these two batteries, not all four.

Will double check the cells as per your advice. I also number my batteries so I am tracking which ones I get good video signal and which ones I get almost no video signal.

Cheers,
2015-10-11
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules