Please select Into the mobile phone version | Continue to access the computer ver.
RC Signal Lost after firmware update / upgrade
7762 28 2016-4-17
Uploading and Loding Picture ...(0/1)
o(^-^)o
calone76
New

Canada
Offline

Hello,

I've successfully flown yesterday morning ignoring the updates advice from DJI GO.
When back home I've performed the update using DJI GO. Turned off both P3 and RC.
When restarted I've got camera image and also red "RC SIGNAL LOST" on DJI GO. After a quick search on internet I've performed following:
- Re-Link radio with P3 (so far for 6 times)
- Deleted DJI GO from my iPad Air2 and iPhone 5S as well, re-installed them
- Downloaded latest 1.8.x P3 firmware, copied .bin file to the root of SD card and started just the P3. LED on front side of gimbal stays solid green (it does not flash red/green).
- Went this morning back to the field and re-linked P3 with RC again ... for a couple of times
- Tried to format the SD card but "command timed out"
As far as I know I cannot downgrade firmware updates.
I'm out of options and I don't know what to do. Please help!

Best Regards,
Val
2016-4-17
Use props
calone76
New

Canada
Offline

Phantom 3 Advanced
Original SD Card
iPad Air 2 16GB
iPhone 5S
Original Apple cable
2016-4-17
Use props
jhall
New

United States
Offline

Exact same problem here. All steps with the exact same result. Started to think I had really messed something up.

Ph3 Pro
2016-4-17
Use props
windbender
lvl.1
United States
Offline

Same problem here - though with a brand new Phantom 3 Standard a friend bought from B&H.  Called their Customer Support, got an RMA and a replacement was in hand within a week.   The new replacement Phantom 3 Standard did the same thing.  Had a green light on the quad and a green light on the transmitter, but once updated, "RC Signal Lost" and no matter how many times I relink them, no dice.  The DJI GO app will say "Link Complete", but the Transmitter icon shows no bars, the LED on the quad goes from blinking red to solid red and the red warning banner pops right back up.  

Very disappointing.  
2016-4-17
Use props
armelvin12
New

United States
Offline

Having the same problem currently. Is this an error in the new firmware upgrade? Very frustrating..
2016-4-17
Use props
rckclmr
lvl.1
Flight distance : 107602 ft
Canada
Offline

armelvin12 Posted at 2016-4-17 16:11
Having the same problem currently. Is this an error in the new firmware upgrade? Very frustrating..

Yeah same issue here.. Downloaded, seemed like everything went well - drove an hour to fly and couldn't link.

SAME ISSUE
2016-4-17
Use props
Patrick P
lvl.2
Flight distance : 322831 ft
  • >>>
Norway
Offline

Strange, I get "Signal Lost" on my HD downlink... The drone is controllable as usual and so are the camera and gimbal, only the HD videolink is out...The only thing is that the screen freezes and turns into B&W..
I just made a thread for this in case someone can be so kind to help me. Got A Phantom 3 Professional.
2016-4-17
Use props
rckclmr
lvl.1
Flight distance : 107602 ft
Canada
Offline

Guys I just finished getting this to work.

I had to delete everything off my SD card ( old videos you name it)
I then downloaded and unzipped the file again.
Moved it to the SD Card..
Inserted it and let it go for about 18 mins..
After the Green light on the front was Steady, i pulled it out checked the text file and thank god SUCCESS..
I powered off.

1).  Powered on the Drone
2).  Powered on the Remote
3).  Connected my iPhone 6S Plus

And no updated was required.. did  a quick 20 min flight and everything seemed to work great.

Rob
2016-4-17
Use props
rckclmr
lvl.1
Flight distance : 107602 ft
Canada
Offline

I was able to get mine to work VAL.. it took a while but had to delete everything off the SD Card.
2016-4-17
Use props
timothypugh151
lvl.2

Offline

Man I'm having exact same issue. I had EXCELLENT signal before update now I'm scared to put it in the sky I lose signal after just a few hundred feet. Very disappointing.
2016-4-17
Use props
jhall
New

United States
Offline

rckclmr Posted at 2016-4-17 18:15
Guys I just finished getting this to work.

I had to delete everything off my SD card ( old videos y ...

Is anyone having trouble with deleting the SD cards?

I have tried to format the card using the app but it comes back with sd card timeout

I tried inserting the card into my mac book pro and for some reason can put anything in the trash or format the card
2016-4-18
Use props
anandharaj
lvl.2
Flight distance : 55184 ft
Offline

I think most people got issue because they perform RC upgrade first. Below is the steps i did:

1. Power ON RC and Aircraft. Everything was normal and got notification about new firmware in DJI GO App.
2. Format the SD card (just in case)
3. Power OFF the Aircraft and RC.
4. Copy the .bin file into the SD card
5. Power ON the Aircraft (RC was not ON) and let it process the upgrade. Power OFF once upgrade complete.
6. Power ON RC and Aircraft. At this time the aircraft flash fast yellow light. I proceed to upgrade RC firmware.
7. Power OFF and Power ON the RC.  Aircraft started flash usual green light.
8. Perform IMU and Gimble calibration.
2016-4-18
Use props
0280
New

United States
Offline

Have to upgrade firmware on controller
2016-4-18
Use props
jhall
New

United States
Offline

rckclmr Posted at 2016-4-18 07:15
Guys I just finished getting this to work.

I had to delete everything off my SD card ( old videos y ...

When you insert the sd card with the bin file does the PH make the beeping sound while updating?
2016-4-18
Use props
jhall
New

United States
Offline

jhall Posted at 2016-4-18 23:42
When you insert the sd card with the bin file does the PH make the beeping sound while updating?

Sorry disregard this forgot to unzip the file. Updating now and hoping for the best
2016-4-18
Use props
alfredodiazm
lvl.1
Flight distance : 171132 ft
Venezuela
Offline

jhall Posted at 2016-4-18 11:24
Sorry disregard this forgot to unzip the file. Updating now and hoping for the best

GOT IT guys, when your unzip the bin file copy from the ZIP window. It must have 63.0 MB unzipeed.
If you clik over the BIN file and copy it to the P3 will not work.

I have try it at least 6 times with no luck have copy the bin file direct from the UNZIP window it works!!
2016-4-18
Use props
alfredodiazm
lvl.1
Flight distance : 171132 ft
Venezuela
Offline

B y sure to copy the bin file from the unzip window direct .....the bin file should have 63.0 MB if not that bin file will not work.

2016-4-18
Use props
rckclmr
lvl.1
Flight distance : 107602 ft
Canada
Offline

jhall Posted at 2016-4-18 12:42
When you insert the sd card with the bin file does the PH make the beeping sound while updating?

Sorry took so long but YES, it went through what i would call the normal process - green red light alternating and then steady green..

I pulled the SD card, and upgrade was successful, after looking at the log file.  
2016-4-19
Use props
mrokay
lvl.2
Flight distance : 2756 ft
United States
Offline

jhall Posted at 2016-4-18 07:22
Is anyone having trouble with deleting the SD cards?

I have tried to format the card using the ap ...

Yea man. I am having the same issue. I thought it was my microSD that was messed up. DJI needs to get their shits together
2016-4-19
Use props
13599
lvl.1

Indonesia
Offline

I had the same problem last night, then charge the batteries of the phone, remote and the drone to full then in the morning I deleted all the caches in the DJI GO app, did the update again and it works!
2016-4-19
Use props
lawlelievre
New

United States
Offline

I'm in the same boat. Generally ignored the update until I was "forced" to update the RC a couple days ago. Been having RC Signal Lost ever since. Will be trying clean install again, but failing that I might have to try down grading. lol
2016-4-19
Use props
mrokay
lvl.2
Flight distance : 2756 ft
United States
Offline

13599 Posted at 2016-4-20 00:43
I had the same problem last night, then charge the batteries of the phone, remote and the drone to f ...

ARE YOU using an Android or IOS device ?
2016-4-20
Use props
svsalim
lvl.1

Indonesia
Offline

mrokay Posted at 2016-4-21 06:44
ARE YOU using an Android or IOS device ?

I am using an IOS device with the latest version of the app
2016-4-20
Use props
calone76
New

Canada
Offline

rckclmr Posted at 2016-4-17 19:16
I was able to get mine to work VAL.. it took a while but had to delete everything off the SD Card.

Fixed mine too. Renamed .bin file to an upper version. Then used HexEditor to rename contents (CAREFULLY) from 1.8 to 1.9
Updated to "newest" version and everything is okay now. Flown 4 flights so far...
2016-4-25
Use props
pacemlumine
New

United States
Offline

A similar issue here, or maybe the same.
There is no video. It says "Disconnected".
The status is "aircraft upgrade failure".
It will fly, and tilt the camera, but no vid.

The P3 Pro upgrade must have been interrupted, or maybe the a/c is just broken. I don't know.

I came back and it was no longer beeping a proper pattern, but one continual beeeeeeeeeeeeeeeeeee....  

This said, if I reboot the P3 pro, it will make the proper noises, and act like it is beginning to take the firmware (1.08), then suddenly make that apparently never-ending beeeeeeeeeeeeeeee...  (no "p" on that beep because it never does finish).

I have tried the things in this topic, but it is not working to fix this problem. (did not try hex editing the FW file. )

Here is what happens exactly.

POWER ON.
1-2-3-4 start up sound
Camera light flashes green
Camera light stays green
One d---dd sound. (once - it is normal)
Camera light alternates red and green,
The D-D-D-D- sound comes. It acts like it is going to take the FW.
The camera light turns continuous red and the beeeeeeeeeeeeeeeeeee.... begins.  This can go on and on, it is really stuck.

What is quite funny is the thing can be flown in this state.  The telemetry for the also battery works but Remote says (as stated) the upgrade failed. So, it is half functional.

What must I do to fix this end of the problem?
2016-4-28
Use props
Rothgarr
lvl.3
Flight distance : 470663 ft
United States
Offline

pacemlumine@hom Posted at 2016-4-29 02:01
A similar issue here, or maybe the same.
There is no video. It says "Disconnected".
The status is " ...

I am also getting RC Signal Lost with my P3P.

I had done the firmware update right before. The controller is a foot away from the copter and yet it says high interference. Tried a number of different places in my house (all worked before the winter when I last flew). Yet I can see what the camera sees on screen.

i also tried updating my app. Where in the app can I see what firmware versions everything has? I hope i didn't brick it...

The lights on the Phantom are solid red in the back and fast blinking yellow up front. As I understand it it means it's not linked. When I go through the process to fix it says successful but it still always says RC Signal Lost.
2016-5-8
Use props
fqhoodjr
New

Offline

dji totally sucks.  never buy anything they have a hand in.  all these issues and forced upgrade and no detailed instructions.  I've spent hours and can't fly
2016-9-5
Use props
fansf99e9898
New

Mexico
Offline

Update my Phantom 3 Standard Firmware v1.08.10 and now has many errors in the flight a lot of signal from the remote control.
2017-2-15
Use props
ntxbowhunter13
lvl.2
  • >>>
United States
Offline

pacemlumine@hom Posted at 2016-4-28 10:01
A similar issue here, or maybe the same.
There is no video. It says "Disconnected".
The status is "aircraft upgrade failure".

Have this exact same problem after trying to update.  The craft seemed to have updated but no signal.  It acts as if it has the latest firmware but I get disconnected after about a minute.  It also works fine if no sd card is inserted into the gimbal.
2017-2-16
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules