Please select Into the mobile phone version | Continue to access the computer ver.
Trouble linking slave remote to master controller on inspire 1 pro
3809 4 2016-10-23
Uploading and Loding Picture ...(0/1)
o(^-^)o
info
New
United States
Offline

Ok So my inspire 1 pro is working fine. Decided I wanted to start doing the dual operator mode, so I bought a second remote on ebay. It is the GL685a remote which I presumed would work fine.
However, when I go to try and look for master remote on the new(685a) remote or even look for slave remote on the original remote(685c) remote they don't seem to find eachother. I have updated the firmware on the new remote as well as the old remote. I know the usb port is working on the new remote because it says aircraft disconnected, instead of the typical disconnected. I have tried resetting the new remote using the c1/c2/photo button but still isn't working.

Does anyone have any suggestions on what I can do to fix this?
2016-10-23
Use props
Wolfexe
lvl.2

Russia
Offline

The last firmware RC I had the same problem. I downgraded firmware to 1.6 and the problem disappeared. Try to do it.
2016-10-23
Use props
DJI Mindy
Administrator
Offline

Could you please double check your controller's firmware version?
And have you tried to re-link the master controller to aircraft?
2016-10-23
Use props
Donnie
First Officer
Flight distance : 3636782 ft
United States
Offline

I concur with Wolfexe, rollback the RC's to 1.6  then do the " find " procedure to get the communication between the Master and Slave you MUST update  bothe controllers to 1.7.  Also if you have any trouble after doing this procedure  ( If you have no communication between the Master and the Aircraft )  you may have to Re link the Master and the Aircraft, it is very simple procedure, the most important part is being able to find the RED Link button inside the white fuselage of the aircraft behind the Top Right Nosecone  silver screw, may need a flashlight .  ( The Master is the ONLY one Linked to the Aircraft by the way )  then you just go to remote control settings and begin the procedure , it is times so thata is hwy I say be sure you can find the red button.  hlod it in for about 7 seconds and then you should have a success Link.  Once again , only do this if you loose the communication from the Master and the Aircraft, it is not always necessary.  
Once up and going you must ask permisson for the slave to work , this is on the Remote control setting of the Slave .  It is easy once you do it once.  also "Caoch " mode must be enabled for that to work as well.  


One other tidbit.  The Master ONLY communicates with the Air Craft , the Slave communicates with the Master controller ONLY .  The video downlink is the only communication between the Aircraft and the  slave.   Make sure you stay in range of the Master with the Slave transmitter ( I believe it is 20 yards )  .  The Right antenna on the  Remotes does two functions  It communicates with the aircraft AND it communicates with the other Slave  transmitter .  If you take a look at the bottom of the RC transmitter you will see TWO wires at the very bottom of the antenna base ONLY on the right side.  Just a little extra info to share at dinner parties with friends...........goood times


donnie







2016-10-24
Use props
DJI-Jamie
DJI team
Flight distance : 112405 ft
United States
Offline

If you could follow Donnie and Mindy's advice it would be appreciated. If the issue persists, could you please provide either some app screenshots of your firmware versions or a small video of the problem?
2016-10-24
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules