Please select Into the mobile phone version | Continue to access the computer ver.
No Camera Image Transmission
1370 8 2017-1-6
Uploading and Loding Picture ...(0/1)
o(^-^)o
Rnfaust
Second Officer
Flight distance : 559642 ft
United States
Offline

Started up today and got the no image warning. I think it's the ribbon to the camera. I did fuss with it and the image appeared for a moment. I have received a blink out or two lately, but now she's dead Fred. I tried disconnecting the cable from the fusalage to the gimbal, but that disconnects all the gimbal controls so it's probably not that. It seems to be just the camera image. The gimbal controls work. I have noticed speckles lately in the shadowy areas of my videos. There have been no changes to software or firmware since my last sucessful flight. Same problem using Litchi. Testing was done at room temp.
Equipment summary.
P3A very reliable since 5/2015
Firmware AC and RC latest
Go app: IOS latest
Ipad mini 2

Anyone replace the ribbon cable between the camera and the gimbal module before? Any advice would be much appreciated.

2017-1-6
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

It's not recommended to change any part by yourself.
Have you tried to change another mobile device to test the transmission? It's probably a hardware issue but it worth to have a try.
I'd suggest you to send it in for further evaluation.
You can create a case by yourself via this link:https://repair.dji.com/en/SelfRepair/Area
2017-1-6
Use props
Rnfaust
Second Officer
Flight distance : 559642 ft
United States
Offline

DJI Mindy Posted at 2017-1-6 23:23
It's not recommended to change any part by yourself.
Have you tried to change another mobile device to test the transmission? It's probably a hardware issue but it worth to have a try.
I'd suggest you to send it in for further evaluation.

Hi Mindy
I took a chance and ordered the flat flexible ribbon cable to the camera and will see if it fixes the problem. I'm well out of warranty, so if it persists, I may be a new Mavic customer for you.
2017-1-10
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Rnfaust Posted at 2017-1-10 09:15
Hi Mindy
I took a chance and ordered the flat flexible ribbon cable to the camera and will see if it fixes the problem. I'm well out of warranty, so if it persists, I may be a new Mavic customer for you.

Thank you for your support. :-)
2017-1-11
Use props
Rnfaust
Second Officer
Flight distance : 559642 ft
United States
Offline

Good news!!
I just finished replacing the part #49 flat gimbal cable. Not really hard, but you will want to have watched the Youtube video a few times and have it handy. It's a 3 dimensional cable and can be a little convoluted. Since it uses adhesive in places there is no margin for error. Still, it's not hard.
Anyway that fixed it. Flight test tomorrow. I'm hoping it will also cure the sparkles I've been seeing lately in the shadowed areas of my videos also.
If anyone else has the same problem with their P3 advanced, it's Dji part #49 available from Amazon or Dji.
I'll still get a Mavic one of these days - just not now.
2017-1-11
Use props
Rnfaust
Second Officer
Flight distance : 559642 ft
United States
Offline

So the final result couldn't be better. Not only did I get the image back, but the "sparkles" (see another thread I started) are gone as well!
A case could be made that there was a connection at one of the many connections along the ribbon cable and reseating them would have restored things, but there is still a bit of disassembly involved so I chose to replace the cable. It was either a bad connection or a cracked wire.
Never worked better after 1.5 years :-)
2017-1-13
Use props
Stinky711
lvl.3
United States
Offline

Well done and handled like a professional! I'm happy for you and your Phantom!  
2017-1-13
Use props
Aardvark
Captain
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

Rnfaust Posted at 2017-1-13 13:18
So the final result couldn't be better. Not only did I get the image back, but the "sparkles" (see another thread I started) are gone as well!
A case could be made that there was a connection at one of the many connections along the ribbon cable and reseating them would have restored things, but there is still a bit of disassembly involved so I chose to replace the cable. It was either a bad connection or a cracked wire.
Never worked better after 1.5 years :-)

Well done that man, how long did it take to repair ?
2017-1-13
Use props
Rnfaust
Second Officer
Flight distance : 559642 ft
United States
Offline

Aardvark Posted at 2017-1-13 13:58
Well done that man, how long did it take to repair ?

Watch the video on camera ribbon cable replacement a few times and keep it handy. Then maybe an hour total. Only tools are a #00 phillips and a #6 torx. Tweezers or needle nose are helpful. You can try just reseating the old connections, but you will still need to remove the back of the camera and the bottom gimbal module cover. You don't need to remove the whole gimbal for that. Note that some connectors just pull out and some have release bars. It's in the video.
I'm totally satisfied.
2017-1-13
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules