Please select Into the mobile phone version | Continue to access the computer ver.
P3S Drone Won't connect to RC
945 9 2017-1-21
Uploading and Loding Picture ...(0/1)
o(^-^)o
Zediathewolf
lvl.1
United States
Offline

I got my drone a little while back, maybe a month or so- It worked perfectly fine up until i tested my 2nd battery (which is faulty still) and had the drone drop from a hover about 5-6 ft above the ground. After that my RC was the only thing connected to the dji GO app, not the cam view (it said disconnected in gray).  I could move the cam on the drone with the rc.
Now, after some fidgeting (downgrading and upgrading back) I seem to have all together disconnected the RC to the drone (cant move cam on drone, still "disconnected" in app). The link button on the drone is red. I had tried multiple times to link. I have done from app and manually (cam roll + c1/c2 switches on rc). Please help- I am going off next week (thursday) and would love if this would work. Incredibly frusturating. Thanks - Jack
2017-1-21
Use props
DanMan32
lvl.4
Flight distance : 2489501 ft
United States
Offline

"Disconnected" means the Go App is not communicating properly with the RC.   I've had difficulty with my HTC 10 connecting to the RC in December, and now that I am using a Samsung Tab E 9.7, problem seems worse.  The Go App has been updated a couple of times since December.   First time I had trouble with the tablet, turning off USB debug mode helped, but then that wouldn't work.  Besides, DJI says debug should be turned on.
What has been consistently working is restarting the tablet while connected to the RC.
I forget what the app says when it is communicating with the RC but the RC is not connected to the aircraft.  I believe it says poor signal.
2017-1-21
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Offline

Jack, sorry to hear about the issue, it seems the drone was damaged when dropping, since you have tried to do basic troubleshooting, it's still not working, the best course would be send both AC and RC in, we'll help you take care of the case.
You can submit here for a case number and apply for pickup: https://repair.dji.com/en/SelfRepair/Area
2017-1-21
Use props
Jack Chronister
lvl.1
United States
Offline

On the request for repair page what should i select for "What is the problem with your Product" question, because I dont know what is wrong with my drone. Also, is this pricey? (If it is physical damage)


2017-1-22
Use props
Jack Chronister
lvl.1
United States
Offline

I sent a shipping request- thank you for help. It must be that something got unplugged during crash )):
2017-1-22
Use props
DRONE NATION
lvl.1

United States
Offline

You have to link the drone itself to to the RC through DJI app. Once you link the RC through DJI app , it will  give you 1 mins while the sound beep, is to let you know to click on the drone red flash light undereath  the drone. hold and push  the red flash light twice to allow the beep to stop and you your RC would be connected. YOur RC must turn on and LInk wifi to Phantom while doing all that.
2017-1-22
Use props
Jack Chronister
lvl.1
United States
Offline

Drone nation I have done that multiple times, as well as manually tried to connect (switches on rc)
2017-1-22
Use props
DJI Natalia
Super Moderator
Flight distance : 318 ft

Offline

Jack Chronister Posted at 2017-1-22 08:16
I sent a shipping request- thank you for help. It must be that something got unplugged during crash )):

We will evaluate the unit firstly after it's delivered and send you an e-mail with the details.
For any other questions, please feel free to contact us again, thanks.
2017-1-22
Use props
Jack Chronister
lvl.1
United States
Offline

So- yay I got it back! It was working fine the first day I got it worked well, I didn't fly it but I paired controller etc and everything was 100%. Today I connected back to update it and I went to update, downloaded file, then swapped wifi and installed- but at 56% installed it froze and I left it for a minute but stupid of me I turned it off and turned it back on to try again, nothing different but I tried again and it stopped at 36%. I turned off again but we I turned it on it made a loud somewhat high pitch beep every second or so. I deleted everything on SD card and tried again- nothing. I heard something about formatting but idk. I am not sending it back again, and I am EXTREMELY mad about this not working.
2017-3-16
Use props
Jack Chronister
lvl.1
United States
Offline

Jack Chronister Posted at 2017-3-16 16:20
So- yay I got it back! It was working fine the first day I got it worked well, I didn't fly it but I paired controller etc and everything was 100%. Today I connected back to update it and I went to update, downloaded file, then swapped wifi and installed- but at 56% installed it froze and I left it for a minute but stupid of me I turned it off and turned it back on to try again, nothing different but I tried again and it stopped at 36%. I turned off again but we I turned it on it made a loud somewhat high pitch beep every second or so. I deleted everything on SD card and tried again- nothing. I heard something about formatting but idk. I am not sending it back again, and I am EXTREMELY mad about this not working.

Update: I posted too quickly as I just fixed problem (and had first flight .
I simply left it to do the update again. I had to put it in our other building (or a place you cant hear that incredibly annoying BEEP BEEP BEEP. Let it update (10-20~ min) and voila it stopped beeping and the drone was ok. bye!
2017-3-17
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules