Please select Into the mobile phone version | Continue to access the computer ver.
phantom 4 pro
1130 0 2017-1-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
unibond
New

United Kingdom
Offline

Hi everyone , I have just purchased a new phantom 4 pro and was feeling excited and hoping to get it in the air today. I charged it up and switched on and was prompted to do some updates.
Did a firmware update on the  drone, after it updated it told me to reconnect, after doing so the update got stuck at 99%. I just left it incase it was taking a long time but after an hour I figured it froze so I unplugged (later I read that for the P4 you have to turn the controller on for the update to finish). Now I can't connect to the drone. When my iphone is connected directly it charges but doesn't recognize the drone. When everything is powered up it only says RC connected. On the RC there is a solid pink/purple light on the Status LED. On the drone there are two flashing yellow lights on the battery side, two solid red lights on the opposite side, and a solid red light in between the micro sd slot and usb port. I even connected the drone to my Mac and successfully updated the firmware with the assistant app. Also tried reconnecting the RC via the app and after pressing okay and pressing the button in between sd slot/usb port for 2 seconds nothing happened. The pink/purple light is still there on the RC. I also tried to hold the c1-c2- rec buttons followed by rite hand wheel pressed once to force it into pairing mode it gives me the D-DD sound but no blue light just the solid pink/purple status light. It will not alow me to pair.


Any ideas please.

2017-1-28
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules