Please select Into the mobile phone version | Continue to access the computer ver.
Firmware 1.03.0400 failed from 1.03.0300
3829 19 2017-2-15
Uploading and Loding Picture ...(0/1)
o(^-^)o
TiArno
lvl.1

Switzerland
Offline

Hello ladies and gents !
I was wondering if someone here experienced the same issue.
Got my drone two days ago. Activated using RC + DJI Go Android.
Had a notification on Tuesday 14th about the new firmware. I accepted and started : RC was ok to 0400 but drone failed to update
Checking on DJI Assistant for PC, have seen that my drone was in 0300 (which is not in the standard list).
Since then i'm trying to upgrade without success : did everything from DJI Assistant on PC / MAC, or using RC. Always fails fails fails.
Seems someone on a french forum had the same issue with 0300 firmware.
Any idea ? i'm stuck with it now.
Thanks a lot
Arno
2017-2-15
Use props
Anoniem
First Officer
Flight distance : 70043 ft
Netherlands
Offline

Maybe try to lower a software version and then update to version .400?
2017-2-15
Use props
TiArno
lvl.1

Switzerland
Offline

Anoniem Posted at 2017-2-15 05:58
Maybe try to lower a software version and then update to version .400?

Thanks ;) I've tried to be back to 0200 / 0000 but same issue. I guess i've got a specific revision and it wasn't made for the 0400. I've tried so many combination that i don't see anything else
2017-2-15
Use props
Anoniem
First Officer
Flight distance : 70043 ft
Netherlands
Offline

Only thing I can think of is do the factory settings reload.. but I cannot believe this truly will solve the issue. Think its a bug....
DJI should have made documentation about this .300 version or just not release it..
Will be corrected by DJI.
Make sure to report this to DJI(can you report it with feedback function in the App.?)
2017-2-15
Use props
Flyboyz
lvl.2
Flight distance : 142615 ft
Singapore
Offline

I got my drone on 7/2 and it came with Firmware 1.03.0300. Have since upgraded to 1.03.0400 with no issue. Btw I am using iPhone for the software.
2017-2-15
Use props
TiArno
lvl.1

Switzerland
Offline

Flyboyz Posted at 2017-2-15 06:32
I got my drone on 7/2 and it came with Firmware 1.03.0300. Have since upgraded to 1.03.0400 with no issue. Btw I am using iPhone for the software.

Thanks i'll be trying this optoin as well..no iphone but..
2017-2-15
Use props
Jdwyier
lvl.3

United States
Offline

I also successfully upgraded from 1.03.0300 to 1.03.0400 on the AC so whatever it is I don't think it has anything to do with the .0300 firmware. Must be something else in play.  I used the Assistant 2 program on a Windows 10 PC with the AC connected directly to the computer via usb.  Perhaps try a different cable if you haven't already.
Alo if you haven't seen comments about it already, be aware that this is a long update and appears to hang for a long amount of time around 80% completetion but should complete normally if you just let it set. Not sure how long the process was as I didn't time it but I'd say maybe 15 minutes, perhaps a bit more when I did mine.
2017-2-15
Use props
TiArno
lvl.1

Switzerland
Offline

Hmm thanks a lot. I've already swapped cables.. everything that could be done has been tested out : several machines, PC, Mac, Phones. WIth all DJI App or Assistant on each side. Directly with AC and RC connected or one by one. Each time it's ok with RC not with AC. I mean : the cable, data connection etc must be fine in this case. If not, the RC would fail as well. I was thinking of a connector issue and swapped cable anyway. Still the same ;(
ï'm really frustrated with all this. Still can fly but ... it's brand new, one day and a half and i don't want to have such issues going on each udpate.
2017-2-15
Use props
Jdwyier
lvl.3

United States
Offline

Hope you get it sorted out. Perhaps reach out to one of the forum mods.  I assume there is an internal SD card that the new firmware gets downloaded to for installation by default. Don't know if there is a hidden trick to re-format that card in case of corruption or not, or if perhaps there is a way to load the new firmware install files onto an external card as was done with the Phantom series.
2017-2-15
Use props
dronist
Captain
  • >>>
United States
Offline

See if any if you rfriends have an IOS and try upgrading. never had an issue with any upgrades using IPHON6s +
2017-2-15
Use props
TiArno
lvl.1

France
Offline

Some news if that can help. I can now reproduce the behaviour : always stuck at 55% then reboots, once, goes on, reboots, fails
Exactly the same pattern
2017-2-15
Use props
Robi87
lvl.1

Austria
Offline

I've the same issue with my mavic.
First tried to update with the app, didn't work. On two different PCs I have the same issue. Gets to 55%, reboots and update fails.

I get the error code: undefined 0x020106

2017-2-15
Use props
TiArno
lvl.1

France
Offline

Robi87 Posted at 2017-2-15 12:59
I've the same issue with my mavic.
First tried to update with the app, didn't work. On two different PCs I have the same issue. Gets to 55%, reboots and update fails.

Hello mate !
Well just solved this issue. Exact same error, error 0x0.... stopping at 55%. To solve it i ... came home and forgot the USB cable at office. So basically i had to take another one. The one i was using were premium ones. Gold platted, insulated etc...
And finally had to go back to a stupid standard low level USB cable. Used it with DJI Assistant 2 on a mac, worked like a charm : get over 55%, 60% etc... hang at 83% or 85% for long long long minutes ;) then 99%, reboot, 100% done !
I've done it dozen of times before, and never worked so i assumed that the usb cable. Don't loose hope, it will work. I've spent 12 hours on this. 7 batteries. I went back to 0200 Firmware, then did everything. Finally got it working. One by one, Drone first, then Remote, each time the other one switched off.
Hope it helps let me know
Arno
2017-2-15
Use props
fans4ed38dd1
lvl.1

United Kingdom
Offline

Same issue here... changing cable hasn't helped

http://forum.dji.com/thread-85282-1-1.html
2017-2-16
Use props
Chewer87
lvl.1

United Kingdom
Offline

Has anyone reported this issue officially? or heard anything back from support?
2017-2-16
Use props
fans909a8d2d
lvl.1
United States
Offline

I think my Mav is bricked from trying this update. Kept failing over and over, then one time the red LEDs on the Mav kept flashing after the failure. Like it was still talking with the software. Rebooted the mav and they were still flashing, while not even plugged into the PC (was using DJI Assistant 2). I let the app try and update it again, and it looked like it worked. The mav rebooted a couple times, then eventually it said finished. Rebooted everything and now i cant connect to the controller to it, i cant read the SD card using the units USB port like i could before. Getting no response at all anymore. Tried the controller binding, but it didnt work.  
2017-2-16
Use props
briangorbett
lvl.1
United States
Offline

I have tried to update my firmware to the latest (1.03.0600) using all the methods described in the forums with no luck. I have tried at least 20 times swapping out batteries to keep the Mavic above 50%. After deleting the app on the phone and reinstalling, the update still fails every time at the same spot (hangs at 76%, jumps to 92%, then fails).
Using DJI Assistant 2 on Mac or PC, it begins updating, gets to 60%, power cycles the Mavic, then fails with error "undefined 0x020106".
I am guessing that this is going to take sending my Mavic in since I have tried just about every other method of updating.
2017-5-1
Use props
Olivier P
New
Belgium
Offline

Hello,

Do you have a solution to this problem? I meet exactly the same ..
2017-11-10
Use props
djiuser_mOLPBnamUcv4
lvl.1
Flight distance : 167267 ft

Germany
Offline

fans909a8d2d Posted at 2017-2-16 06:09
I think my Mav is bricked from trying this update. Kept failing over and over, then one time the red LEDs on the Mav kept flashing after the failure. Like it was still talking with the software. Rebooted the mav and they were still flashing, while not even plugged into the PC (was using DJI Assistant 2). I let the app try and update it again, and it looked like it worked. The mav rebooted a couple times, then eventually it said finished. Rebooted everything and now i cant connect to the controller to it, i cant read the SD card using the units USB port like i could before. Getting no response at all anymore. Tried the controller binding, but it didnt work.

У меня такая же самая проблема, не знаю как решить.
2019-3-2
Use props
djiuser_mOLPBnamUcv4
lvl.1
Flight distance : 167267 ft

Germany
Offline

fans909a8d2d Posted at 2017-2-16 06:09
I think my Mav is bricked from trying this update. Kept failing over and over, then one time the red LEDs on the Mav kept flashing after the failure. Like it was still talking with the software. Rebooted the mav and they were still flashing, while not even plugged into the PC (was using DJI Assistant 2). I let the app try and update it again, and it looked like it worked. The mav rebooted a couple times, then eventually it said finished. Rebooted everything and now i cant connect to the controller to it, i cant read the SD card using the units USB port like i could before. Getting no response at all anymore. Tried the controller binding, but it didnt work.

У меня такая же самая проблема, не знаю как решить.
2019-3-2
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules