Please select Into the mobile phone version | Continue to access the computer ver.
DJI GO app keeps crashing
738 1 2017-5-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
Colin Watts
lvl.1
Flight distance : 348087 ft
United Kingdom
Offline

I have DJI GO app for Android version 3.1.5 running on Android 7.0 on a Samsung S6 with 14GB for free storage and 1.9GB out of 3GB memory free on startup.  The app keeps crashing....  At first this was once or twice while flying with loss of recording video but now it is within minutes of opening the app and without any device connection.  Have see some reference to issues with auto rotate of the display causing problems but can not se anyway of turning this off in Android 7.0...  I use both an Inspire 1 V2 with all the latest software and an Osmo.

2017-5-8
Use props
fansedd50a8b
Second Officer
Flight distance : 1749321 ft
United States
Offline

Try this:
I have a Samsung Galaxy Note 5. Recently there was an update pushed out for the phone that apparently turned off USB debugging. It was a little convoluted turning it back on. For those of you with a Note 5 I am including the process for doing so:

      Open Settings
      Scroll down and select ‘About phone’
      Scroll down to ‘Build number’ and tap it 7 times to turn on developer mode
            (It will count down the number of remaining taps until it is turned on)
      Return to the previous screen – (I use the ?  at the top left of the screen)
      Scroll down to the options listed under System. Developer options should now be available
      Select Developer options
      Scroll down to USB debugging and move the little bubble to the right to turn it on.

At this point I am thinking ‘Sweet… it’s on… everything should work now’. Imagine my surprise when I connected everything up and had the same problem. Now I am wondering if there could there be something wrong with the USB port on my phone. I tried connecting my phone to the USB port on my Surface and, sure enough, the Surface could not see the phone either. I can’t imagine how the phone’s USB port could have broken… the phone is only a couple of months old and I don’t beat on the thing; so I decide to check out the settings again.

I opened up Settings --> Developer options and scroll past USB debugging and through the various items listed until I came across USB configuration. Under this option it was listed as ‘Charging’. I had initially thought that it meant that the phone was charging. Nope, it actually means the USB port is used for charging. Once I tapped the USB configuration additional options were displayed:

      Charging
      MTP (Media Transfer Protocol)
      PTP (Picture Transfer Protocol)
      RNDIS (USB Ethernet)
      Audio Source
      MIDI

I selected MTP (Media Transfer Protocol), reconnected everything back up to the Inspire 1 remote and presto… everything worked.

So, ultimately, my problems had nothing to do with the Inspire 1 upgrade. It was the phone update that was pushed out. Hopefully this information will help you Android folks out there from having to go through the frustration I did. One other thing to note… the option for USB configuration seems to revert back to Charging. Subsequent uses of the DJI Go app required me to go back into settings and change it to MTP (Media Transfer Protocol) again.
2017-5-8
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules