Please select Into the mobile phone version | Continue to access the computer ver.
OTG not working on spark
12Next >
22239 71 2017-7-27
Uploading and Loding Picture ...(0/1)
o(^-^)o
Spatterfree
lvl.1
Flight distance : 126781 ft
United States
Offline

Hi,
finally received my OTG cable, plugged it into my ipad mini 2 and Spark controller but nothing happens, still have to use WIFI to connect to the Spark, anybody know what i can
do to enable it? i am runnnig the latest firmaware. just updated it today.
thanks,

2017-7-27
Use props
Lian82
Second Officer
Flight distance : 626768 ft
Italy
Offline

Before changing Wi-Fi in 2.4ghz then while AC reboots Wi-Fi ... you turn off the smartphone Wi-Fi and enter oTG in the rc and then on the smartphone.
2017-7-27
Use props
Spatterfree
lvl.1
Flight distance : 126781 ft
United States
Offline

so i need to change it to 2.4ghz?
2017-7-27
Use props
Lian82
Second Officer
Flight distance : 626768 ft
Italy
Offline

YesI use 2.4ghz because in Italy the 5.8ghz sucks.. try to see if it works with the 5.8ghz I see that you (lucky) live in America.
2017-7-27
Use props
Sliderul
lvl.3
Flight distance : 501942 ft
United States
Offline

I found the order of connection really makes a difference. If I turn on the RC and the media device then attach the OTG cable; first to the media device, then to the RC, being certain that the OTG adapter or cable end is attached to the RC, I get a connection between the device and the RC. I'm using a Samsung phone and shut down wireless altogether since the OTC connection seems to work so much better.
2017-7-27
Use props
Spatterfree
lvl.1
Flight distance : 126781 ft
United States
Offline

I got it to work once, but this iPad is exclusively to fly the spark, always connected. Do I have to go through that process every time?
2017-7-27
Use props
fans9ff6d142
lvl.4
Flight distance : 64865 ft
United States
Offline

Plug in the lightning connector first before you insert the micro USB side. It matter which order, I couldn't get mine to work unless I plug in micro USB last.
2017-7-27
Use props
Spatterfree
lvl.1
Flight distance : 126781 ft
United States
Offline

wow, thats almost not worth it, disappointed. between every battery i have to unplug the RC and iPad in order to get it connected again.
also i put it in 2.4ghz and that really put my range down. worked much better in 5.8
2017-7-27
Use props
TexasAerials
First Officer
Flight distance : 566952 ft
United States
Offline

it works, just plug it in to phone first, then the remote last.  I went through all my batteries today connected with OTG, and the video came back on after the spark rebooted again each time no problem.  
2017-7-27
Use props
Kent360
lvl.4
Greece
Offline

Hi Spatterfree bit of advice please I am going to order a flymore and want to order OTG cable. Is there any particular spec cable I need? (phone is samsung s6)... or just any otg?
2017-7-27
Use props
Spatterfree
lvl.1
Flight distance : 126781 ft
United States
Offline

Hi Kent,
i had a lightning to microUSB for my iPad, that part worked, but i had to unplug at the controller after each battery to get it connected. also it switched my signal to 2.4ghz which brought my range down to less then half.
2017-7-28
Use props
Aerial Ant
Second Officer
Flight distance : 1249711 ft
United States
Offline

Sliderul Posted at 2017-7-27 12:07
I found the order of connection really makes a difference. If I turn on the RC and the media device then attach the OTG cable; first to the media device, then to the RC, being certain that the OTG adapter or cable end is attached to the RC, I get a connection between the device and the RC. I'm using a Samsung phone and shut down wireless altogether since the OTC connection seems to work so much better.

Bingo! The sequence is the key because at first I thought I had a faulty cable.  Also, my OTG cable works only one way there's a "host" end that goes in the r/c and if its backwards it won't work either. BTW I have iphone and I use a lightning adapter with micro to micro cable.
2017-7-29
Use props
Magius
lvl.2
Singapore
Offline

Sliderul Posted at 2017-7-27 12:07
I found the order of connection really makes a difference. If I turn on the RC and the media device then attach the OTG cable; first to the media device, then to the RC, being certain that the OTG adapter or cable end is attached to the RC, I get a connection between the device and the RC. I'm using a Samsung phone and shut down wireless altogether since the OTC connection seems to work so much better.

If i connect the OTG to the mobile phone end it doesnt work. If I connect the OTG to rc it works.

2017-7-29
Use props
fans909d0edb
lvl.2
Flight distance : 19465 ft
United States
Offline

what is best brand and length for Android OTG cable. I was hoping for a fairly short micro to micro USB OTG cable. What is everyone using?
2017-7-29
Use props
Aerial Ant
Second Officer
Flight distance : 1249711 ft
United States
Offline

fans909d0edb Posted at 2017-7-29 12:58
what is best brand and length for Android OTG cable. I was hoping for a fairly short micro to micro USB OTG cable. What is everyone using?

Try Amazon, many sellers have some of the exact same products with various prices. You can get 1' or 8" cables (I use 1' for phone and tablet use), longer or shorter, OEM or non-OEM cables, different colors, shapes or stronger braided cables. Its personal choice mostly.
2017-7-30
Use props
ecf_08
lvl.2
United States
Offline

Aerial Ant Posted at 2017-7-29 07:22
Bingo! The sequence is the key because at first I thought I had a faulty cable.  Also, my OTG cable works only one way there's a "host" end that goes in the r/c and if its backwards it won't work either. BTW I have iphone and I use a lightning adapter with micro to micro cable.

Thanks. I simulated it many times and this is the key. I summarized for everyone.

1) Power On Spark
2) Power On RC
3) Connect OTG to Smartphone first then to RC
4) Start DJI Go App 4
5) Go Fly Appears
2017-8-6
Use props
ecf_08
lvl.2
United States
Offline

ecf_08 Posted at 2017-8-6 15:10
Thanks. I simulated it many times and this is the key. I summarized for everyone.

1) Power On Spark

just to add. Smartphone already in airplane mode in step 3. Sometimes a message appears asking you to use this USB accessory by default by this App. Just choose Yes
2017-8-6
Use props
PascalG
lvl.4
Flight distance : 214455 ft
United States
Offline

As someone Mentioned earlier sequence is important. Connect the lightning cable to otg first, and then connect the otg to controller last. Don't start dji go app till after you get the accessory not supported message
2017-8-6
Use props
Bradders
Second Officer
Flight distance : 862283 ft
United Kingdom
Offline

This cable works perfectly for me http://amzn.to/2vFDS6n
2017-8-6
Use props
ecf_08
lvl.2
United States
Offline

PascalG Posted at 2017-8-6 17:46
As someone Mentioned earlier sequence is important. Connect the lightning cable to otg first, and then connect the otg to controller last. Don't start dji go app till after you get the accessory not supported message

No. for me the DJI app can be started already or not it would not matter...
2017-8-7
Use props
ImHereToCrash
Captain
Flight distance : 5014068 ft
  • >>>
United States
Offline

there is a delay between when phone/tablet will sync to RC via OTG.. i usually pair my spark to RC first.. then i connect my ipad turn off wifi on ipad, and BT... i say wait 30 seconds from sync time till plugging -in in total after syncing RC to spark..    as for direction, RC is the host, so OTG must be RC side.. as for which to plug in first, it's just a cable being repinned mostly so doesn't matter which side goes in first as long as host is RC side..

as for shortened range on 2.4Ghz or 5.8Ghz i have seen both scenarios..depends on location, enviroment and if nature is against you.   if you dont want to fuss around trying to pick the best signal, then once everything is synced up with OTG and wifi and bluetooth is on on the tablet/phone, hold button on back of the spark (on the battery) till it beeps once, let go it should change flashing patterns its now hunting for new signals, on the RC press Pause + FN + C1 and hold it for a couple of seconds after starts rapidly beeping at you (2-3 seconds AFTER it begins beeping rapidly at you), then let it go.. the RC will beep rapidly until the two reconnect on the "best" signal  then in the app you should see a clear picture with little to no lag.  if bad quality or laggy (like half second or more) redo linking process again.

2017-8-7
Use props
ZSAY
lvl.2
Flight distance : 7785 ft
Saudi Arabia
Offline

ImHereToCrash Posted at 2017-8-7 20:05
there is a delay between when phone/tablet will sync to RC via OTG.. i usually pair my spark to RC first.. then i connect my ipad turn off wifi on ipad, and BT... i say wait 30 seconds from sync time till plugging -in in total after syncing RC to spark..    as for direction, RC is the host, so OTG must be RC side.. as for which to plug in first, it's just a cable being repinned mostly so doesn't matter which side goes in first as long as host is RC side..

as for shortened range on 2.4Ghz or 5.8Ghz i have seen both scenarios..depends on location, enviroment and if nature is against you.   if you dont want to fuss around trying to pick the best signal, then once everything is synced up with OTG and wifi and bluetooth is on on the tablet/phone, hold button on back of the spark (on the battery) till it beeps once, let go it should change flashing patterns its now hunting for new signals, on the RC press Pause + FN + C1 and hold it for a couple of seconds after starts rapidly beeping at you (2-3 seconds AFTER it begins beeping rapidly at you), then let it go.. the RC will beep rapidly until the two reconnect on the "best" signal  then in the app you should see a clear picture with little to no lag.  if bad quality or laggy (like half second or more) redo linking process again.

Hi ImHereToCrash, you state in your first paragraph "turn OFF Wifi on iPad and BT."
But then you state later in second paragraph "then once everything is synced up with OTG and wifi and bluetooth is ON on the tablet/phone, hold button on back of the spark,,,,"
I'm confused, you turn back ON Wifi and BT again??
2017-8-14
Use props
Bobesh
lvl.4
Flight distance : 270840 ft
Czechia
Offline

OTG is disabled on iOS devices from the new firmware. From some reports, DJI is working on official support of OTG.
2017-8-14
Use props
KeltikCanuk
lvl.2
Flight distance : 52562 ft
Canada
Offline

Spatterfree Posted at 2017-7-27 12:42
wow, thats almost not worth it, disappointed. between every battery i have to unplug the RC and iPad in order to get it connected again.
also i put it in 2.4ghz and that really put my range down. worked much better in 5.8

You shouldn't have to disconnect /reconnect OTG when changing batteries. If you follow the connection sequence listed here (RC connection last), you'll be fine through all your battery changes.
2017-8-14
Use props
wobbles
Captain
Flight distance : 545023 ft
  • >>>
United Kingdom
Offline

i found this very helpful
2017-8-14
Use props
fansbc0b98b2
lvl.1
France
Offline

Sliderul Posted at 2017-7-27 12:07
I found the order of connection really makes a difference. If I turn on the RC and the media device then attach the OTG cable; first to the media device, then to the RC, being certain that the OTG adapter or cable end is attached to the RC, I get a connection between the device and the RC. I'm using a Samsung phone and shut down wireless altogether since the OTC connection seems to work so much better.

Hi
I have the Samsung A5 2016 but OTG connection is acting weirdly. like if the phone was trying to charge itself, beeping 2 times every second. Any idea ?
2017-8-19
Use props
Bradders
Second Officer
Flight distance : 862283 ft
United Kingdom
Offline

I heard that someone said that the OTG Cables are being cancelled with the new controller update, I have not flown my spark for a while but if so then this will be the only thing that would work most likely, http://amzn.to/2vRFlDL
2017-8-19
Use props
fansbc0b98b2
lvl.1
France
Offline

Bradders Posted at 2017-8-19 04:06
I heard that someone said that the OTG Cables are being cancelled with the new controller update, I have not flown my spark for a while but if so then this will be the only thing that would work most likely, http://amzn.to/2vRFlDL

thanks, I got the 2 of these and they do not work :

https://www.amazon.fr/gp/product ... 0?ie=UTF8&psc=1
https://www.amazon.fr/gp/product ... 0?ie=UTF8&psc=1
2017-8-19
Use props
realstreetuk
Second Officer
Flight distance : 7966 ft
  • >>>
United Kingdom
Offline

Bradders Posted at 2017-8-19 04:06
I heard that someone said that the OTG Cables are being cancelled with the new controller update, I have not flown my spark for a while but if so then this will be the only thing that would work most likely, http://amzn.to/2vRFlDL

I hope this is not the case, as i only can get to use 2.4 using the OTG method.
2017-8-19
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
Australia
Online

Bobesh Posted at 2017-8-14 00:59
OTG is disabled on iOS devices from the new firmware. From some reports, DJI is working on official support of OTG.

Haven't been able to get my ipad mini 4 connected with the OTG, so this must be the reason
2017-8-19
Use props
Bobesh
lvl.4
Flight distance : 270840 ft
Czechia
Offline

lannes Posted at 2017-8-19 05:44
Haven't been able to get my ipad mini 4 connected with the OTG, so this must be the reason

It usually is when someone from DJI says it is disabled on iOS
2017-8-19
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
United Kingdom
Online

Bobesh Posted at 2017-8-19 12:21
It usually is when someone from DJI says it is disabled on iOS

Managed to get OTG on the ipad mini 4 working, just had to follow this sequence, which a slight difference to what was previously listed

1) Ipad on and turn wi-fi off
2) RC on
3) Spark on
4) Wait until RC is connected to Spark (green light on RC)
5) Run DJI GO 4  and Connect OTG to RC









2017-8-20
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
United Kingdom
Online

fansbc0b98b2 Posted at 2017-8-19 04:13
thanks, I got the 2 of these and they do not work :

https://www.amazon.fr/gp/product/B072N2SN5R/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

maybe it's the sequence of turning on the RC, DJI Go 4 and the AC
2017-8-20
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
United Kingdom
Online

realstreetuk Posted at 2017-8-19 05:36
I hope this is not the case, as i only can get to use 2.4 using the OTG method.

With the ipad mini and OTG, I am getting only 2.4
With the WI-FI connection between the ipad mini and the RC, I get the 5.8 option as well



2017-8-20
Use props
IFrumble-Spark
lvl.1
Netherlands
Offline

I have no issues with IPhone 6. Works perfect. I'm still little scared having the spark flying far (>150 meters) away from me. As well between mountains (200 meter wide crack) it's response really funny.
2017-8-20
Use props
Bobesh
lvl.4
Flight distance : 270840 ft
Czechia
Offline

lannes Posted at 2017-8-20 06:23
Managed to get OTG on the ipad mini 4 working, just had to follow this sequence, which a slight difference to what was previously listed

1) Ipad on and turn wi-fi off

Interesting
2017-8-22
Use props
phatav8r60
lvl.2
United States
Offline

Bobesh Posted at 2017-8-14 00:59
OTG is disabled on iOS devices from the new firmware. From some reports, DJI is working on official support of OTG.

not true, I have flown many number of flights in OTG since the update
2017-8-22
Use props
Joelling
Second Officer
Flight distance : 76539 ft
Thailand
Offline

Despite following the connection sequence, I have noticed that certain usb cables work but not others. But I am still unable to find out the cause of this.

I am using a Samsung S7 btw
2017-8-28
Use props
Kladhams
lvl.1
Flight distance : 5020 ft
United Kingdom
Offline

HI all, I have been trying for a few days now to connect via OTG. I have tried all the different connection methods mentioned above but nothing. I have tried to different android phones, one micro usb (Sony Xperia Z3) and one with type-c (Oneplus 3T) but neither work. The moment wifi is off I get a grey screen and disconnected appears. I really need to find a way around this as I want to have data on (or a way of connecting to the internet) as I live in a Authorisation zone and can't get authorised without connecting to the internet and doing it 24 hours in advanced on a PC is slow.
2017-9-1
Use props
freeflightflyin
New
Flight distance : 7930 ft
United Kingdom
Offline

UPDATE:

I was also having issues with connecting my phone to the remote. I have found the solution to be by using the otg cable in the remote rather than phone side. I know this has been mentioned before but I didn't quite understand what it meant till now. For anyone else having any similar issues (think I posted mine above). Try switching the otg cable around!
2017-9-1
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules